cloudy cloudy

Author Topic: WD Respecting 10-min average speed option for WU Rapid Fire  (Read 719 times)

0 Members and 1 Guest are viewing this topic.

Offline Spiderj

  • Posts: 18
  • OS/Browser:
  • Win NT 10.0
  • Chrome 76.0.3809.100
WD Respecting 10-min average speed option for WU Rapid Fire
« on: August 10, 2019, 04:16:30 PM »
Hi.
In my country, we usually use 10-minute speed averages to measure the average wind speed, and although WD can do this if you tick Calculate 10-min average in units settings, the WU rapid fire values still seem to use the default average value (is it the Davis 2 minutes value? seems to vary so quickly compared to tests I've done in for example Cumulus, station is a Davis Vantage Vue).

Would it be possible to make the rapid fire data sends respect this preference? The regular 5 minute sends seem to respect this but not Rapid Fire.

Thanks in advance.

Offline Weather Display

  • Posts: 87,244
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 76.0.3809.100
    • Weather Display
Re: WD Respecting 10-min average speed option for WU Rapid Fire
« Reply #1 on: August 10, 2019, 09:26:40 PM »
I guess I could add that option
but the whole idea of rapid fire data is to see the latest , fast updating, weather data
and only having the 10 minute average speed takes away from that

Offline Spiderj

  • Posts: 18
  • OS/Browser:
  • Win NT 10.0
  • Chrome 76.0.3809.100
Re: WD Respecting 10-min average speed option for WU Rapid Fire
« Reply #2 on: August 10, 2019, 11:00:15 PM »
Indeed, I do understand your point. The thing is, Rapidfire does already seem to send WD's default average anyway...

Example: https://i.imgur.com/BKin1iq.png

That first value is the same as the current WD "Average" and not the latest Davis value shown in "Current".
« Last Edit: August 10, 2019, 11:11:11 PM by Spiderj »

Offline Weather Display

  • Posts: 87,244
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 76.0.3809.100
    • Weather Display
Re: WD Respecting 10-min average speed option for WU Rapid Fire
« Reply #3 on: August 11, 2019, 06:28:30 PM »
yes, the protocol for the WU rapid fire states that the averaging period is determined by the software
WD calculates a rolling average speed from the station
but I could add this option...to send 10 minute average speed (updated every minute?)

Offline Spiderj

  • Posts: 18
  • OS/Browser:
  • Win NT 10.0
  • Chrome 76.0.3809.100
Re: WD Respecting 10-min average speed option for WU Rapid Fire
« Reply #4 on: August 13, 2019, 12:49:15 PM »
Hi Brian.
Yes that seems fine, would at least give some flexibility to the users who prefer 10 min averages logged instead of the rolling average if they want to be WMO-compliant, for example.

Offline Weather Display

  • Posts: 87,244
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 76.0.3809.100
    • Weather Display
Re: WD Respecting 10-min average speed option for WU Rapid Fire
« Reply #5 on: August 13, 2019, 10:09:37 PM »

Offline Spiderj

  • Posts: 18
  • OS/Browser:
  • Win NT 10.0
  • Chrome 76.0.3809.100
Re: WD Respecting 10-min average speed option for WU Rapid Fire
« Reply #6 on: August 15, 2019, 11:56:34 AM »
Hello.
Yes, seems to be working fine, other than a very minor issue of the new checkbox not being remembered when you go into the wunderground settings again after setting it. Thank you.

Offline Weather Display

  • Posts: 87,244
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 76.0.3809.100
    • Weather Display
Re: WD Respecting 10-min average speed option for WU Rapid Fire
« Reply #7 on: August 15, 2019, 08:58:55 PM »
ops, my bad
download again, same url, to fix that setting not sticking

 

cumulus