cloudy cloudy

Author Topic: HWS-template (WD34) July version available  (Read 22784 times)

0 Members and 2 Guests are viewing this topic.

Offline bitsostring

  • Posts: 1,038
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.102
    • Home Weather Station
Re: HWS-template (WD34) July version available
« Reply #240 on: August 17, 2019, 01:58:51 PM »
Obviously tested too much versions at the same time  :oops:

 :)

But now you have switched your demo to the 12-hour clock (see attached) I think there might be too much space between time and am/pm; and an unnecessary space after the date numerals (17). IMHO. . .
« Last Edit: August 17, 2019, 02:01:24 PM by bitsostring »
It's meant to be fun. . .

Offline Bjørn

  • Posts: 334
  • Ulsteinvik, Norway
  • OS/Browser:
  • Win NT 10.0
  • Chrome 76.0.3809.100
    • Ulsteinvikweather
Re: HWS-template (WD34) July version available
« Reply #241 on: August 17, 2019, 03:04:40 PM »
Hi.

I have just installed this latest template and it looks greate :-)

But how to speed up the live update of wind and wind direction data ??

I use lateste WD and its API to upload the text file needed every 5 sec, but still the site is updating like strait after installation, default aprox every 30 sec on the web site ???

The site: https://www.ulsteinvikweather.com/pws/

Any help is apreasiated :-)

Bjørn
« Last Edit: August 17, 2019, 03:06:42 PM by Bjørn »

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,421
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 76.0.3809.100
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34) July version available
« Reply #242 on: August 17, 2019, 04:19:52 PM »
Hi.
I have just installed this latest template and it looks greate :-)
But how to speed up the live update of wind and wind direction data ??
I use lateste WD and its API to upload the text file needed every 5 sec, but still the site is updating like strait after installation, default aprox every 30 sec on the web site ???
The site: https://www.ulsteinvikweather.com/pws/
Any help is apreasiated :-)
Bjørn
Be aware that most providers do not allow the very frequent execution of PHP scripts, that is why the times are set this way.

All individual blocks  have their own refresh times.
You can adapt those times in w34_blocks.php   The wind-block has a default of 40 seconds.

Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline weatherbee

  • Posts: 726
  • Sherman, Ct.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Sherman Ct. Weather
Re: HWS-template (WD34) July version available
« Reply #243 on: August 17, 2019, 04:28:37 PM »
Wim,
For some unknown reason my WxSim forecast is in Dutch (I think).
Seen at https://www.shermanctweather.org/pwsWD/index.php
Not sure why.
Tom
Sony Pentium 4, 1.6 GHZ,512 MB Ram, Windows XP Pro, SP2


Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,421
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 76.0.3809.100
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34) July version available
« Reply #244 on: August 17, 2019, 04:34:49 PM »
Wim,
For some unknown reason my WxSim forecast is in Dutch (I think).
Seen at https://www.shermanctweather.org/pwsWD/index.php
Not sure why.
Tom
The scripts are using the plaintext files from wxsim.
And Ken True's plaintext parser.
Check the settings in the pwsWD/wxsimPP/plaintext-parser.php script.

https://www.shermanctweather.org/pwsWD/wxsimPP/plaintext-parser.php   returns a dutch forecast so there must be a setting in the script to do that.
Change line 134 to your language,
Code: [Select]
$lang = 'nl';                             // default language is 'en' = English
Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline blainec

  • Posts: 442
  • Calgary, Ab.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 68.0
    • Weather YYC
Re: HWS-template (WD34) July version available
« Reply #245 on: August 17, 2019, 06:22:09 PM »
Just noticed a problem in current conditions block: there is a point (full stop) after the windspeed units in "This hour" Wind-Gust forecast. Suggest deleting the point in w34_util_ccn.php - the last line shown here:

Code: [Select]
echo '</span> '.$windunit.PHP_EOL;
# rain
if (isset ($hourlyPrecipProb) )
     {  echo '.<br />';

Apologies: I have modified my file so I can't give line numbers, but I think it will be obvious.

I believe it is line#141

Offline Bjørn

  • Posts: 334
  • Ulsteinvik, Norway
  • OS/Browser:
  • Win NT 10.0
  • Chrome 76.0.3809.100
    • Ulsteinvikweather
Re: HWS-template (WD34) July version available
« Reply #246 on: August 17, 2019, 06:40:07 PM »
Be aware that most providers do not allow the very frequent execution of PHP scripts, that is why the times are set this way.

All individual blocks  have their own refresh times.
You can adapt those times in w34_blocks.php   The wind-block has a default of 40 seconds.

Wim

Thanks Wim, you made my weekend perfect :-)  :D

Offline bitsostring

  • Posts: 1,038
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.102
    • Home Weather Station
Re: HWS-template (WD34) July version available
« Reply #247 on: August 17, 2019, 06:52:01 PM »
I believe it is line#141

It is in my script, but I am not using the latest version. . .  :)

It is line 138 in the latest version, which puts back the UV estimate in front of rain, but correcting it might affect something else further down?

Code: [Select]
138 $break = '.<br />';

EDIT: Having looked at it again, I think it's OK to delete the point in the latest version too.
« Last Edit: August 18, 2019, 03:58:18 PM by bitsostring »
It's meant to be fun. . .

Offline blainec

  • Posts: 442
  • Calgary, Ab.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 68.0
    • Weather YYC
Re: HWS-template (WD34) July version available
« Reply #248 on: August 17, 2019, 07:00:50 PM »
It is in my script, but I am not using the latest version. . .  :)

It is line 138 in the latest version, which puts back the UV estimate in front of rain, but correcting it might affect something else further down?

Code: [Select]
138 $break = '.<br />';
This is the version date mine has:
$scrpt_vrsn_dt  = 'w34_util_ccn.php|00|2019-04-25|';   #icons w34

Offline bitsostring

  • Posts: 1,038
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.102
    • Home Weather Station
Re: HWS-template (WD34) July version available
« Reply #249 on: August 17, 2019, 07:07:40 PM »
This is the version date mine has:
$scrpt_vrsn_dt  = 'w34_util_ccn.php|00|2019-04-25|';   #icons w34

And me. . . but latest version is

$scrpt_vrsn_dt  = 'w34_util_ccn.php|00|2019-06-29|';   # added UV | icons w34

See https://www.weather-watch.com/smf/index.php/topic,68132.msg547965.html#msg547965
« Last Edit: August 17, 2019, 07:09:42 PM by bitsostring »
It's meant to be fun. . .

Offline blainec

  • Posts: 442
  • Calgary, Ab.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 68.0
    • Weather YYC

Offline meteolive57

  • Posts: 20
  • OS/Browser:
  • Win NT 10.0
  • Firefox 68.0
Re: HWS-template (WD34) July version available
« Reply #251 on: August 18, 2019, 01:13:42 PM »
hello
i uploaded the latest version of the template
http://valdefench57sgz.franceserv.com/pwsWD/index.php
live data running with the WL 2.0 API
for graphs, my setup parameterized with WU
on the other hand the monthly charts are "out" and the annual ones are all stopped at 25; 07.2019 ??
Regards

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,421
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 76.0.3809.100
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34) July version available
« Reply #252 on: August 18, 2019, 02:59:59 PM »
hello
i uploaded the latest version of the template
http://valdefench57sgz.franceserv.com/pwsWD/index.php
live data running with the WL 2.0 API
for graphs, my setup parameterized with WU
on the other hand the monthly charts are "out" and the annual ones are all stopped at 25; 07.2019 ??
Regards

That is a severe problem with WU.  They are working on it, maybe they solve it or they kill it altogether.

Most stations have intermittent gaps in the .CSV downloads as they often contain partial data only. Your yearly data is only available until July 25.
https://www.wunderground.com/weatherstation/WXDailyHistory.asp?ID=ILORRAIN49&graphspan=year&year&format=1
Yout "this month" data is  empty file https://www.wunderground.com/weatherstation/WXDailyHistory.asp?ID=ILORRAIN49&graphspan=month&year&month&format=1

Your other weather-websites are affected also, example  => July 25
http://valdefench57sgz.franceserv.com/realtime/weather28/index.php?p=wsReports&lang=en&wp=MB#data-area

There are dozens of discussions about all WU problems at the WX-forum, most important one: https://www.wxforum.net/index.php?topic=37137.0

WIM


Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline ms372591

  • Posts: 12
  • OS/Browser:
  • Win NT 10.0
  • Chrome 76.0.3809.100
Re: HWS-template (WD34) July version available
« Reply #253 on: August 18, 2019, 11:46:45 PM »
Yes, the error apparently only applies to some WU sites.
Your problem seems to be quite like mine.

I have not received a response from WU. I probably didn't expect that either  :x But on their forum they write

"Hi, Ul Ke!

This is a problem we know about and have in the queue to address.  I hope you will be patient with us while the programmers work. 

Thank you!

--Victoria"


How long to be patient?

Have you heard anything from WU? Nothing has changed on my site.

Offline blainec

  • Posts: 442
  • Calgary, Ab.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 68.0
    • Weather YYC
Re: HWS-template (WD34) July version available
« Reply #254 on: August 19, 2019, 02:39:23 AM »
Have you heard anything from WU? Nothing has changed on my site.
I had a problem like this about 1 year ago. They never responded to my requests and about 3 months later, it was fixed