cloudy cloudy

Author Topic: HWS-template (WD34) beta test July version  (Read 1559 times)

griffo42 and 1 Guest are viewing this topic.

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,191
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
HWS-template (WD34) beta test July version
« on: June 05, 2019, 08:23:15 AM »
http://wd34.weather-template.com/beta.php

Offline blainec

  • Global Moderator
  • Posts: 404
  • Calgary, Ab.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
    • Weather YYC
Re: HWS-template (WD34) beta test July version
« Reply #1 on: June 05, 2019, 03:02:24 PM »
I just installed this.
I am wanting to get UV data from darksky, but UV/Solar block is not showing that data.

https://weatheryyc.com/pws

Offline weatherbee

  • Posts: 708
  • Sherman, Ct.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Sherman Ct. Weather
Re: HWS-template (WD34) beta test July version
« Reply #2 on: June 05, 2019, 03:05:41 PM »
Sony Pentium 4, 1.6 GHZ,512 MB Ram, Windows XP Pro, SP2


Offline blainec

  • Global Moderator
  • Posts: 404
  • Calgary, Ab.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
    • Weather YYC
Re: HWS-template (WD34) beta test July version
« Reply #3 on: June 05, 2019, 03:24:48 PM »
On a few blocks I am seeing the time/date displayed incorrectly.
Time is wrong and date is included.
After 3 refreshes the time displays correctly

https://weatheryyc.com/pws
« Last Edit: June 05, 2019, 03:27:07 PM by blainec »

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,191
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34) beta test July version
« Reply #4 on: June 05, 2019, 03:53:13 PM »
I just installed this.
I am wanting to get UV data from darksky, but UV/Solar block is not showing that data.

https://weatheryyc.com/pws
It seems that the setting is incorrect.
Did you copy the settings from another version?
Or did you set them from scratch?

Wim

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,191
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34) beta test July version
« Reply #5 on: June 05, 2019, 04:06:40 PM »
On a few blocks I am seeing the time/date displayed incorrectly.
Time is wrong and date is included.
After 3 refreshes the time displays correctly

https://weatheryyc.com/pws
Thank you!
That is an error caused by wxsim script.
Will look into that tomorrow.

=== :oops:
In the moon-block an old error returned. Attached a better version for the west of greenwich countries. 

Wim


Offline blainec

  • Global Moderator
  • Posts: 404
  • Calgary, Ab.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
    • Weather YYC
Re: HWS-template (WD34) beta test July version
« Reply #6 on: June 05, 2019, 04:09:00 PM »
I think the date/time issue is related to firefox. I tested with chrome, it it works fine

Offline blainec

  • Global Moderator
  • Posts: 404
  • Calgary, Ab.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
    • Weather YYC
Re: HWS-template (WD34) beta test July version
« Reply #7 on: June 05, 2019, 04:13:12 PM »
It seems that the setting is incorrect.
Did you copy the settings from another version?
Or did you set them from scratch?

Wim
Ooops. sorry, I missed that one  :oops:

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,191
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34) beta test July version
« Reply #8 on: June 05, 2019, 04:19:10 PM »
On a few blocks I am seeing the time/date displayed incorrectly.
Time is wrong and date is included.
After 3 refreshes the time displays correctly

https://weatheryyc.com/pws
New version of the wxsim script attached
Wim

Offline blainec

  • Global Moderator
  • Posts: 404
  • Calgary, Ab.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
    • Weather YYC
Re: HWS-template (WD34) beta test July version
« Reply #9 on: June 05, 2019, 04:25:40 PM »
New version of the wxsim script attached
Wim

It appears to have fixed the problem.

Thank you

Offline BfdWx

  • Posts: 1,607
  • Branford Connecticut
  • OS/Browser:
  • Mac OS X 10.14.5
  • Chrome 74.0.3729.169
    • Southern CT Weather
Re: HWS-template (WD34) beta test July version
« Reply #10 on: June 06, 2019, 02:35:48 PM »
It appears that my max/min wind gust is not working in the small display on top. 12:58 has not come yet today :)

http://southernctwx.com/WX/index.php

Just started working.......disregard!
« Last Edit: June 06, 2019, 03:08:16 PM by BfdWx »

Offline mldenison

  • Posts: 292
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 74.0.3729.169
    • York, Pennsylvania USA Weather
Re: HWS-template (WD34) beta test July version
« Reply #11 on: June 06, 2019, 03:05:39 PM »
The current conditions block has a line of untranslated text - to English:


Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,191
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34) beta test July version
« Reply #12 on: June 06, 2019, 03:29:59 PM »
The current conditions block has a line of untranslated text - to English:
Is this your HWS site: http://www.m82a1.us/pwsWD/ ?
Check the setting for the language of the DarkSky forecast. You can have that set to a different, often more local, language.
It is set to Dutch (Netherlands), should be your English.

http://www.m82a1.us/pwsWD/_test.php?test=forecastDSdaily_popup.php

===

If the language is set correctly the cached file is still valid for about an hour.
Then the next load of the Darksky forecast will remove the dutch file.

Wim

@ALL  Please always post the URL to the site. Especially if you have multiple versions
« Last Edit: June 06, 2019, 03:34:18 PM by wvdkuil »

Offline mldenison

  • Posts: 292
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 74.0.3729.169
    • York, Pennsylvania USA Weather
Re: HWS-template (WD34) beta test July version
« Reply #13 on: June 06, 2019, 05:03:56 PM »
Sorry, Wim.  That's the April version.

Here's the July version: https://www.m82a1.us/pwstestWD/index.php

Even though I didn't think I was using DarkSky, after I entered the API, the language translation worked.

Also, when using the Google Chrome browser, the menu link in the header doesn't show.  It's fine on the April version.  And it works fine in my Pale Moon browser.

Thanks

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,191
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34) beta test July version
« Reply #14 on: June 07, 2019, 08:41:33 AM »
. . . shortened . . .
Even though I didn't think I was using DarkSky, after I entered the API, the language translation worked.
. . . shortened ...
The current conditions block displays also a one-hour "forecast". And WD does not supply that info.
Quote
Also, when using the Google Chrome browser, the menu link in the header doesn't show.  It's fine on the April version.  And it works fine in my Pale Moon browser.
Thanks
I could not replicate that problem with my Chrome browser. See attached screenshot
===
In some browsers your webcam image is not shown as the link http://182.168.1.65:82/?_1559896445 should be https also.
Code: [Select]
Mixed Content: The page at 'https://www.m82a1.us/pwstestWD/index.php' was loaded over HTTPS,
but requested an insecure image 'http://182.168.1.65:82/?_1559896445'.
This content should also be served over HTTPS.
Wim
« Last Edit: June 07, 2019, 08:45:51 AM by wvdkuil »