cloudy cloudy

Author Topic: OpenWeatherMap upload problem  (Read 479 times)

0 Members and 1 Guest are viewing this topic.

Offline CaptKirk

  • Posts: 106
  • WeatherHawk 240 SS
  • Šibenik, Croatia
  • OS/Browser:
  • Win NT 10.0
  • Chrome 74.0.3729.48
    • Sibenik - Krvavice
OpenWeatherMap upload problem
« on: April 11, 2019, 06:10:51 PM »
Hi. I registered my pws on OpenWeatherMap using Postman software, and it is ok. Problem is what I cannnot transfer my data over weather dipslay. I think that is problem in station ID. Where i need to enter station ID in weather display software applet? Thanks.

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 73.0.3683.86
    • Weather Display
Re: OpenWeatherMap upload problem
« Reply #1 on: April 11, 2019, 07:54:15 PM »
OK, I can add where you can set the stationID that you have already

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 73.0.3683.86
    • Weather Display
Re: OpenWeatherMap upload problem
« Reply #2 on: April 11, 2019, 08:20:28 PM »
i have added that now
to the latest .zip update

there is a file
openweathersendresult.txt
which should have the result code from the data send

Offline CaptKirk

  • Posts: 106
  • WeatherHawk 240 SS
  • Šibenik, Croatia
  • OS/Browser:
  • Win NT 10.0
  • Chrome 74.0.3729.48
    • Sibenik - Krvavice
Re: OpenWeatherMap upload problem
« Reply #3 on: April 11, 2019, 09:33:23 PM »
Sorry. It does not working. I can not see file openweathersendresult.txt

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 73.0.3683.86
    • Weather Display
Re: OpenWeatherMap upload problem
« Reply #4 on: April 11, 2019, 09:36:12 PM »
when you say not working, how do you mean exactly?

Offline CaptKirk

  • Posts: 106
  • WeatherHawk 240 SS
  • Šibenik, Croatia
  • OS/Browser:
  • Win NT 10.0
  • Chrome 74.0.3729.48
    • Sibenik - Krvavice
« Last Edit: April 11, 2019, 09:50:20 PM by CaptKirk »

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 73.0.3683.86
    • Weather Display
Re: OpenWeatherMap upload problem
« Reply #6 on: April 11, 2019, 09:59:12 PM »
what shows in the openweathersendresult.txt file
where WD is installed
(make sure you are using the latest .zip update of WD which has a new cronopenweathermap.exe version which produces that file)
also there is a openweathermapaggregatedata.txt file

Offline CaptKirk

  • Posts: 106
  • WeatherHawk 240 SS
  • Šibenik, Croatia
  • OS/Browser:
  • Win NT 10.0
  • Chrome 74.0.3729.48
    • Sibenik - Krvavice
Re: OpenWeatherMap upload problem
« Reply #7 on: April 11, 2019, 10:12:10 PM »
I can not see "openweathersendresult.txt" nowhere... :( I have last zip update.

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 73.0.3683.86
    • Weather Display
Re: OpenWeatherMap upload problem
« Reply #8 on: April 11, 2019, 10:34:06 PM »
to make sure you have the latest update
download
http://www.weather-display.com/downloadfiles/cronopenweathermap.zip
and then check the modified date/time on that .exe file (and let me know)

Offline CaptKirk

  • Posts: 106
  • WeatherHawk 240 SS
  • Šibenik, Croatia
  • OS/Browser:
  • Win NT 10.0
  • Chrome 74.0.3729.48
    • Sibenik - Krvavice
Re: OpenWeatherMap upload problem
« Reply #9 on: April 11, 2019, 10:53:25 PM »
I have the same file in my wdisplay folder, modified 11. april ‎2019., ‏‎22:01:07

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 73.0.3683.86
    • Weather Display
Re: OpenWeatherMap upload problem
« Reply #10 on: April 11, 2019, 11:04:18 PM »

Offline CaptKirk

  • Posts: 106
  • WeatherHawk 240 SS
  • Šibenik, Croatia
  • OS/Browser:
  • Win NT 10.0
  • Chrome 74.0.3729.48
    • Sibenik - Krvavice
Re: OpenWeatherMap upload problem
« Reply #11 on: April 11, 2019, 11:40:56 PM »
Not working again, but now I see this two files. See below

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 73.0.3683.86
    • Weather Display
Re: OpenWeatherMap upload problem
« Reply #12 on: April 12, 2019, 12:37:17 AM »
 the result code is 415
instead of 202
and that is the problem

Offline CaptKirk

  • Posts: 106
  • WeatherHawk 240 SS
  • Šibenik, Croatia
  • OS/Browser:
  • Win NT 10.0
  • Chrome 74.0.3729.48
    • Sibenik - Krvavice
Re: OpenWeatherMap upload problem
« Reply #13 on: April 12, 2019, 12:42:23 AM »
Why did I get a mistake? I entered the correct data. Is the windows xp problem possibly?
« Last Edit: April 12, 2019, 12:46:09 AM by CaptKirk »

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 73.0.3683.86
    • Weather Display
Re: OpenWeatherMap upload problem
« Reply #14 on: April 12, 2019, 01:01:48 AM »
no
I do not know why
the first data send after a station is auto registered (i.e you have no stationID entered or set)
returns 202
but the second data send, using the stationid that was generated the first time and saved, then returns 415
I do not know why
if the stationid is allowed to be kept on being auto created then the data send using that stationid works (202 code) but the problem is then you just end up with multiple station ID's