cloudy cloudy

Author Topic: HWS-template (WD34 ) April release  (Read 8452 times)

0 Members and 1 Guest are viewing this topic.

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
Re: HWS-template (WD34 / weather34) April release
« Reply #150 on: June 09, 2019, 12:39:47 PM »
The database only has 1 table with todays measurements, just to calculate at the end of the day the min-max values for that day.
The result.csv file contains the data for todays graphs.

Your result.csv file contains data for multiple days. So the daily graphs displays all that data.

The two cron-jobs should add 1 line to the month and year .CSV files and clean the result.csv
So it seems that the two cron-jobs did not work as they should.

I run the add-to-year cron in testmode:
http://www.rrogers.us/pws/_test.php?test=w34_cron_addtoyear.php
And it adds 1 line to both month and year file.
Running http://www.rrogers.us/pws/_test.php?test=w34_cron_empty.php clears the daily data correctly
Conclusion:  running the jobs from the browser => no problem.

Now carefully check the cron-settings for the two midnight cron-jobs.
Then tomorrow morning (or after 24:00 this night) check if the daily file contains only that new days data
And that the month and year files have that extra line with todays min/max data.

Wim

Wim,

The cron jobs ran last night, but it appears one of them may not have worked as desired from the info I received via email after it was run.

For the job: w34_cron_addtoyear.php, this is the response I got back from the web server: Couldn not write headers to chartsmysql/2019_06.csv

For the job: w34_cron_empty.php, this is the response I got back from the web server: success 1-2

So, it appears they both ran.

Now I also looked at the data from the result.csv and there is no data recorded before 0100, so it appears the table is missing an hour's worth of data.  Would this be normal??  I also looked at the other two tables and it appears the data contained within are exactly the same.

Rick

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,357
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34 / weather34) April release
« Reply #151 on: June 09, 2019, 12:57:34 PM »
Wim,

The cron jobs ran last night, but it appears one of them may not have worked as desired from the info I received via email after it was run.

For the job: w34_cron_addtoyear.php, this is the response I got back from the web server: Couldn not write headers to chartsmysql/2019_06.csv

For the job: w34_cron_empty.php, this is the response I got back from the web server: success 1-2

So, it appears they both ran.

Now I also looked at the data from the result.csv and there is no data recorded before 0100, so it appears the table is missing an hour's worth of data.  Would this be normal??  I also looked at the other two tables and it appears the data contained within are exactly the same.

Rick
The one hour difference can occur because of Daylight savings time. Maybe the cron does not use that?
All cron-servers are different, difficult to check for me. Ask with your webhoster.

Also it is possible that you scheduled the w34_cron_empty one hour off. check the cron settings. It should run at 00:05  not at 01:05.

The two other files still contain test data from yesterday.
But also the correct line from the cron-job.
Code: [Select]
2019-06-08 23:55:02,81.0,69.0,69.00,64.00,0.00,26.0,21.0,0.00,29.86,29.81,0,From now on the yearly file will get one  line per day until Dec 31.
The month file 2019_06.csv also during june. In July there will be a new file. 2019_07.csv created.

So lets check tomorrow.

Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
Re: HWS-template (WD34 / weather34) April release
« Reply #152 on: June 09, 2019, 01:24:31 PM »
The one hour difference can occur because of Daylight savings time. Maybe the cron does not use that?
All cron-servers are different, difficult to check for me. Ask with your webhoster.

Also it is possible that you scheduled the w34_cron_empty one hour off. check the cron settings. It should run at 00:05  not at 01:05.

The two other files still contain test data from yesterday.
But also the correct line from the cron-job.
Code: [Select]
2019-06-08 23:55:02,81.0,69.0,69.00,64.00,0.00,26.0,21.0,0.00,29.86,29.81,0,From now on the yearly file will get one  line per day until Dec 31.
The month file 2019_06.csv also during june. In July there will be a new file. 2019_07.csv created.

So lets check tomorrow.

Wim

Okay, I have the cron jobs scheduled at 2358 and the other is scheduled to run at 0000.  Should I change it to 0005?

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
Re: HWS-template (WD34 / weather34) April release
« Reply #153 on: June 09, 2019, 01:41:53 PM »
I just checked with my hosting company tech support and they stated the cron server does recognize daylight savings.

I also adjusted the time of the cron job to clear the table to 0005.

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
Re: HWS-template (WD34 / weather34) April release
« Reply #154 on: June 10, 2019, 04:36:35 PM »
The one hour difference can occur because of Daylight savings time. Maybe the cron does not use that?
All cron-servers are different, difficult to check for me. Ask with your webhoster.

Also it is possible that you scheduled the w34_cron_empty one hour off. check the cron settings. It should run at 00:05  not at 01:05.

The two other files still contain test data from yesterday.
But also the correct line from the cron-job.
Code: [Select]
2019-06-08 23:55:02,81.0,69.0,69.00,64.00,0.00,26.0,21.0,0.00,29.86,29.81,0,From now on the yearly file will get one  line per day until Dec 31.
The month file 2019_06.csv also during june. In July there will be a new file. 2019_07.csv created.

So lets check tomorrow.

Wim

Wim,

I checked this morning and it appears both cron jobs ran again last night, but what I didn't notice yesterday that I noticed today...is they both ran an hour late, both Saturday night and last night.  Instead of running at 2358 and 0005 as scheduled, they ran at 0058 and 0105.  That would explain why there was no data between 0000 and 0100, because it was cleared out at 0100 (the original time was set at 0000 to clear the table, but apparently ran an hour later).

In an attempt to correct this, today I changed the scheduled times to 2258 and 2305.  I will check again tomorrow morning.  If my theory is true and for whatever reason the jobs run an hour later than scheduled, they should run at the time I am desiring.  :)

Another question which might be a setting I missed.  When looking at the forecast, in the pop up window it shows the temp in C versus F.  Is this a conversion issue in the coding or did I miss a setting?  See the image below.

Then one more thing I noticed, at the top of the page in the Annual block it shows 16.7 inches of rain for the year and 0.0 inches of rain for June.  Then at the bottom of the page in the Rainfall today block 16.69 inches of rain for 2019 and 0.01 inches of rain for June.  I assumed the difference for rain total for the year was the figure in the annual block had been rounded up, but in the Rainfall today block, if one were to add the rainfall for June to the yearly total you would come with the same result.  Any ideas??

Thanks again for everything.

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,357
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34 / weather34) April release
« Reply #155 on: June 10, 2019, 05:03:06 PM »
Wim,
. . . shortened . . .
Another question which might be a setting I missed.  When looking at the forecast, in the pop up window it shows the temp in C versus F.  Is this a conversion issue in the coding or did I miss a setting?  See the image below.
The text-line in the top is not converted.
Check your easyweather-settings.  Probably you selected for DarkSky to use metric units. The scripts will translate all units to the desired ones. But not the text-forecasts.
Quote
Then one more thing I noticed, at the top of the page in the Annual block it shows 16.7 inches of rain for the year and 0.0 inches of rain for June.  Then at the bottom of the page in the Rainfall today block 16.69 inches of rain for 2019 and 0.01 inches of rain for June.  I assumed the difference for rain total for the year was the figure in the annual block had been rounded up, but in the Rainfall today block, if one were to add the rainfall for June to the yearly total you would come with the same result.  Any ideas??
That is a coincidence. The values are rounded.  In the July release the number of decimals are correct for inches also in the small block
Check http://wd34.weather-template.com/pws07/index.php?units=us
Quote
Thanks again for everything.
No thanks, best regards, wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline Tlowe

  • Posts: 157
  • Minneapolis, MN, US
  • OS/Browser:
  • Win NT 10.0
  • Chrome 74.0.3729.169
Re: HWS-template (WD34 / weather34) April release
« Reply #156 on: June 11, 2019, 03:26:25 AM »
Just an FYI.

I have had successful WU downloads with an APi key 24/7 for 3 days.

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
Re: HWS-template (WD34 / weather34) April release
« Reply #157 on: June 11, 2019, 04:46:42 PM »
The text-line in the top is not converted.
Check your easyweather-settings.  Probably you selected for DarkSky to use metric units. The scripts will translate all units to the desired ones. But not the text-forecasts.That is a coincidence. The values are rounded.  In the July release the number of decimals are correct for inches also in the small block
Check http://wd34.weather-template.com/pws07/index.php?units=usNo thanks, best regards, wim

Wim,

Yeah, it was a setting for DarkSky, I was using SI for units versus the US, I did it quick and thought I had picked the right one.  After it downloaded the updated information from DarkSky it was displaying the correct units.

This morning I checked and the cron jobs ran at the correct time.  I don't know if the data in the tables has the correct times though when I looked at them early this morning shortly after the jobs ran.

Otherwise, the web page seems to be displaying most of the data correctly.  I'm not sure the windows for the month or yearly graphs are correct, but this may have more to do with not enough data in the tables.

Rick

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
Re: HWS-template (WD34 / weather34) April release
« Reply #158 on: June 12, 2019, 03:29:31 AM »
Hello, I've come across another part on my web page that I don't have set correctly and need help setting it up correctly.  At the top of the page on the right is a block which displays Weather Alert (see pic below).  When I saw this I thought it is a great addition to the page.  My problem is it isn't displaying the alerts for my area.  I think it is displaying the default information. 

In the EasyWeatherSetup for weatheralarm I chose USA use NWS, for the alarm_area I put in the S.A.M.E. (Specific Area Messaging Encoding) code for my area from the NWS.  I'm not sure if that was correct or not.

Is there something else I am supposed to do??

Thanks in advance,
Rick

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,357
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34 / weather34) April release
« Reply #159 on: June 12, 2019, 06:37:04 AM »
Hello, I've come across another part on my web page that I don't have set correctly and need help setting it up correctly.  At the top of the page on the right is a block which displays Weather Alert (see pic below).  When I saw this I thought it is a great addition to the page.  My problem is it isn't displaying the alerts for my area.  I think it is displaying the default information. 
In the EasyWeatherSetup for weatheralarm I chose USA use NWS, for the alarm_area I put in the S.A.M.E. (Specific Area Messaging Encoding) code for my area from the NWS.  I'm not sure if that was correct or not.

Is there something else I am supposed to do??
Thanks in advance,Rick

The Curly NWS-alrert scripts are exactly the same, without any customisation,  as the distribution by Ken True, who is maintaining those legacy scripts.
Instructions: http://www.rrogers.us/pws/nws-alerts-142/NWS-alerts_read_me.html

Normally there is also a menu entry which leads to http://www.rrogers.us/pws/w34_start_frame.php?frame=weatheralarms
There you can check which areas you are using.

Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
Re: HWS-template (WD34 / weather34) April release
« Reply #160 on: June 13, 2019, 11:56:32 AM »
We finally got some rain yesterday, yeah!!!  Something I noticed this morning is in the rainfall today box, on the left side it shows 0 in of rain for yesterday, yet we received 0.52 inches as the total raised by that amount.

Has this already been addressed??

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,357
  • Leuven Belgium CET
  • OS/Browser:
  • iOS 12.3.1
  • Safari 12.1.1
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34 / weather34) April release
« Reply #161 on: June 13, 2019, 12:02:22 PM »
We finally got some rain yesterday, yeah!!!  Something I noticed this morning is in the rainfall today box, on the left side it shows 0 in of rain for yesterday, yet we received 0.52 inches as the total raised by that amount.
Has this already been addressed??
What is the problem exactly? What is wrong, what should the different  amounts be?

Both your "weather34/Ken True"  version and "my" version show exactly the same amounts.

Wim
« Last Edit: June 13, 2019, 12:20:48 PM by wvdkuil »
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
Re: HWS-template (WD34 / weather34) April release
« Reply #162 on: June 13, 2019, 12:39:40 PM »
What is the problem exactly? What is wrong, what should the different  amounts be?

Both your "weather34/Ken True"  version and "my" version show exactly the same amounts.

Wim

In the pic attached to my post I circled what I'm talking about.  I'm assuming where it says yesterday is supposed to show the amount of rain received yesterday.  It shows "0" or is this supposed to be showing what the rain rate yesterday was??

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,357
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34 / weather34) April release
« Reply #163 on: June 13, 2019, 01:49:04 PM »
In the pic attached to my post I circled what I'm talking about.  I'm assuming where it says yesterday is supposed to show the amount of rain received yesterday.  It shows "0" or is this supposed to be showing what the rain rate yesterday was??
It should show the total amount of rain of yesterday. Same amount as in your Cumulus program was recorded yesterday.
https://cumuluswiki.wxforum.net/a/Realtime.txt
Code: [Select]
22 yesterday's rainfall <#rfallY>As both dashboards show the same value, why do you think there was another amount of rain?
They use the same realtime.txt but the different scripts show the same values. So no script error.

There are no other values to check. Do you have more values or screenshots?

Wim
« Last Edit: June 13, 2019, 01:53:35 PM by wvdkuil »
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
Re: HWS-template (WD34 / weather34) April release
« Reply #164 on: June 13, 2019, 02:06:27 PM »
It should show the total amount of rain of yesterday. Same amount as in your Cumulus program was recorded yesterday.
https://cumuluswiki.wxforum.net/a/Realtime.txt
Code: [Select]
22 yesterday's rainfall <#rfallY>As both dashboards show the same value, why do you think there was another amount of rain?
They use the same realtime.txt but the different scripts show the same values. So no script error.

There are no other values to check. Do you have more values or screenshots?

Wim

Please see the picture below.  It is a screen shot of the data taken from the result.csv table, which shows exactly what I previously stated.  I knew the amount because I was watching it during the storm, but the data in the table confirms it.

Thanks,
Rick

 

cumulus