cloudy cloudy

Author Topic: HWS-template (WD34 ) April release  (Read 8447 times)

0 Members and 1 Guest are viewing this topic.

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,357
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34 / weather34) April release
« Reply #135 on: June 05, 2019, 10:03:00 AM »
Doh! sorry.  Site is at https://weather.nolatron.net/   

So currently the only 2 issues I'm having are:

1) The pushing of data from WD to the WDapi.txt file.

I have a picture of my Weather34 setup attached, and I have the Main Internet Switch turned on. If I press the Test/Update button in the Home Weather Station API menu, I get a success message and the file updates. Everything looks good.   But then it never updates again on it's own.  So I'm not sure if I'm missing some other setting in WD that's needed to push data or something else.

2) The Darksky forecast doesn't seem to be showing any rain values even though their site is showing rain chances in the coming days.

Thanks!
With the WDapi not functioning is strange and i can not assist you with that.
The Darksky forecast has been changed a few times during the last months.
Check this post https://www.weather-watch.com/smf/index.php/topic,67862.msg545919.html#msg545919

===

Also there is a new beta version you could test, it should have removed a lot of errors.
http://wd34.weather-template.com/beta.php

Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline ms372591

  • Posts: 12
  • OS/Browser:
  • Win NT 10.0
  • Chrome 75.0.3770.66
Re: HWS-template (WD34 / weather34) April release
« Reply #136 on: June 05, 2019, 11:51:46 AM »
My site is https://pendulous-here.000webhostapp.com/pwsWD/?units=us and I was wondering why under the rain block almanac section my numbers are always N/A for year, month, and last hour. I'm currently using Weatherunderground data and the month and year to date charts have data.

Thanks!

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,357
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34 / weather34) April release
« Reply #137 on: June 05, 2019, 11:58:35 AM »
My site is https://pendulous-here.000webhostapp.com/pwsWD/?units=us and I was wondering why under the rain block almanac section my numbers are always N/A for year, month, and last hour. I'm currently using Weatherunderground data and the month and year to date charts have data.

Thanks!
Because WU does not supply that data. And the WU version was available as a first test in the April release.
When you check the current beta version using WU-data at https://www.weerstation-herent.be/pws07/
and compare it with f.i. this Weathercat version at http://wd34.weather-template.com/pws07/
you will see that the blocks adapt to the available data.

Just a few weeks and the July version is ready.

Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline pricey

  • Posts: 191
  • Llanelli Wales United Kingdom
  • OS/Browser:
  • iOS 12.3
  • Safari 0.8.2
    • Llanelli Weather
Re: HWS-template (WD34 / weather34) April release
« Reply #138 on: June 08, 2019, 12:39:11 PM »
Hello Wim.
Not sure if this is the correct place to post but I am using the original build of the software. Noticed that in the almanac section of the rainfall area, the figure showing in the last hour rainfall always shows the current running total for the day.
Donít know if it has been fixed with the April build.
By the way love the July build. If it has been fixed I will wait until the July build is not in beta then update.

http://www.llanelliweather.co.uk/

Cheers Steve.

Offline bitsostring

  • Posts: 991
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: HWS-template (WD34 / weather34) April release
« Reply #139 on: June 08, 2019, 01:25:12 PM »
the figure showing in the last hour rainfall always shows the current running total for the day.
Donít know if it has been fixed with the April build.

There were a number of new downloads for the original release in January, did you get all these? The final one is here, to correct rain last hour in  w34_livedata.php, but I think there was a new rainfall_block download just before that. . . I'm still running the original (with clientraw) and rain last hour works for me  :)

EDIT: latest rainfall_block download actually here. This was only to add some units, but it should have the latest "rain last hour" - as long as you also have the livedata changes! (File rainfall_block.php should be dated 27/01/19, w34_livedata.php 22/01/19.)

Only problem that still remains in the original release is that "rain last hour" shows negative "rain yesterday" at midnight reset.
« Last Edit: June 09, 2019, 10:13:17 AM by bitsostring »
It's meant to be fun. . .

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,357
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34 / weather34) April release
« Reply #140 on: June 08, 2019, 01:33:12 PM »
Hello Wim.
Not sure if this is the correct place to post but I am using the original build of the software. Noticed that in the almanac section of the rainfall area, the figure showing in the last hour rainfall always shows the current running total for the day.
Donít know if it has been fixed with the April build.
By the way love the July build. If it has been fixed I will wait until the July build is not in beta then update.

http://www.llanelliweather.co.uk/

Cheers Steve.
For debugging, please always give the real link to the HWS-template, in your case http://www.llanelliweather.co.uk/pwsWD/index.php

And yes, the values seem correct now. But as I do not have an operational WD-version, I rely on others to test.
Thanks to them that error was removed.  =D>

Wim


Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
Re: HWS-template (WD34 / weather34) April release
« Reply #141 on: June 08, 2019, 04:13:38 PM »
Hello from the Mid-West in the US. I am using this template and like it a lot.  I've been muddling my way around trying to get everything to work correctly.  The address to my site is: www.rrogers.us/pws   I am using the database on my web site to store the data, which I believe to be just the daily data if I am understanding everything correctly.

The issue I'm having is when looking at the graph displays for weather, barometer, etc. the information is not correct, see below.

I don't know if this is something I have set incorrectly or what. I have checked the data in the database and from the created csv file and the data is correct, but isn't the same as what is showing up on the graphs.

The data is being sent from my weather station directly to my web site.  I have the web site running the cron jobs, the stationcron every 5 minutes and the other two at the prescribed scheduled time.

Suggestions or ideas would be appreciated.

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,357
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34 / weather34) April release
« Reply #142 on: June 08, 2019, 04:36:18 PM »
Hello from the Mid-West in the US. I am using this template and like it a lot.  I've been muddling my way around trying to get everything to work correctly.  The address to my site is: www.rrogers.us/pws   I am using the database on my web site to store the data, which I believe to be just the daily data if I am understanding everything correctly.

The issue I'm having is when looking at the graph displays for weather, barometer, etc. the information is not correct, see below.

I don't know if this is something I have set incorrectly or what. I have checked the data in the database and from the created csv file and the data is correct, but isn't the same as what is showing up on the graphs.

The data is being sent from my weather station directly to my web site.  I have the web site running the cron jobs, the stationcron every 5 minutes and the other two at the prescribed scheduled time.

Suggestions or ideas would be appreciated.
The database only has 1 table with todays measurements, just to calculate at the end of the day the min-max values for that day.
The result.csv file contains the data for todays graphs.

Your result.csv file contains data for multiple days. So the daily graphs displays all that data.

The two cron-jobs should add 1 line to the month and year .CSV files and clean the result.csv
So it seems that the two cron-jobs did not work as they should.

I run the add-to-year cron in testmode:
http://www.rrogers.us/pws/_test.php?test=w34_cron_addtoyear.php
And it adds 1 line to both month and year file.
Running http://www.rrogers.us/pws/_test.php?test=w34_cron_empty.php clears the daily data correctly
Conclusion:  running the jobs from the browser => no problem.

Now carefully check the cron-settings for the two midnight cron-jobs.
Then tomorrow morning (or after 24:00 this night) check if the daily file contains only that new days data
And that the month and year files have that extra line with todays min/max data.

Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
Re: HWS-template (WD34 / weather34) April release
« Reply #143 on: June 08, 2019, 06:31:09 PM »
The database only has 1 table with todays measurements, just to calculate at the end of the day the min-max values for that day.
The result.csv file contains the data for todays graphs.

Your result.csv file contains data for multiple days. So the daily graphs displays all that data.

The two cron-jobs should add 1 line to the month and year .CSV files and clean the result.csv
So it seems that the two cron-jobs did not work as they should.

I run the add-to-year cron in testmode:
http://www.rrogers.us/pws/_test.php?test=w34_cron_addtoyear.php
And it adds 1 line to both month and year file.
Running http://www.rrogers.us/pws/_test.php?test=w34_cron_empty.php clears the daily data correctly
Conclusion:  running the jobs from the browser => no problem.

Now carefully check the cron-settings for the two midnight cron-jobs.
Then tomorrow morning (or after 24:00 this night) check if the daily file contains only that new days data
And that the month and year files have that extra line with todays min/max data.

Wim

The above makes sense.  I will check the cron jobs on my web server and set it up so that it emails me when these jobs run.

But...it still doesn't explain why the temp graph shows my temp at 176 degrees F just after noon today.  I mean it is warm outside with the humidity and all, but if the temp was really that high...  LOL  The actual temp was in the mid to upper 70s F.  The graph for the wind also shows us having gusts in excess of 55 mph, which we are not having and the barometer is less that 1....something like 0.81.

Thoughts??

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
Re: HWS-template (WD34 / weather34) April release
« Reply #144 on: June 08, 2019, 06:43:18 PM »
The database only has 1 table with todays measurements, just to calculate at the end of the day the min-max values for that day.
The result.csv file contains the data for todays graphs.

Your result.csv file contains data for multiple days. So the daily graphs displays all that data.

The two cron-jobs should add 1 line to the month and year .CSV files and clean the result.csv
So it seems that the two cron-jobs did not work as they should.

I run the add-to-year cron in testmode:
http://www.rrogers.us/pws/_test.php?test=w34_cron_addtoyear.php
And it adds 1 line to both month and year file.
Running http://www.rrogers.us/pws/_test.php?test=w34_cron_empty.php clears the daily data correctly
Conclusion:  running the jobs from the browser => no problem.

Now carefully check the cron-settings for the two midnight cron-jobs.
Then tomorrow morning (or after 24:00 this night) check if the daily file contains only that new days data
And that the month and year files have that extra line with todays min/max data.

Wim

Another question about the result.csv file, when I look at the date...it is incorrect, see below.

It shows today's date as 6-Aug.  I thought maybe this was the formatting in Excel so I tried changing the formatting, but it kept the month and day the same.  If one were to use the number for each, the day and the month, the data would show 6-08, which would correspond to today's date, June 8th, but when opened the file using notepad+ so I could see the data, it shows the date as 06 Aug.  What am I missing??

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,357
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34 / weather34) April release
« Reply #145 on: June 08, 2019, 08:03:17 PM »
Another question about the result.csv file, when I look at the date...it is incorrect, see below.

It shows today's date as 6-Aug.  I thought maybe this was the formatting in Excel so I tried changing the formatting, but it kept the month and day the same.  If one were to use the number for each, the day and the month, the data would show 6-08, which would correspond to today's date, June 8th, but when opened the file using notepad+ so I could see the data, it shows the date as 06 Aug.  What am I missing??
Another conversion problem, but it has no effect for the graphs.

Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,357
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34 / weather34) April release
« Reply #146 on: June 08, 2019, 08:11:54 PM »
The above makes sense.  I will check the cron jobs on my web server and set it up so that it emails me when these jobs run.

But...it still doesn't explain why the temp graph shows my temp at 176 degrees F just after noon today.  I mean it is warm outside with the humidity and all, but if the temp was really that high...  LOL  The actual temp was in the mid to upper 70s F.  The graph for the wind also shows us having gusts in excess of 55 mph, which we are not having and the barometer is less that 1....something like 0.81.

Thoughts??
The data is converted twice as there was an error with the units for cumulus. Not that much cumulus+us+sql users.
New scripts attached.
Wim

Also use the new graph script!
« Last Edit: June 08, 2019, 08:42:58 PM by wvdkuil »
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline medic29

  • Posts: 52
  • OS/Browser:
  • Win NT 10.0
  • Firefox 67.0
Re: HWS-template (WD34 / weather34) April release
« Reply #147 on: June 09, 2019, 12:35:12 AM »
The data is converted twice as there was an error with the units for cumulus. Not that much cumulus+us+sql users.
New scripts attached.
Wim

Also use the new graph script!

Perfect, that fixed it.

Thank you for everything you have done and continue to do!!!

Offline pricey

  • Posts: 191
  • Llanelli Wales United Kingdom
  • OS/Browser:
  • iOS 12.3
  • Safari 0.8.2
    • Llanelli Weather
Re: HWS-template (WD34 / weather34) April release
« Reply #148 on: June 09, 2019, 12:00:32 PM »
Ok Wim and Bitsostring thanks for the replyís. Will update soon
Steve

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,357
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 74.0.3729.169
    • My PWS at Leuven Belgium Europe
Re: HWS-template (WD34 / weather34) April release
« Reply #149 on: June 09, 2019, 12:09:33 PM »
Ok Wim and Bitsostring thanks for the replyís. Will update soon
Steve
End of June is near.  The July release with all its advantages is available within a month.
Better wait for that version.
Or use the beta build to test it.
I am especially interested in your testing that version.
Your webhosting seems to restrict the number of parallel PHP scripts, as the blocks are loaded one at a time.
That should be solved in the July release, so if you test that new version let me know, so we can compare and check if the template runs faster.

Wim
« Last Edit: June 09, 2019, 12:13:30 PM by wvdkuil »
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/