cloudy cloudy

Author Topic: WXSIM 2019 Build 1.1 ... hopeful bug fix!  (Read 681 times)

0 Members and 1 Guest are viewing this topic.

Offline Tom Ehrensperger

  • Posts: 2,659
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
WXSIM 2019 Build 1.1 ... hopeful bug fix!
« on: March 07, 2019, 05:34:32 AM »
I've just uploaded a new version of WXSIM, which you use the upgrade installer to get:

www.wxsim.com/wxsimupg.exe

I'd had a few reports of a mysterious "error 6 in main" message, which I had been unable to reliably replicate.  Finally, tonight, I saw it myself!  Since I could trigger it in the development environment, I was able to quickly find and correct it! (Whew!)  It was simply out of range (too large for the integer data type) values of the new mixed layer height variable.  I haven't addressed the calculation issue per se (which leads to unrealistically high heights), but I've arbitrarily limited the value to more plausible values that at least won't trigger an error!  This info shows up only in latestblyr.csv.

Let me know how that goes!

By the way, I'll be out of town most of the next week, with limited internet access, but will certainly be checking back here when I return!

Thanks!

Tom

Offline hrvistaweather

  • Posts: 287
  • Tasmania
  • OS/Browser:
  • Win NT 10.0
  • Chrome 72.0.3626.121
Re: WXSIM 2019 Build 1.1 ... hopeful bug fix!
« Reply #1 on: March 07, 2019, 10:17:16 PM »
Hi Thanks Tom,
Installed and has done 4 Auto Runs (without issues).
Note: (wxsim - Proxy for all selected in wxsimate).
kind Regards,
Tony

Offline M.P.C.

  • Posts: 276
  • Toronto, Ontario,Canada
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 72.0.3626.121
    • High Park Village Toronto,ON,Canada
Re: WXSIM 2019 Build 1.1 ... hopeful bug fix!
« Reply #2 on: March 08, 2019, 01:32:06 AM »
Hello Tom,

  I am pleased with how new programs are running.

  Thank you,
   Marian
 :D :) :lol:

Offline Stegrie

  • Posts: 63
  • Germany
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
    • Wetterstation Johanngeorgenstadt
Re: WXSIM 2019 Build 1.1 ... hopeful bug fix!
« Reply #3 on: March 08, 2019, 05:26:43 AM »
Hi Tom,

have updated yesterday,since all runs working good :)

Stefan
Weather Station - Johanngeorgenstadt
Davis Vantage Pro 2 Plus - WXSIM,Blitzortung ,WD, 2 Soil Temp/Moist + Solar/Rad.
System: Windows 7

Offline cpejstrup

  • Posts: 28
  • OS/Browser:
  • Win NT 6.3
  • Firefox 65.0
Re: WXSIM 2019 Build 1.1 ... hopeful bug fix!
« Reply #4 on: March 20, 2019, 08:46:01 AM »
Works for me as well, thanks Tom

Offline JEB_Tucson

  • Posts: 48
  • Tucson, AZ, USA
    • none
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
Re: WXSIM 2019 Build 1.1 ... hopeful bug fix!
« Reply #5 on: March 20, 2019, 06:09:40 PM »
Hi Tom

Running great here!!!

Thanks,
James B
DW4536

Offline gwwilk

  • Posts: 672
  • Lincoln, NE
  • OS/Browser:
  • Win NT 10.0
  • Chrome 72.0.3626.121
    • Southeast Lincoln Weather
Re: WXSIM 2019 Build 1.1 ... hopeful bug fix!
« Reply #6 on: March 21, 2019, 01:53:31 PM »
It has been humming along here for over a week, Tom. 

Thanks!
Regards, Jerry Wilkins
gwwilk@inebraska.com

Offline Tom Ehrensperger

  • Posts: 2,659
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
Re: WXSIM 2019 Build 1.1 ... hopeful bug fix!
« Reply #7 on: March 22, 2019, 02:02:55 AM »
Thanks for all this good news! :)


 

cumulus