cloudy cloudy

Author Topic: New Wunderground API is available,if you use WU to get data, you need to migrate  (Read 1296 times)

0 Members and 1 Guest are viewing this topic.

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 72.0.3626.119
    • Weather Display
Hi
wunderground have released their new api
you can now get your api key
to then be able to have WD (build 92 update) use your wunderground data as a data source

if you had WD doing that before, then the old api is going to stop working on the 22nd March
so you will need to move to the new api

there is a link to click to get the new api key in the staitonless type setup in WD (where you have your WU station ID set)

you can set the update rate too (update to 30 calls a minute are allowed with the new api, which is really good)

The new api also has a 5 day forecast
I need to get WD to use that new system , e.g for under view, WU almanac (you will need to get a new api key to use that)

Offline R_o_B

  • Posts: 325
  • Maple Bay, British Columbia, Canada
  • OS/Browser:
  • Win NT 10.0
  • Firefox 52.0
    • Tzouhalem-Maple Bay Weather
Sorry Brian, I am probably getting 'dense' as I get older, but I do not quite understand the procedure on how to get the new API key from Weather Underground!  :oops:

I have clicked on a link at the bottom of the 'Weather Station Type Selection' window after choosing the 'Sationless/Wunderground' option, where it written to 'Click here for link to get API key'.

Clicking on that link takes me to the Weather Underground 'Member Account' page where I am automatically signed in since I already have an account with Weather Underground and my browser just automatically signs me in.

Using another browser (which does not sign me in automatically), after getting on the Weather Underground 'Member Account' page, I selected the 'Don't have an account? Sign up' and went through the signing procedures. As I completed the procedures, my account was provided with both a new 'Station ID' and 'Station Key/Password'.

I have not yet found a way to get the new API key...  :(
R_o_B
---
eMail: weather@tzweather.org

Online wvdkuil

  • Wim van der Kuil
  • Posts: 1,220
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 72.0.3626.119
    • My PWS at Leuven Belgium Europe
Sorry Brian, I am probably getting 'dense' as I get older, but I do not quite understand the procedure on how to get the new API key from Weather Underground!  :oops:
. . . shortened . . .
I have not yet found a way to get the new API key...  :(
The easiest way: You should sign in in your current WU account.
Then click the link https://www.wunderground.com/member/api-keys
This is the last mail:
Quote
Dear PWS uploaders, thank you for your continued loyalty and patience!
 
The gateway for the new API keys for PWS uploaders is open.
 
Cut and paste this URL into your browser:  https://www.wunderground.com/member/api-keys
 
If you are not logged in, you will be asked to.  The system will also verify that you have a PWS uploading to the system.
 

Wim

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 72.0.3626.119
    • Weather Display
that is the link that WD does you too
but not all browsers work very well with it
so try Edge maybe

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 10,526
  • Davis Vue/Win10
  • Ocean Park, WA.
  • OS/Browser:
  • Mac OS X 10.10.5
  • Chrome 72.0.3626.119
    • Traveling RV Weather
It's not very clear who actually needs to get the new API and why?  Is this something a PWS owner who SENDS data to WU need to take action?  Or as the subject points out, this is for people who run WD and PULL (stationless) data from WU? 

Confused as usual here...  :?


Also, I am unable to install build 92 here...tried downloading it twice and still won't install giving me an error..."Windows cannot access the specified device, path, or file"
« Last Edit: February 27, 2019, 05:08:53 PM by NorCal Dan »

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 72.0.3626.119
    • Weather Display
as per what the subject of this thread says
i.e only needed at this stage if you use WU as a data source for WD

but it will be needed for the 5 day forecast function in the almanac, but there does not seem to be any way to replace the almanac data (record hi/low for selected station) with the new api
edit, actually WD uses http://classic.wunderground.com/ to get the almanac data, so that should hopefully keep working
but the 5 day forecast and current conditions I will need to change to the new api and you will need to get and use your own api key

re your last statement, its not clear if you mean the full install or .zip update
« Last Edit: February 27, 2019, 06:07:06 PM by Weather Display »

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 10,526
  • Davis Vue/Win10
  • Ocean Park, WA.
  • OS/Browser:
  • Mac OS X 10.10.5
  • Chrome 72.0.3626.119
    • Traveling RV Weather
re your last statement, its not clear if you mean the full install or .zip update

Full install...haven't tried the zip update...

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 72.0.3626.119
    • Weather Display
I have tested and the full install works here
I do not have any other reports of a problem with it
maybe try a pc reboot?

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 72.0.3626.119
    • Weather Display
actually WD used to use the classic url, for the almanac...but changed to using the api
but I can see if using the classic url will still work (it was not the best method as was just scraping the data from a web page)

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 72.0.3626.119
    • Weather Display
done some experimenting
and
http://classic.wunderground.com/

does not exist anymore (moved permanently)

so RIP WU Almanac after the 22nd March :(

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 72.0.3626.119
    • Weather Display
I have moved the almanac and the wunderground station data (both via view )
to the new api

there is no record max/min available with the new api but you can use the manual data entry to set that so those custom tags work still

note that for the above 2 new screens, any station that was remembered has been reset and you need to get the new api key
also the search for stations is based on lat/long (geo code) and the latitude is a +ve value for west of GMT

the 5 day forecast works now from the new api (many hours spent getting that to work)

note that the old api is restricted for number of calls now and will close all together on the 22nd march
just a heads up


Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 72.0.3626.119
    • Weather Display
what the new api and 5 day forecast looks like now in WD

Offline bitsostring

  • Posts: 859
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
I have moved the almanac and the wunderground station data (both via view )
to the new api

Good job, Brian  :)

Quote
the search for stations is based on lat/long (geo code) and the latitude is a +ve value for west of GMT

I had to put in a -ve value for longitude west of GMT  :?
It's meant to be fun. . .

Online Weather Display

  • Posts: 86,945
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 72.0.3626.119
    • Weather Display
ops, I had that message backwards re longitude

Offline WeatherShip

  • Posts: 102
  • Terry Davis Vantage Vue
  • Columbus, OH
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
    • WeatherShip
Brian. Before all this new api stuff, I was using the WD/WU almanac successfully for years. I never had to get or purchase an api for this. Now, using 4 different browsers, the "get new api" link takes me only to my WU member settings page and nowhere is there an API function. What am I missing if you have a thought?
Thanks