cloudy cloudy

Author Topic: Help for install onto Ubuntu 18.04 64bit on VMware VM  (Read 1127 times)

0 Members and 1 Guest are viewing this topic.

Offline tobes49

  • Posts: 8
  • Irchester
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • T49.net My homepage
Help for install onto Ubuntu 18.04 64bit on VMware VM
« on: January 13, 2019, 09:23:51 PM »
Hi,

After a bit of help installing weather display onto ubuntu 18.04 64bit, Running on VM on ESXI 6.7
Im quite good with computers but new to linux,

Setup USB port and can find the weather station on - bus 002 device 004

Downloaded the 64bit GUI version

Going through the readme,txt file as the install guide  (.doc format) on the website seems to wrong for this install

Downloaded the package and extracted no problem
Ran the apt-get and installed libwebkitgtk all fine
Copied the files from deploy to usr/lib
Try to run ./weatherdisplay

comes up with error - error while loading shared libraries: libusb-0.1.so.4: cannot open shared object file: No such file or directory

Quick google comes up with install 32bit version

Tried sudo apt-get install libwebkitgtk-3.0:i386

but comes up with
Packages have unmet dependencies
libwebkitgtk:i386
E: Unable to correct problems, you have held broken packages


Anyone else have any ideas?

Cheers  Toby

http://weather.t49.net
Irchester, Northamptonshire, UK

Offline Weather Display

  • Posts: 87,192
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • Weather Display
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #1 on: January 14, 2019, 03:35:58 AM »
you seem to have trying to fix a usb driver problem but installing a gtk graphics driver instead
google has set you wrong me thinks

Offline tobes49

  • Posts: 8
  • Irchester
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • T49.net My homepage
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #2 on: January 17, 2019, 09:30:44 AM »
you seem to have trying to fix a usb driver problem but installing a gtk graphics driver instead
google has set you wrong me thinks

What a stupid mistake I made  #-o   Thank you for the pointer

Google was correct it was me mixing up libusb USB driver and libwebkitgtk  (Don't try to install things half asleep!)

I installed libusb-0.1.so.4 this didn't sure the problem
but this cured the problem - 
Code: [Select]
sudo apt-get install libusb-dev
I now get to the main screen but seems to lock up, will have another go over the weekend
http://weather.t49.net
Irchester, Northamptonshire, UK

Offline tobes49

  • Posts: 8
  • Irchester
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • T49.net My homepage
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #3 on: January 18, 2019, 07:16:05 AM »
For some reason the guided setup seems to lock up but using the control panel and setup works fine.

I have set the station type and external sensor

When to set comport and it states WMR200 doesn't need a comport number.

Ive tried removing the 0 eg - ttyUSB - no luck
Tried leaving it blank
Tried ttyUSB2 and ttyUSB4
as
Code: [Select]
lsusb lists as bus 2 device 4

Still no luck in getting the data to show?

What else can I test?
http://weather.t49.net
Irchester, Northamptonshire, UK

Offline Weather Display

  • Posts: 87,192
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • Weather Display
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #4 on: January 18, 2019, 08:41:05 PM »
you should just need to set the station type
then restart WD
then a separate program should run that should then get the data from the wmr200 station
yes?

Offline tobes49

  • Posts: 8
  • Irchester
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • T49.net My homepage
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #5 on: January 19, 2019, 08:16:06 AM »
I've tried restarting, weather display starts all fine and everything clickable,

but no extra program loads and  I no longer get a lag screen saying i'm on a trial version?   (Could this be the problem as I now unless you click the nag screen it wont start getting data)
It still states trail version in the top bar.

First load I had the pop up nag screen after I changed the station type and restarted I've not seen the nag screen.
http://weather.t49.net
Irchester, Northamptonshire, UK

Offline Weather Display

  • Posts: 87,192
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • Weather Display
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #6 on: January 19, 2019, 09:03:08 AM »
actually for the Linux version there is no separate cron program running
my bad
but you should be able to see some debug code in WD under view, debug info

what shows there?

Offline tobes49

  • Posts: 8
  • Irchester
  • OS/Browser:
  • (Linux Mint)
  • Firefox 64.0
    • T49.net My homepage
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #7 on: January 20, 2019, 12:49:43 PM »
Ive created a new  VM with a fresh install of ubuntu 18.04 LTS

Setup weather display and this time when clicking on WMR200 weather station a pop up window appears and looks for data from the wmr200

But this window seems to dissapear and errors appear on the terminals screen:
Code: [Select]
Starting
Loaded main form
Loaded internet form
Loaded graph form
Loaded settings form
Loaded control form
Loaded view form
Loaded weather station type
Loaded user daily report
Loaded com port
Loaded timer1
Loaded log settingd
Loaded graph setup
Loaded uv/solar
Loaded ws2000
Loaded extra sensor graph
Loaded daily hi/lo
Loaded metar
Loaded new graph
Loaded large display
Loaded dials
Loaded weather dials
Loaded sun moon
Loaded sensor list
Loaded trends
Loaded sun moon images
Loaded moon
Loaded summary
Loaded extra metars
Loaded 3D graph
Loaded energy
Loaded new rain chart
Doing mainform formcreate
Setting program location to: /home/weatherdisplay/Documents/wdisplay/
Creating ini files
Writing exit to ftp ini file
Setting up graph axis
Initiating variables
Setting conditions strings
Finished doing mainform form create
showing mainform
done form broadcast create
hiding splash screen
setting up graphs
finished showing mainform
usbreaderirox: no process found
usbreader: no process found
Cannot connect to station: Device or resource busy
Exception EAccessViolation in module weatherdisplay at 0000000001328AB4.
Access violation at address 0000000001328AB4, accessing address FFFFFFFFF60C9090.
Exception EAccessViolation in module weatherdisplay at 0000000000B2DB0E.
Access violation at address 0000000000B2DB0E, accessing address 0000000000000018.
Runtime error 217 at 0000000000581AF8

lsusb shows this
Code: [Select]
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 004: ID 0fde:ca01 Oregon Scientific WMRS200 weather station
Bus 002 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
Bus 002 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
http://weather.t49.net
Irchester, Northamptonshire, UK

Offline Weather Display

  • Posts: 87,192
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Android 7.1.1
  • Chrome 71.0.3578.99
    • Weather Display
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #8 on: January 20, 2019, 07:08:33 PM »
The device resource busy error
Is the clue
You could try starting weatherdisplay as sudo
In a terminal window

Offline tobes49

  • Posts: 8
  • Irchester
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • T49.net My homepage
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #9 on: January 20, 2019, 09:28:54 PM »
The device resource busy error
Is the clue
You could try starting weatherdisplay as sudo
In a terminal window

I did start in a terminal window with the sudo command,

terminal window,
Code: [Select]
cd wdisplay
Code: [Select]
sudo ./weatherdisplay
For testing I just installed weather display on a windows 7 VM, swapped the USB port to the Win 7 PC and this receives the data straight away
http://weather.t49.net
Irchester, Northamptonshire, UK

Offline BabcockFarms

  • Posts: 18
  • Spring Ranch, NE
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
    • Babcock Farms
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #10 on: February 18, 2019, 03:50:13 AM »
Hello tobes49,

I'm wondering if you made any progress on this? I built a beefy ESXi 6.7 host running several VM's on it (Windows 10, a few Ubuntu servers, Ubuntu workstation) and started down this road to configure another guest ubuntu 18.04 workstation to run Weather Display on. However, I'm not getting Weather Display to load completely. If I run as sudo it starts to load but never completes getting hung at setting up station type. If I run ./weather display I receive an error Runtime error 231 at 000000000046CB4E. I haven't had Weather Display open successfully.

Any help, thoughts or direction would be greatly appreciated. I would really like to get Weather Display working on a Linux system.

Thanks, Ron
« Last Edit: February 18, 2019, 03:53:17 AM by BabcockFarms »

Offline Weather Display

  • Posts: 87,192
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • Weather Display
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #11 on: February 18, 2019, 06:25:53 AM »
what happens when you run it as
sudo ./weatherdisplay

Offline BabcockFarms

  • Posts: 18
  • Spring Ranch, NE
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
    • Babcock Farms
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #12 on: February 23, 2019, 01:17:30 AM »
It would hang if I ran sudo ./weatherdisplay.

With that said, the problem was I hadn't allocated enough memory to the VM (Ubuntu Workstation 18.04) to run both the OS and Weather Display. I added memory and it would load WD when I run sudo ./weatherdisplay. When I run ./weatherdisplay I still receive the error mentioned earlier. I apologize for not figuring out the memory issue sooner.

I have it receiving data from the Wireless Weather Envoy and a USB Data Logger. Now on to figuring out how I want to publish the data to the web.

Thanks, Ron


Offline Weather Display

  • Posts: 87,192
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • Weather Display
Re: Help for install onto Ubuntu 18.04 64bit on VMware VM
« Reply #13 on: February 23, 2019, 03:56:08 AM »
ah, good oh, so its working now?  :wink:

 

cumulus