cloudy cloudy

Author Topic: Secure server issues  (Read 1053 times)

0 Members and 1 Guest are viewing this topic.

Offline Tom Ehrensperger

  • Posts: 2,682
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
Secure server issues
« on: February 07, 2019, 02:58:06 AM »
I think some of the data sources went to https in the last day or so, and that's giving WXSIMATE trouble trying to download from those URL's.  I have a solution that I just need to get coded and uploaded.  Working on it!

Tom

Offline Tom Ehrensperger

  • Posts: 2,682
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
Re: Secure server issues
« Reply #1 on: February 08, 2019, 03:49:19 AM »
Progress report: Sam Bohler is working now on setting up some URL's and I'll follow shortly (in a day or so) with a new WXSIMATE, so we'll be back to multiple options again! :)

Offline saratogaWX

  • Global Moderator
  • Posts: 5,937
  • Ken True
  • Saratoga, CA, USA 37:16:28N, 122:01:23W - Elev: 374ft.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 64.0
    • Saratoga Weather
Re: Secure server issues
« Reply #2 on: February 08, 2019, 05:01:51 AM »
Yes, several NOAA/NWS sites went https only but did it poorly -- some of the site names are using a common certificate that doesn't include that specific hostname in it, so attempts to 'verify host' fail.

I've had to turn off 'verify host' and 'verify peer' for programmatic access to several of the NWS sites due to that bad certificate they installed.

Hopefully, it will get fixed shortly and https will be smoothly flowing without certificate warnings.
Ken True
Saratoga Weather
CWOP: CW1792
WeatherUnderground: KCASARAT1
Free weather website PHP scripts and WD website AJAX templates

Offline Tom Ehrensperger

  • Posts: 2,682
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
Re: Secure server issues
« Reply #3 on: February 08, 2019, 11:16:46 PM »
I think we've got a fix for WXSIMATE with these secure server issues.  Sam Bohler set up some proxies, and I've re-coded some stuff in WXSIMATE (now version 7.1) so it should be able to read METAR, RAOB, and FOUS data from these NOAA sites again.  I don't have the new WXSIMATE packaged into an installer yet, here's the .exe:

www.wxsim.com/wxsimate.exe

Give that a try and let me know how it goes!

Tom

Offline M.P.C.

  • Posts: 280
  • Toronto, Ontario,Canada
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 71.0.3578.98
    • High Park Village Toronto,ON,Canada
Re: Secure server issues
« Reply #4 on: February 09, 2019, 12:33:33 AM »
Hello Tom,
In version 7.1, two errors appear, are attached, the program is blocked.
You can get a suggestion.
Thank you,
Marian

Offline Tom Ehrensperger

  • Posts: 2,682
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
Re: Secure server issues
« Reply #5 on: February 09, 2019, 02:27:08 AM »
You're right!  They did another one!!  I'm checking into that now.  Hopefully this will be the last of the changes.  Even my browser doesn't trust the new MOS URL's.  Meanwhile, uncheck MOS.  The GFS for Advection data will fill in nicely for that.

Tom

Offline bertsp

  • Posts: 25
  • KPRC
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
    • Dreamland Ranch-Sundown Acres Wx
Re: Secure server issues
« Reply #6 on: February 13, 2019, 04:41:45 PM »
Tom,
On the new wxsimate, I am getting a different error. It seems to be referencing time setting. It only occurs on the Buoy site. If I click the Buoy off, it finished the run and if I click the Synop, it works also (as per message).
I am in AZ where we don't change time.
BertSP
Ambient WS-1200-IP
WeatherHawk 916

Offline Tom Ehrensperger

  • Posts: 2,682
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
Re: Secure server issues
« Reply #7 on: February 15, 2019, 03:30:49 AM »
OK, I *think* I've got all the issues taken care of from this recent spate of switches to secure servers!  Here's the latest version of WXSIMATE.  It's the executable itself (not an installer), so you just download the file and use it to replace the WXSIMATE you already have.  It should show Version 7.2:

www.wxsim.com/wxsimate.exe

The latest changes were to the MOS text files.  These are now retrieved through a proxy.

Let me know how it goes!

Tom

Offline mikeym

  • Posts: 1,304
  • Thornhurst, Pa USA
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 65.0
    • MikeyMs Thornhurst,PA Weather
Re: Secure server issues
« Reply #8 on: February 15, 2019, 02:45:29 PM »
Tom

Looks good on the initial run - thanks

 :D

MikeyM
http://mikeymsweather.com/

Another VERY Happy WD user
Shuttle XS36v4 8 GB RAM
Davis Vantage Pro 2 wireless w/ Davis solar sensor
Laser Snow Depth Sensor LR4/Fluke 414D working in WD thanks to Brian

Offline M.P.C.

  • Posts: 280
  • Toronto, Ontario,Canada
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 72.0.3626.109
    • High Park Village Toronto,ON,Canada
Re: Secure server issues
« Reply #9 on: February 15, 2019, 02:49:39 PM »
Working well!

 :D

Thank you,

  Tom

Offline Breezy

  • Indian Trail Weather
  • Posts: 367
  • Hessville, NY, U.S.A.
    • baldwinj1
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 65.0
    • Indian Trail Weather
Re: Secure server issues
« Reply #10 on: February 16, 2019, 01:37:58 AM »
Working fine, Tom.

Thank you!  \:D/
« Last Edit: February 16, 2019, 01:42:05 AM by Breezy »
Jeff

W7-64, Intel Z170A 16 GB RAM
Davis VP2 Plus & Soil Moisture/Temp Sensors, Laser Snow Sensor LR4/Fluke 414D, 6 Webcams

Offline saratogaWX

  • Global Moderator
  • Posts: 5,937
  • Ken True
  • Saratoga, CA, USA 37:16:28N, 122:01:23W - Elev: 374ft.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
    • Saratoga Weather
Re: Secure server issues
« Reply #11 on: February 16, 2019, 03:42:12 AM »
For me too.  Thanks Tom!
Ken True
Saratoga Weather
CWOP: CW1792
WeatherUnderground: KCASARAT1
Free weather website PHP scripts and WD website AJAX templates

Offline sacreysouthern

  • Posts: 239
  • Echo Valley Weather
  • Benton, AR, USA
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 72.0.3626.109
    • Echo Valley Weather
Re: Secure server issues
« Reply #12 on: February 16, 2019, 12:36:50 PM »
Hi Tom,

Looks to be working well for me also.

I will also let you know that the latest version of Malwarebytes Premium just flagged wxsim.exe amd wxsimate.exe as ransomware on my computer as a false positive. I had to exclude the entire folder to make WxSim work again. This is the first time I have had that happen to WxSim. It may be because of the .exe's being digitally unsigned possibly????

John
GR2AE, GR3, Davis VP2 Pro CWOP ID: D2073