cloudy cloudy

Author Topic: WXSIM 2019, Build 1.0 Released!  (Read 2239 times)

0 Members and 1 Guest are viewing this topic.

Offline broadstairs

  • Stuart
  • Posts: 7,034
  • Broadstairs, Kent, UK
  • OS/Browser:
  • (Linux Mint)
  • Firefox 61.0
    • Broadstairs
Re: WXSIM 2019, Build 1.0 Released!
« Reply #15 on: February 02, 2019, 11:58:29 AM »
Tony I had issues with the 2019 release and since going back have not (touch wood) had any.

Stuart

Offline hrvistaweather

  • Posts: 287
  • Tasmania
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
Re: WXSIM 2019, Build 1.0 Released!
« Reply #16 on: February 02, 2019, 12:58:17 PM »
Hi Stuart,
Thanks matey, will try that, if it fails I'm done.
Tom as per your request on error 6 which I get on some runs, wonder if it is Cumulus or your wxsim source data or maybe 9 day vs say 4 day forecast.
zipped files attached.
Kind regards,
Tony

Offline hrvistaweather

  • Posts: 287
  • Tasmania
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
Re: WXSIM 2019, Build 1.0 Released!
« Reply #17 on: February 02, 2019, 01:22:05 PM »
Hi reinstated old version and did manual run, all good.
Off to bed now, will see if auto runs are fault free when I awake.
One thing I did note is that in wxsimate, I was running :
Metar : proxy/wxsim (in old and new version)
Synop : proxy/wxsim (in old and new version)
RAOB : rap.ucar.edu (in old but (proxy/wxsim) in new version). did not realise till revert so not sure if it was an underling issue.

kind regards,
Tony

Offline broadstairs

  • Stuart
  • Posts: 7,034
  • Broadstairs, Kent, UK
  • OS/Browser:
  • (Linux Mint)
  • Firefox 56.2.6
    • Broadstairs
Re: WXSIM 2019, Build 1.0 Released!
« Reply #18 on: February 02, 2019, 03:00:56 PM »
SYNOP is the only one I see in old version now with proxy value in. RAOB is
Code: [Select]
www.rap.ucar.edu
Stuart

Offline Tom Ehrensperger

  • Posts: 2,659
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
Re: WXSIM 2019, Build 1.0 Released!
« Reply #19 on: February 02, 2019, 09:40:00 PM »
Tony, thanks for the files from when you got the error.  I'm working on it! :)

Tom

Offline hrvistaweather

  • Posts: 287
  • Tasmania
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
Re: WXSIM 2019, Build 1.0 Released!
« Reply #20 on: February 02, 2019, 10:52:00 PM »
Thanks Tom,
Old version forecast's ran ok overnight, though I had to remove my fix for the additional UTC stamp in latest.csv (I forgot to last night).
Only issue I have now in old is that autolearn will not run, it crashes with error 62 input past end of file.
Smoke back thick as again today. :(
Kind Regards,
Tony

Offline Tom Ehrensperger

  • Posts: 2,659
  • OS/Browser:
  • Win NT 10.0
  • Firefox 65.0
Re: WXSIM 2019, Build 1.0 Released!
« Reply #21 on: February 03, 2019, 12:29:16 AM »
Hi Tony,

I DID manage to reproduce the error, though I haven't quite found the variable that's overflowing, because I have lots of error trapping, that sends the error to the handler instead of leaving it where it occurred.  However, I'm almost sure it is associated with the fact that you are running a long forecast, with 60 iterations per interval, which has the counter up to 15,900 when the error occurs.  I think some related variable must be about twice that, and is an integer exceeding the bounds of such things (32,768, I think).  I easily solved this by cutting back to 20 iterations per interval.  In fact, I see no reason to use more than 6.  This is under parameters.

I'm confused about why there would be any difference between the older and new versions here, though.  I can't think of anything I changed related to this.  I also don't know whether Stuart was seeing the same thing.  In any case, I'd be interested to hear how the new version does with 6 (or as much as 20) iterations per interval.  If that solves the problem, I can prevent this somehow.

With autolearn, does it crash immediately?  Can you send me a screen shot? Can you send me alrninit.txt?

Thanks!

Tom

Offline hrvistaweather

  • Posts: 287
  • Tasmania
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
Re: WXSIM 2019, Build 1.0 Released!
« Reply #22 on: February 03, 2019, 01:23:21 AM »
Hi Tom,
Greatly appreciated, just reinstalled upgraded version again and reduced iterations to 6, will see how it goes next auto run.
Tried autolearn again but same issue. yes crashes as soon as i click run immediately. have attached as requested.
Kind Regards,
« Last Edit: February 03, 2019, 01:25:04 AM by hrvistaweather »
Tony

Offline hrvistaweather

  • Posts: 287
  • Tasmania
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
Re: WXSIM 2019, Build 1.0 Released!
« Reply #23 on: February 03, 2019, 09:19:46 AM »
Hi Tom,
I have found the reason for autolearn error 62, though can only assume there must have been a save issue somewhere during the upgrade and next run stage.
I found that the correc.txt file was not line format structured as it normally is. eg seemed to be centred vs left aligned with line breaks.
Any way lucky I had previous day backup, so added recent day line to old file and all ran perfect.
So now running new version no issues.
Strange about the iteration issue as I have been running at 60 for months now (just to see if it would differ or break) I like doing that.
Kind Regards,
« Last Edit: February 03, 2019, 09:21:39 AM by hrvistaweather »
Tony

Offline hrvistaweather

  • Posts: 287
  • Tasmania
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
Re: WXSIM 2019, Build 1.0 Released!
« Reply #24 on: February 03, 2019, 06:56:30 PM »
Hi Tom,
Overnight runs went fine no errors, however this mornings 05:00 run (which is gfs 12z) failed after the 7th day with error 6 in wxsim.
I have run 9 days without error for years, so unsure what is causing it.
For now I have cut back to 7 days.
Kind regards,
Tony

Offline hrvistaweather

  • Posts: 287
  • Tasmania
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
Re: WXSIM 2019, Build 1.0 Released!
« Reply #25 on: February 04, 2019, 01:20:17 AM »
Hi Tom,
another issue, my 11:00 (gfs 18z) run failed this time wxsimate unable to download (not sure if it was Metar (proxy.wxsim.net...) or RAOB (proxy.wxsim.net....) sorry did not capture the windows exception error.
So I changed source as per image below and all ran ok again, will wait and see what happens next run.
Kind regards,
Tony

Offline broadstairs

  • Stuart
  • Posts: 7,034
  • Broadstairs, Kent, UK
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 56.2.6
    • Broadstairs
Re: WXSIM 2019, Build 1.0 Released!
« Reply #26 on: February 16, 2019, 04:36:12 PM »
Tom I'm wondering if you have managed to get to the issues which several of us have had with this release?

Stuart

 

cumulus