cloudy cloudy

Author Topic: ***closed*** weather34 for WeatherDisplay (clientraw and WDapi)  (Read 23444 times)

0 Members and 1 Guest are viewing this topic.

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,346
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #180 on: January 17, 2019, 10:24:24 AM »
Hi Wim,
Can you tell me what the little temperature below the main temperature is supposed to represent (see attachment)?  I assume it some kind of trend, however mine seems to be way off and it has been like this since the start.  How is this calculated?
If it helps, here is a link to my site.http://micklehamweather.com/pwsWD/
Thanks,Neil
Compare your site with the demo-site.  It should be the temperature trend.
Most of the times it should be between -1 and + 1.
The script compares "current temp" with "temp 15 minutes" ago.
But you WD file as uploaded contains 2 extra spaces.
All fields after these two spaces are misaligned  and  current temp  is now compared to lowest dewpoint today.

Please update to the latest WD release as this is an old problem.
Or use clientraw.txt for your data.

Why do I always ask for the link to the site?
To check a lot of values with this script: http://micklehamweather.com/pwsWD/w34_module_test.php
One can check the calculated "Live data values" or the WDapi values with the field-names.
All the uploaded files, as long as they are in the default folders, can also be inspected this way.
And any individual script can be run with error-reporting on.
Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline Cheffy

  • Posts: 86
  • Melbourne, Australia
  • OS/Browser:
  • iOS 12.1.2
  • Safari 12.0
    • Mickleham Weather
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #181 on: January 17, 2019, 11:18:44 AM »
Thanks again Wim - I have updated to the latest version of WD and it is working fine.

Neil

Offline bitsostring

  • Posts: 976
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #182 on: January 17, 2019, 08:20:24 PM »
Silly trivial question: why are the legends (data source, hardware, etc.) not automatically centred? Is that css too?

Legend1 is my site, legend2 is your test site - viewed in Chrome.
It's meant to be fun. . .

Offline GW400

  • Posts: 83
  • Klepp, Norway
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
Issue loading webcam image
« Reply #183 on: January 17, 2019, 08:24:23 PM »
In w34_easyweathersetup I have used this link to my webcam image: ./webcam/aad-axis-01.jpg?
Nothing is shown under "Live Web Cam" rectangle.
If  I select "Live Web Cam" link at the bottom the static webcam image pops up.
Any idea what I'm doing wrong?

What is requirements for showing webcam image?
Can we add a url to the webcam when using an IP camera? Should we use http://xxx or just add fqdn?
When using an image what is the size requirements (X x Y pixels)?
Regards G400

Offline Weather Display

  • Posts: 87,212
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • Weather Display
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #184 on: January 17, 2019, 08:29:00 PM »
the web cam Q was asked and answered further up in this thread

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,346
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #185 on: January 17, 2019, 08:41:34 PM »
Silly trivial question: why are the legends (data source, hardware, etc.) not automatically centred? Is that css too?

Legend1 is my site, legend2 is your test site - viewed in Chrome.
Please always the URL to your pwsWD folder.  I had to scan your previous posts to find the URL.

Yes, it is in the CSS and the three lines itself are centred. But the block with the three is not centred in the footer.
It only has a 75px left margin to not interfere with the images on the left.

As I have a longer third line it only looks like the block with the three lines is centred.
Adapting the CSS is a not so trivial task for the April release.

Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline GW400

  • Posts: 83
  • Klepp, Norway
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #186 on: January 17, 2019, 10:48:38 PM »
the web cam Q was asked and answered further up in this thread

The previous post recommends: "You set the link to  "../webcam/image.jpg" which is 100% correct"
This is what I have done by specifying ../webcam/aad-axis-01.jpg , but on an "X weathercam" is shown in rectangle for Live Web Cam

ls -l webcam
total 156
-rw------- 1 weather weather 158374 Jan 17 09:26 aad-axis-01.jpg

_____________________
After posting the previous message I discovered my error: owner user and group was incorrect.
Now it is working
« Last Edit: January 17, 2019, 10:51:17 PM by GW400 »
Regards G400

Offline blainec

  • Global Moderator
  • Posts: 438
  • Calgary, Ab.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 64.0
    • Weather YYC
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #187 on: January 18, 2019, 04:19:29 AM »
OK, it was the UV value which was causing the problem.
Please test this version,
Wim
It's working now.  Thank you

https://weatheryyc.com/pwsWD

Offline Cheffy

  • Posts: 86
  • Melbourne, Australia
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • Mickleham Weather
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #188 on: January 19, 2019, 05:24:23 AM »
Hi Wim,

Sorry I have another question, this maybe a bug or a lack of understanding on my part.  Currently I have an AQI reading on my site of 99 - this is based on the nearest AQ station (for me it's Footscray, Australia).  If I go to the link for this station the AQI is actually 35 - see link below.

https://aqicn.org/city/australia/melbourne/footscray/

I have then checked the output for my AQI in the module_test page, I can see the reference of an AQI of 35, but nothing for 99.  How is the 99 generated?  Maybe I am wrong, but I assumed my site should be showing the same AQI as the source, which is 35.

The link to my site is,

https://micklehamweather.com/pwsWD/

Thanks,
Neil


Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,346
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #189 on: January 19, 2019, 08:11:19 AM »
Hi Wim,

Sorry I have another question, this maybe a bug or a lack of understanding on my part.  Currently I have an AQI reading on my site of 99 - this is based on the nearest AQ station (for me it's Footscray, Australia).  If I go to the link for this station the AQI is actually 35 - see link below.

https://aqicn.org/city/australia/melbourne/footscray/

I have then checked the output for my AQI in the module_test page, I can see the reference of an AQI of 35, but nothing for 99.  How is the 99 generated?  Maybe I am wrong, but I assumed my site should be showing the same AQI as the source, which is 35.

The link to my site is,

https://micklehamweather.com/pwsWD/

Thanks,
Neil
Thank you, added future code for test and did not remove all before release  :oops:  A new version is attached.

One can check the files itself by using this script:  https://micklehamweather.com/pwsWD/w34_module_test.php
Just use list contents and select "./jsondata/gov_aqi.txt"  it shows all data (also in json).
Wim
« Last Edit: January 19, 2019, 08:16:36 AM by wvdkuil »
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline Cheffy

  • Posts: 86
  • Melbourne, Australia
  • OS/Browser:
  • iOS 12.1.2
  • Safari 12.0
    • Mickleham Weather
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #190 on: January 19, 2019, 09:30:44 AM »
Thanks Wim - itís working fine now.

It looks like the pop up script will also need a fix as it is still showing the old AQI value.

Neil

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,346
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #191 on: January 19, 2019, 09:52:38 AM »
Thanks Wim - itís working fine now.
It looks like the pop up script will also need a fix as it is still showing the old AQI value.
Neil
:oops:
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline bitsostring

  • Posts: 976
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #192 on: January 19, 2019, 12:42:46 PM »
Moon rise and set appear to be shown an hour late: moon set in Edinburgh this morning was 0645, next moon rise is 1425.

http://swanston.maui.co.uk/pws/
It's meant to be fun. . .

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,346
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #193 on: January 19, 2019, 12:54:58 PM »
Moon rise and set appear to be shown an hour late: moon set in Edinburgh this morning was 0645, next moon rise is 1425.

http://swanston.maui.co.uk/pws/
There is an update on-line with all changed scripts: http://wd34.weather-template.com/
The moon-block.php and two new supporting scripts in the other/ folder could take care of it.
Wim


Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline bdtripps

  • Posts: 194
  • Youngtown, AZ
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • Agua Fria Ranch Youngtown, AZ
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #194 on: January 19, 2019, 03:06:41 PM »
B.Trip
DavisVP2/ Envoy Wireless, 2011 Mac Mini Server
Sierra 10.12.6, 2.3ghz Quad-Core Intel Core i7 16GB Ram
Arizona