cloudy cloudy

Author Topic: ***closed*** weather34 for WeatherDisplay (clientraw and WDapi)  (Read 23280 times)

0 Members and 1 Guest are viewing this topic.

Offline Svenni

  • Posts: 38
  • Moss in Norway
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.102
    • Refsnesbakken Borettslag
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #135 on: January 09, 2019, 08:57:11 PM »
Hello Wim

Thx for the update of this nice layout.
I have it up and go, but i se on the right side on the current condition and push the link on "nearby" i get (EEBR , Brussel)

Svenni


Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,341
  • Leuven Belgium CET
  • OS/Browser:
  • iOS 12.0.1
  • Safari 12.0
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #136 on: January 09, 2019, 09:03:24 PM »
Hello Wim

Thx for the update of this nice layout.
I have it up and go, but i se on the right side on the current condition and push the link on "nearby" i get (EEBR , Brussel)
Did you het your METAR API key?
Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline Svenni

  • Posts: 38
  • Moss in Norway
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.102
    • Refsnesbakken Borettslag
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #137 on: January 09, 2019, 09:17:35 PM »
Ahhhhh sorry Wim, it's on place i forgot to do that. Thx
Svenni


Offline bitsostring

  • Posts: 970
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #138 on: January 09, 2019, 10:34:29 PM »
Temp and Barometer block pop-up graphs for Y and M (not D) show "<br><color>Radiation</color>" after the High/Low legend?

« Last Edit: January 09, 2019, 10:37:50 PM by bitsostring »
It's meant to be fun. . .

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,341
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #139 on: January 10, 2019, 08:47:12 AM »
Temp and Barometer block pop-up graphs for Y and M (not D) show "<br><color>Radiation</color>" after the High/Low legend?
That is an unexpected/invalid translation in the language file for english
Add to the bottom of  pwsWD/languages/lang.en.php   1 line just before the ?>
Code: [Select]
$lang['Good']= 'Good Air Quality ';

$lang['Low'] = 'Low';
?>
Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline bitsostring

  • Posts: 970
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #140 on: January 10, 2019, 10:51:08 AM »
That is an unexpected/invalid translation in the language file for english

Thanks, Wim, all good now  :)
It's meant to be fun. . .

Offline R_o_B

  • Posts: 341
  • Maple Bay, British Columbia, Canada
  • OS/Browser:
  • Win NT 10.0
  • Firefox 52.0
    • Tzouhalem-Maple Bay Weather
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #141 on: January 10, 2019, 02:40:38 PM »
Wim, is there a way to force a page refresh when the page is loaded - I know I can click on the refresh button of my browser, but I would prefer to click on the link to my page and have that page loaded with fresh/up-to-date weather data (skipping any cache data).
R_o_B
---
eMail: weather@tzweather.org

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,341
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #142 on: January 10, 2019, 02:53:56 PM »
Wim, is there a way to force a page refresh when the page is loaded - I know I can click on the refresh button of my browser, but I would prefer to click on the link to my page and have that page loaded with fresh/up-to-date weather data (skipping any cache data).
As all data comes from PHP the browser cache will not be used for data as with html.
The server caches the data loaded from external sites. But those are not refreshed when reloading the page.
Actions when loading the page (as it is functioning now)
1. Frame of the  page with empty boxes is sent back to to the requesting browser
2. The "update script" is loaded and it starts re-loading obsolete data form external sources (DarkSky, AQ,  a.s.o.)
3. All blocks are loaded one by one and they use the available data on the server, the blocks do not reload data themselves
4. All blocks refresh their data at different intervals after they are loaded

Often one uses a cron-job so that all data on the server is always valid and step 2  just checks and find all data is OK.

Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline bitsostring

  • Posts: 970
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #143 on: January 10, 2019, 05:34:06 PM »
A couple more observations on the Dark Theme viewed in Chrome. . .

1. Your test page Sun block has a problem with "Estimated" font size - see Sun1. (I presume you have been making changes, as the block is no longer titled Sun, Moon & Space like mine - see Sun2. I prefer just Sun!)

2. I think the webcam fits better at $webcam_height of 155px (webcam2) rather than 160px (webcam1, where it hangs over the bottom of the frame)? (I changed mine to show width 70%, too, to reproduce the 4:3 aspect ratio without stretching.)
It's meant to be fun. . .

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,341
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #144 on: January 10, 2019, 06:27:03 PM »
A couple more observations on the Dark Theme viewed in Chrome. . .

1. Your test page Sun block has a problem with "Estimated" font size - see Sun1. (I presume you have been making changes, as the block is no longer titled Sun, Moon & Space like mine - see Sun2. I prefer just Sun!)
Yes I am testing a new sun-block.php, it should always display the correct sun-position ,also when someone from another time-zone visits your site.  That "Estimated" is only displayed in the "dark theme". I removed it in the script as all text should be translated to the default language.
Quote
2. I think the webcam fits better at $webcam_height of 155px (webcam2) rather than 160px (webcam1, where it hangs over the bottom of the frame)? (I changed mine to show width 70%, too, to reproduce the 4:3 aspect ratio without stretching.)
The problem is not with the height the webcam image. The problem is a difference in the CSS between light and dark. All block-headers are displayed lower in the dark theme, just outside the  band. In the light theme they are correctly place inside the grey band.
Have to find where it is specified.
Wim
FOUNDIT:  weatheritem has 6px padding in dark  0px in light theme
There are more differences this pushes all content lower in the box.
« Last Edit: January 10, 2019, 06:54:39 PM by wvdkuil »
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline bitsostring

  • Posts: 970
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #145 on: January 10, 2019, 07:22:56 PM »
FOUNDIT:  weatheritem has 6px padding in dark  0px in light theme

Well done! I wonder why. . . (But that's why my 5px correction made it "look" better!)
It's meant to be fun. . .

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 10,552
  • Davis Vue/Win10
  • Ocean Park, WA.
  • OS/Browser:
  • Mac OS X 10.10.5
  • Chrome 71.0.3578.98
    • Traveling RV Weather
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #146 on: January 10, 2019, 08:01:28 PM »
That is an unexpected/invalid translation in the language file for english
Add to the bottom of  pwsWD/languages/lang.en.php   1 line just before the ?>
Code: [Select]
$lang['Good']= 'Good Air Quality ';

$lang['Low'] = 'Low';
?>
Wim

Is this related to the same issue?

Offline bitsostring

  • Posts: 970
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #147 on: January 10, 2019, 08:49:41 PM »
That "Estimated" is only displayed in the "dark theme". I removed it in the script as all text should be translated to the default language.

I did notice that the French translation is "Luminosité".

It's meant to be fun. . .

Offline bitsostring

  • Posts: 970
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #148 on: January 12, 2019, 04:08:50 PM »
Small problem in Rain block: 0.3 mm rainfall today was at 0130 Z, so "Last Hour" should be zero.
It's meant to be fun. . .

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,341
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #149 on: January 12, 2019, 04:26:31 PM »
Small problem in Rain block: 0.3 mm rainfall today was at 0130 Z, so "Last Hour" should be zero.
But there is no link to that  page. Not in the Avatar not in the post.
As I am not clairvoyant, there is nothing i can do.
Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/