cloudy cloudy

Author Topic: ***closed*** weather34 for WeatherDisplay (clientraw and WDapi)  (Read 23431 times)

0 Members and 1 Guest are viewing this topic.

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,346
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #75 on: January 05, 2019, 02:54:11 PM »
Hello Wim
Great work. I see some small fixes on the  installation page. How do you update the build?
Thanks
Steve
You should unzip the update.
The 10 changed scripts go into the pwsWD/ folder on your server.
There are two folders with a name  "copy to "
One has the extra flag, goes into pwdWD/img/flags/  The other has the extra language files for pwdWD/languages/

Succes,
Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline bitsostring

  • Posts: 976
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #76 on: January 05, 2019, 03:54:44 PM »
One small typo, in line 137 of W34_menu.php: 'Select langauge'  should read 'Select language'

(That works in my menu, but I don't know if there are any other places I should look?)

And the words "Template by weather34.com" at bottom right overhang the main template "frame". . .?

« Last Edit: January 05, 2019, 04:18:11 PM by bitsostring »
It's meant to be fun. . .

Offline pricey

  • Posts: 190
  • Llanelli Wales United Kingdom
  • OS/Browser:
  • Android 8.0.0
  • Chrome 71.0.3578.99
    • Llanelli Weather
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #77 on: January 05, 2019, 04:25:04 PM »
Ok Wim will give it a go.

Thanks
Steve

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,346
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #78 on: January 05, 2019, 05:15:32 PM »
One small typo, in line 137 of W34_menu.php: 'Select langauge'  should read 'Select language'
(That works in my menu, but I don't know if there are any other places I should look?)
Very easy solution:
Correct all typing errors by using the language files.  |'Select langauge|Select language|
That way you are sure that with a new release the error does not return.
And that visitors using another language can see the translation to their language also.
The script-editors do not catch those typing errors and English is not my native language either
This: |from text in script |to text visitor sees|  is therefor used by multiple template authors.
Quote
And the words "Template by weather34.com" at bottom right overhang the main template "frame". . .?
Can you make a small screenshot, as I do not understand what the problem is at my test site, thanks.
Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline bitsostring

  • Posts: 976
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #79 on: January 05, 2019, 05:31:26 PM »
Very easy solution:
Correct all typing errors by using the language files.  |'Select langauge|Select language|
That way you are sure that with a new release the error does not return.

Thanks, Wim.

Can you make a small screenshot, as I do not understand what the problem is at my test site, thanks.

1.JPG shows my site, 2.JPG shows your test site. Legends (Data source, Hardware, etc.) not centred, either.
« Last Edit: January 05, 2019, 05:33:32 PM by bitsostring »
It's meant to be fun. . .

Offline eb3bvb

  • Posts: 157
  • Torrelavega, Cantabria
  • OS/Browser:
  • Win NT 10.0
  • Firefox 64.0
    • meteotorrelavega
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #80 on: January 05, 2019, 05:48:22 PM »
Hello, the page
http://www.meteotorrelavega.com/pwsWD/w34_cron_stationcron.php
Give me this:
No loading of DB neededsuccess files loaded + to day file
Y :
http://www.meteotorrelavega.com/pwsWD/w34_util_createdb.php

weather34 Error creating database: Access denied for user 'meteotorkcmilio' @ '%' to database 'weatherstation'
I have checked name database, use password everything is fine
I connect to phpMyAdmin right
attached images
the second is what I think by importing the sql file
any suggestions
emilio #-o 8O 8O

Offline Boce

  • Posts: 46
  • Knjazevac, Serbia
  • OS/Browser:
  • Win NT 10.0
  • Firefox 64.0
    • Meteo Knjazevac
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #81 on: January 05, 2019, 05:57:10 PM »
Win direction and avg wind direction always have some direction although they have different ones :?

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,346
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #82 on: January 05, 2019, 06:46:35 PM »
Thanks, Wim.

1.JPG shows my site, 2.JPG shows your test site. Legends (Data source, Hardware, etc.) not centred, either.
your site http://swanston.maui.co.uk/pws/  shows differently at my place with chrome and FF. I think the height has to be adjusted to fit.
Script w34_index.php line 261 reads now
Code: [Select]
        <img src="img/weather34logo.svg" width="40px" alt="https://weather34.com/homeweatherstation/" class="homeweatherstationlogo" ></a>';}change the height to 30px so we can see if that solves it.
Code: [Select]
        <img src="img/weather34logo.svg" width="30px" alt="https://weather34.com/homeweatherstation/" class="homeweatherstationlogo" ></a>';}
Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,346
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #83 on: January 05, 2019, 06:59:48 PM »
Hello, the page
http://www.meteotorrelavega.com/pwsWD/w34_cron_stationcron.php
Give me this:
No loading of DB neededsuccess files loaded + to day file
You have to specify in the settings if the cron file should store the data +  you should have a working database
Quote
Y :
http://www.meteotorrelavega.com/pwsWD/w34_util_createdb.php
Did you give the user all rights to the database? Seems not as the checkboxes are empty.
That user must be allowed to define new tables ans so on, as that is what the
And what are those  strange  characters  '@ '%' doing in the error message?
Quote
weather34 Error creating database: Access denied for user 'meteotorkcmilio' @ '%' to database 'weatherstation'
I have checked name database, use password everything is fine
I connect to phpMyAdmin right
attached images
the second is what I think by importing the sql file
That image is correct as the test record is inserted in the databas-table.
Quote
any suggestions
emilio #-o 8O 8O
You should now give the user all rights.  And set the cron-job to do the updates,
Success, Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline bitsostring

  • Posts: 976
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #84 on: January 05, 2019, 07:11:17 PM »
your site http://swanston.maui.co.uk/pws/  shows differently at my place with chrome and FF.

Apologies: I'm using Edge, and didn't think to check in Chrome  #-o

Quote
I think the height has to be adjusted to fit.
change the height to 30px so we can see if that solves it.

Afraid not. . . see screenshots. (Chrome is better, though, as the logo doesn't interfere with the text!)
It's meant to be fun. . .

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,346
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #85 on: January 05, 2019, 07:13:39 PM »
Win direction and avg wind direction always have some direction although they have different ones :?
Thank you spotting this.
There must be enough difference, so preferably 22 degrees to show another compass reading, but is always showed the same compass for avg and normal direction.
I attach  a modified script which should remove this error.
Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline bitsostring

  • Posts: 976
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #86 on: January 05, 2019, 07:15:16 PM »
Very easy solution:
Correct all typing errors by using the language files.  |'Select langauge|Select language|

Sorry, do I add that to lang_extra.txt?
It's meant to be fun. . .

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,346
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #87 on: January 05, 2019, 07:20:55 PM »
Sorry, do I add that to lang_extra.txt?
No to lang.en.php if you use English.
It should look like
Code: [Select]
$lang['Select langauge'] = 'Select language';I did not redo the English file as most untranslated words are in English.
The typing errors should be added to the english file in the PHP way as in the original weather34.

sorry, Wim
Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 1,346
  • Leuven Belgium CET
  • OS/Browser:
  • Mac OS X 10.13.6
  • Chrome 71.0.3578.98
    • My PWS at Leuven Belgium Europe
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #88 on: January 05, 2019, 07:23:53 PM »
Apologies: I'm using Edge, and didn't think to check in Chrome  #-o
Afraid not. . . see screenshots. (Chrome is better, though, as the logo doesn't interfere with the text!)
The chrome screenshot looks acceptable.
And yes edge. I do not know how much more differences will show with the very complex  css which is used
At least microsoft will build a new Edge using the chromium engine and then these problems will fade away.
As  soon as Brians new css can be used I will start testing with edge also.

Wim

Support & demo PWS_Dasboard  (HWS_template) http://pwsdashboard.weather-template.com/ 
My PWS at home https://weer.sluispark.be/
And at my daughters house https://www.weerstation-herent.be/

Offline bitsostring

  • Posts: 976
  • Oregon Scientific WMR200
  • Edinburgh, U.K.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: weather34 for WeatherDisplay (clientraw and WDapi)
« Reply #89 on: January 05, 2019, 07:32:04 PM »
No to lang.en.php if you use English.

Thank you, again!

At least microsoft will build a new Edge using the chromium engine and then these problems will fade away.

Can't wait  :)


It's meant to be fun. . .

 

cumulus