cloudy cloudy

Author Topic: New WXSIM to try!  (Read 1063 times)

0 Members and 1 Guest are viewing this topic.

Offline Tom Ehrensperger

  • Posts: 2,701
  • OS/Browser:
  • Win NT 10.0
  • Firefox 64.0
New WXSIM to try!
« on: December 31, 2018, 02:45:09 AM »
I've been working hard the last few days on a new feature (requested by a WXSIM user): boundary layer predictions, like depth and strength of nocturnal temperature inversions, mixed layer height, capping inversion height, etc.  I also made a couple of minor formatting changes (like now displaying a decimal place on the normal min and max temperatures for the date, on the Data Entry form).

I've also prepared a document (which will be part of the updated manual, which I'm working on now) to explain the new outputs.  A very common use for such information is the trapping versus dispersal of pollutants, so it can be pretty relevant.

I haven't made an installer for this, as it's a "beta" version which I'd like a few days of testing on before releasing, so I'm posting a link to the actual .exe, with which to replace wxsim.exe:

www.wxsim.com/wxsim.exe

and here's that document

www.wxsim.com/Boundary Layer Predictions.docx

Also, if you haven't yet tried it, here's the new WXSIMATE, with updated URL's:

www.wxsim.com/wxsimate.exe

I'm hoping to have this all packaged up for official release soon, so let me know how it goes.  Thanks for all the support this community has given WXSIM!

And Happy New Year!!

Tom


Offline oreitsma

  • Posts: 559
  • Assen, Netherlands
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • Weerstation Assen
Re: New WXSIM to try!
« Reply #1 on: January 01, 2019, 09:32:52 AM »
Hi Tom,

First I wish you Happy New Year.

This morning I had for the second time a Division by Zero error.
After update to this latest version I had it 2 times.

May be a bug?

Brgds,
Oebel

Offline emsiwx22

  • Posts: 116
  • Bytca
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 70.0.3538.102
    • AMS EmsiWx Bytca, Slovakia
Re: New WXSIM to try!
« Reply #2 on: January 04, 2019, 02:24:38 PM »
Hi Tom,

I gave the new version a try. First run completed with no issues.

However, when I imported the new csv file, I get some strange values (screen attached).

Thank you for your time and great job.

EmsiWx

Offline Tom Ehrensperger

  • Posts: 2,701
  • OS/Browser:
  • Win NT 10.0
  • Firefox 64.0
Re: New WXSIM to try!
« Reply #3 on: January 04, 2019, 10:36:42 PM »
If you get those strange values, you probably use commas instead of periods in your regional Windows settings, but there's an accommodation for this.  Go to Start/Auto Run and Other Settings, and find and check the box that sys "Use semicolons instead of commas in .csv files", and let me know if that fixes it!

Tom

Offline Tom Ehrensperger

  • Posts: 2,701
  • OS/Browser:
  • Win NT 10.0
  • Firefox 64.0
Re: New WXSIM to try!
« Reply #4 on: January 04, 2019, 10:37:52 PM »
New version!  Hopefully fixes the bug Oebel and one other person have told me about.  Try this:

www.wxsim.com/wxsim.exe

It's called WXSIM 2019, Build 1.0 beta.

Thanks!

Tom

Offline emsiwx22

  • Posts: 116
  • Bytca
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 70.0.3538.102
    • AMS EmsiWx Bytca, Slovakia
Re: New WXSIM to try!
« Reply #5 on: January 04, 2019, 11:25:57 PM »
If you get those strange values, you probably use commas instead of periods in your regional Windows settings, but there's an accommodation for this.  Go to Start/Auto Run and Other Settings, and find and check the box that sys "Use semicolons instead of commas in .csv files", and let me know if that fixes it!

Tom

Thank you Tom. That helped.

Offline Tom Ehrensperger

  • Posts: 2,701
  • OS/Browser:
  • Win NT 10.0
  • Firefox 64.0
Re: New WXSIM to try!
« Reply #6 on: January 05, 2019, 02:45:49 AM »
Yet another version!  My last one neglected to archive the latestblyr.csv files in a user-specifed place (like the other .csv files)_.  Fixed now, I think.  It's 2019, Build 1.0 beta2, and is at

www.wxsim.com/wxsim.exe

Thanks!

Tom

Offline Tom Ehrensperger

  • Posts: 2,701
  • OS/Browser:
  • Win NT 10.0
  • Firefox 64.0
Re: New WXSIM to try!
« Reply #7 on: January 05, 2019, 04:06:01 PM »
One more!  I'd left the new file out of a section of code for archiving forecasts.  Think I've got it now.  This is beta3:

www.wxsim.com/wxsim.exe

Offline oreitsma

  • Posts: 559
  • Assen, Netherlands
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • Weerstation Assen
Re: New WXSIM to try!
« Reply #8 on: January 06, 2019, 07:46:58 AM »
Hi Tom,

It seems that my division by zero problem is solved.
Thanks!

Best regards,
Oebel