cloudy cloudy

Author Topic: MySQL Error  (Read 627 times)

0 Members and 1 Guest are viewing this topic.

Offline 3DAdamsWeather

  • Posts: 10
  • Tualatin, OR USA
  • OS/Browser:
  • Mac OS X 10.14.3
  • Safari 12.0.3
    • 3DAdams Weather
MySQL Error
« on: December 17, 2018, 11:47:15 PM »
When I try to run the cronmysql to create a MySQL database for Weather Display, I get the following error.

ERROR: [FireDAC][Phys][MySQL]-314. Cannot load vendor library [libmysqlclient.dylib or libmysqld.dylib]. Hint: check it is in the PATH or application EXE directories, and has x86 bitness. at time/date 3:08:17 PM 12/17/18

I originally thought that it was that Weather Display could not find the dylibs for MySQL client.  I have followed all kinds of steps that I have found on the Internet, but none of them have worked.  I noticed that MySQL is a 64-bit application and Weather Display is a 32-bit application and am wondering if this is the issue.  I am running Mohave 10.14.2 and MySQL 5.7.24. 

Is this version compatible with Weather Display or should I be running another version?  Anybody got any ideas on how to resolve this issue?

Thanks,

Don
Don Adams
dsadams@3dadams.org

Offline GW400

  • Posts: 83
  • Klepp, Norway
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
Re: MySQL Error
« Reply #1 on: February 04, 2019, 09:33:48 AM »
Did you find an answer regarding 32bits versus 64bits MySQL?
Regards G400

Online Weather Display

  • Posts: 87,220
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 71.0.3578.98
    • Weather Display
Re: MySQL Error
« Reply #2 on: February 04, 2019, 06:37:23 PM »
I don't think its related to 32 or 64 bit at all
its more related to the path to the driver

 

cumulus