cloudy cloudy

Author Topic: Index screen problem  (Read 130 times)

0 Members and 1 Guest are viewing this topic.

Offline jahuff

  • Posts: 968
  • Northern New Hampshire, USA
  • OS/Browser:
  • Mac OS X 10.14.1
  • Safari 12.0.1
    • Weather Data Pittsburg, NH
Index screen problem
« on: November 21, 2018, 02:27:38 PM »
Hi Everyone,

Has anyone experienced this type of problem?

It started showing up about two months ago. At first it happened very infrequently but now its more frequent. Every few days it happens.

This is the message I Get from my service provider when I ask them for help.

"
The domain johnsnhweather.com is accessible but showing a white screen on our end.

Checking the access logs of this domain I could see below entries which were already mentioned by my colleague.

==============
[21-Nov-2018 08:50:00 America/New_York] PHP Parse error: syntax error, unexpected ';' in /home/johnsnh/public_html/testtags.php on line 1002
[21-Nov-2018 08:50:02 America/New_York] PHP Parse error: syntax error, unexpected ';' in /home/johnsnh/public_html/testtags.php on line 1002
[21-Nov-2018 08:50:04 America/New_York] PHP Parse error: syntax error, unexpected ';' in /home/johnsnh/public_html/testtags.php on line 1002
[21-Nov-2018 08:50:05 America/New_York] PHP Parse error: syntax error, unexpected ';' in /home/johnsnh/public_html/testtags.php on line 1002
[21-Nov-2018 08:50:09 America/New_York] PHP Parse error: syntax error, unexpected ';' in /home/johnsnh/public_html/testtags.php on line 1002
==============
"

A completely white screen is the only thing that shows on the screen.

Unfortunately I'm not as technically savvy as I should be. Any help would be greatly appreciated.

Thanks,

John

www.johnsnhweather.com

Offline niko

  • syzygy
  • Global Moderator
  • Posts: 27,666
  • Crystal Ball broken! Please post the URL.
  • Northern California, U.S.A.
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 70.0.3538.102
Re: Index screen problem
« Reply #1 on: November 21, 2018, 04:30:05 PM »
I've looked at it a couple of times and it's working OK for me. You need to look at line 1002 of testtags.php when it is failing. Looking at your testtags.php http://www.johnsnhweather.com/testtags.php?sce=view in a browser line 1002 is:

$maxtempyest = 25.9;

My best guess is that tag sometimes doesn't return a value like:

$maxtempyest = ;

which will trigger the error that you are seeing.

Hope this will help you to diagnose the problem.

Offline jahuff

  • Posts: 968
  • Northern New Hampshire, USA
  • OS/Browser:
  • Mac OS X 10.14.1
  • Chrome 70.0.3538.102
    • Weather Data Pittsburg, NH
Re: Index screen problem
« Reply #2 on: November 21, 2018, 04:34:58 PM »
Thanks niko,

I'll keep trying to figure it out.

John

Offline Weather Display

  • Posts: 85,438
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.102
    • Weather Display
Re: Index screen problem
« Reply #3 on: November 21, 2018, 07:54:25 PM »
make sure you are using the latest version re that custom tag

Offline jahuff

  • Posts: 968
  • Northern New Hampshire, USA
  • OS/Browser:
  • Mac OS X 10.14.1
  • Chrome 70.0.3538.102
    • Weather Data Pittsburg, NH
Re: Index screen problem
« Reply #4 on: November 21, 2018, 10:09:41 PM »
Thanks Brian, I just updated to the latest version. I was on build 82.

John

 

cumulus