cloudy cloudy

Author Topic: WMR200 history data not logged or graphed  (Read 372 times)

0 Members and 1 Guest are viewing this topic.

Offline bitsostring

  • Posts: 614
  • Oregon Scientific WMR200
  • Edinburgh, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
WMR200 history data not logged or graphed
« on: November 14, 2018, 03:50:22 PM »
As reported here and here WD is not logging or graphing history data from the WMR200. I have no idea how long this has been going on, as WD normally runs 24/7 unless Windows 10 surprises me with an update restart - which happened again today. I didn't notice for half an hour: on restarting WD the history data was read and ignored.
It's meant to be fun. . .

Offline bitsostring

  • Posts: 614
  • Oregon Scientific WMR200
  • Edinburgh, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: WMR200 history data not logged or graphed
« Reply #1 on: December 12, 2018, 12:37:02 PM »
Another 11 minutes data lost for a Windows update/restart today. WMR History vers 1.3 reads history data OK, then it runs again (why?), but then the history data is not decoded, logged or graphed. I tried converting the history.txt file to a log file but if that worked I don't know where it ended up. Running 10.37S84.
« Last Edit: December 12, 2018, 12:50:03 PM by bitsostring »
It's meant to be fun. . .

Offline bitsostring

  • Posts: 614
  • Oregon Scientific WMR200
  • Edinburgh, UK
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • Home Weather Station
Re: WMR200 history data not logged or graphed
« Reply #2 on: January 14, 2019, 11:31:39 PM »
Another 12 minutes' graph/log lost for a Win 10 update/restart.
It's meant to be fun. . .

Offline bitsostring

  • Posts: 614
  • Oregon Scientific WMR200
  • Edinburgh, UK
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • Home Weather Station
Re: WMR200 history data not logged or graphed
« Reply #3 on: January 18, 2019, 12:39:06 PM »
Another 7 minutes lost for an update/restart. The history data is not being decoded. Running 10.37S86.

It's meant to be fun. . .

Offline bitsostring

  • Posts: 614
  • Oregon Scientific WMR200
  • Edinburgh, UK
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • Home Weather Station
Re: WMR200 history data not logged or graphed
« Reply #4 on: January 20, 2019, 03:00:17 PM »
Today I have an hour's data in wmr200history.txt after a "feature upgrade" to Win10 (1803 to 1809). As before, WMR200 History vers 1.3 runs twice and gets the data from the console, but it is not decoded. The WMR200 History Data decoding screen appears, and the raw data is shown on the screen, but then it immediately shows "Finished" and disappears. No data is added to the log or the graphs, and there is no time to check that it is showing the right start time or to change it.

How do I convert the history.txt file into log/data files?

I looked at Control Panel / Data Logger but there is no way of specifying the .txt file instead of the console logger.

Action / Convert log files to data doesn't cover it, as far as I can see, and nor does Action / Import log files.
It's meant to be fun. . .

Offline bitsostring

  • Posts: 614
  • Oregon Scientific WMR200
  • Edinburgh, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: WMR200 history data not logged or graphed
« Reply #5 on: January 30, 2019, 10:57:02 PM »
WD just stopped running tonight. . . another hour and a half's data in wmr200history.txt not decoded.

How do I convert this to log/data?
It's meant to be fun. . .

Offline bitsostring

  • Posts: 614
  • Oregon Scientific WMR200
  • Edinburgh, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
    • Home Weather Station
Re: WMR200 history data not logged or graphed
« Reply #6 on: February 13, 2019, 11:29:15 PM »
Another 9 minutes lost for a Win10 update, console logger data read but not decoded.
It's meant to be fun. . .