cloudy cloudy

Author Topic: Some tags now empty!  (Read 370 times)

0 Members and 1 Guest are viewing this topic.

Offline R_o_B

  • Posts: 221
  • Maple Bay, British Columbia, Canada
  • OS/Browser:
  • Win NT 10.0
  • Firefox 52.0
    • Tzouhalem-Maple Bay Weather
Some tags now empty!
« on: November 11, 2018, 09:22:25 AM »
Brian, what should I check.

For the past days, some tags that used to contain data are now empty of data such as (as of today, November 11 at 01:10):
  • maxhourrnt
  • maxhumyest
  • maxhumyestt
  • minbaroyest
  • minbaroyestt
The only change I made to my system was to update Weather Display to the latest release (ie: build 83, dated November 5, 2018).

I am running the same version/build of Weather Display on two different computers and the same tags are missing values (the tags are empty) on both computers.

What/where should I look for a cause to the problem, for a solution?

It seems the above mentioned tags have been 'disappearing' with one of the latest updates of Weather display.

Other than the update to the latest releases of Weather Display, nothing (none of the settings) has been changed.
R_o_B
---
eMail: weather@tzweather.org

Offline gwwilk

  • Posts: 657
  • Lincoln, NE
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.77
    • Southeast Lincoln Weather
Re: Some tags now empty!
« Reply #1 on: November 11, 2018, 03:50:59 PM »
There's a later version of WD dated 9 Nov 2018 that fixes these bugs.
Regards, Jerry Wilkins
gwwilk@inebraska.com

Offline Weather Display

  • Posts: 85,438
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.77
    • Weather Display
Re: Some tags now empty!
« Reply #2 on: November 11, 2018, 06:12:30 PM »
yeah, my bad  #-o
update to the latest ;)

Offline R_o_B

  • Posts: 221
  • Maple Bay, British Columbia, Canada
  • OS/Browser:
  • Win NT 10.0
  • Firefox 52.0
    • Tzouhalem-Maple Bay Weather
Re: Some tags now empty!
« Reply #3 on: November 11, 2018, 06:13:12 PM »
Jerry, thank you for the suggestion ... but even after installing the latest update of Weather Display (dated November 9th), I am still getting many tags that are empty, whereas, a weeks or so ago, those tag contained data!

On computer #1 (where I run Weather Display to provide data for my local/development web pages), the tags that used to contain data and that are now empty of data are (as of today, November 11 at 10:00)(the data has been 'disappearing' from even more tags since yesterday):
  • highbaro
  • highbarot
  • highhumt
  • lowhumt
  • maxheat
  • maxhourrnt
  • maxhumyest
  • maxhumyestt
  • maxwindchill
  • maxwindchillt
  • minbaroyest
  • minbaroyestt
  • mindew
  • mindewt
  • minheat
  • minwindch
  • minwindcht
On computer #2 (where I run Weather Display to upload data to my old web site and to some online weather providers), the tags that used to contain data and that are now empty of data are (as of today, November 11 at 10:00):
  • maxgsthrtime
  • maxgustlastimediatehourtime
As I wrote in my previous message, I have not changed any of Weather Display's settings for weeks if not months (on either of the computers).

So, my question, what/where should I look for a cause to the problem, for a solution?

Those missing tags are really 'destroying' the appearance of my web pages...  :x
R_o_B
---
eMail: weather@tzweather.org

Offline Weather Display

  • Posts: 85,438
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.77
    • Weather Display
Re: Some tags now empty!
« Reply #4 on: November 11, 2018, 09:55:25 PM »
you still not might have the latest update
try downloading again

also a test
if you go to view, daily hi/low, in WD, does that then fix the tags on the next tags update?

Offline hcorrin

  • Posts: 1,213
  • Ballaugh Isle of Man GB
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • Ballaugh Weather
Re: Some tags now empty!
« Reply #5 on: November 11, 2018, 11:21:02 PM »
Hi have just tested the tags from your list on my test / backup unit all work with latest 83 build from 9 November except %maxgsthrtime% which on checking the testtags.txt should be %maxgustlastimediatehourtime%

Offline R_o_B

  • Posts: 221
  • Maple Bay, British Columbia, Canada
  • OS/Browser:
  • Win NT 10.0
  • Firefox 52.0
    • Tzouhalem-Maple Bay Weather
Re: Some tags now empty!
« Reply #6 on: November 12, 2018, 01:53:11 PM »
you still not might have the latest update
try downloading again
Brian, I have the latest version, the one that was updated on November 12.

also a test
if you go to view, daily hi/low, in WD, does that then fix the tags on the next tags update?
Did not fix!  :(

On the 'Extra Daily High/Low Weather Parameters' window, there are many boxes without any value under the columns for yesterday.

Here are the tags that are 'still' missing some data (either a value or a time or both are missing)(as of 05h45 on November 12 PST):
  • maxbaroyest = yesterday high barometer value
  • maxbaroyestt = yesterday high barometer time
  • maxgustlastimediatehourtime = max gust last prior 1 hour time
  • maxhourrnt = maximum rain last hour for the day time
  • minchillyest = yesterday's minimum wind chill value
  • minchillyestt = yesterday's minimum wind chill time
  • mindewyest = yesterday's minimum dew point value
  • mindewyestt = yesterday's minimum dew point time
  • minheatyest = yesterday's minimum heat index value
  • mintempyestt = yesterday's minimum temperature time

What is really really odd is that the two copies (same version number) of Weather Display that I am running on two different computers (with no interaction between each computers) have started producing the same empty tags at the same time!  8O

What else could I checked, could one data file (or more) produced by Weather Display got corrupted? The tags without value are really messing up my web pages.

Hi have just tested the tags from your list on my test / backup unit all work with latest 83 build from 9 November except %maxgsthrtime% which on checking the testtags.txt should be %maxgustlastimediatehourtime%
My Weather Display is producing two different variables using the same tag - I should have quoted the variable ''$maxgustlastimediatehourtime' which is produced by the tag '%maxgustlastimediatehourtime%' rather than the variable '$maxgsthrtime' which is also produced by the tag '%maxgustlastimediatehourtime%'. Sorry.

R_o_B
---
eMail: weather@tzweather.org

Offline Weather Display

  • Posts: 85,438
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.77
    • Weather Display
Re: Some tags now empty!
« Reply #7 on: November 12, 2018, 07:25:59 PM »
the .zip update now has a new build number
so you will know if you have the latest

Offline R_o_B

  • Posts: 221
  • Maple Bay, British Columbia, Canada
  • OS/Browser:
  • Win NT 10.0
  • Firefox 52.0
    • Tzouhalem-Maple Bay Weather
Re: Some tags now empty!
« Reply #8 on: November 13, 2018, 02:10:25 PM »
the .zip update now has a new build number
so you will know if you have the latest
Brian, my computers were indeed running the latest version of Weather Display (build 84, with the latest file dated November 12).

Fortunately, it was after Weather Display cross-over midnight that the tags got reset. It now appears that the only tags without data are:
  • maxgustlastimediatehourtime == time that the max gust last prior 1 hour occurred
  • maxhourrnt == time that the max rain last hour for the day occurred
R_o_B
---
eMail: weather@tzweather.org

Offline Weather Display

  • Posts: 85,438
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.77
    • Weather Display
Re: Some tags now empty!
« Reply #9 on: November 13, 2018, 08:57:17 PM »
see if they come correct

Offline R_o_B

  • Posts: 221
  • Maple Bay, British Columbia, Canada
  • OS/Browser:
  • Win NT 10.0
  • Firefox 52.0
    • Tzouhalem-Maple Bay Weather
Re: Some tags now empty!
« Reply #10 on: November 14, 2018, 02:38:32 PM »
see if they come correct
Both tags have data again - I guess that some time was needed for all the 'broken' tags to 'mend' themselves.  :wink:

Brian, what do you think might have caused those specific tags to suddenly go empty, at the same time on two computers (same operating system Windows 10 Pro but very different hardware) running the same version of Weather Display?
R_o_B
---
eMail: weather@tzweather.org

Offline bitsostring

  • Posts: 506
  • Oregon Scientific WMR200
  • Edinburgh, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.140
Re: Some tags now empty!
« Reply #11 on: November 15, 2018, 07:43:48 PM »
what . . . might have caused those specific tags to suddenly go empty, at the same time on two computers

I gather from this thread that there was a bug in the early release of build 83 that you were using. Hence replies #1 and #2 to your post.
It's meant to be fun. . .

 

cumulus