cloudy cloudy

Author Topic: SYNOP (and some RAOB) URL problems in WXSIMATE  (Read 217 times)

0 Members and 1 Guest are viewing this topic.

Offline Tom Ehrensperger

  • Posts: 2,610
  • OS/Browser:
  • Win NT 10.0
  • Firefox 63.0
SYNOP (and some RAOB) URL problems in WXSIMATE
« on: November 09, 2018, 01:36:43 AM »
I'm aware that recently, seemingly all of WXSIMATE's synoptic data sources (I don't use SYNOP myself, preferring METAR) have quit working.  The FSU links are affected by their decision to require (free) registration.  I haven't tried registering yet.  Have any of you tried?  And have the links changed?

The one I was working on tonight is the COD (digatmos) one.  The URL is now https instead of just http, and I tried hard-coding that change, but it still gives me a "cannot establish connection with the secure server channel SSL/TLS", or something like that.  This isn't a field of expertise for me.  Doers anyone have any ideas or information?

Thanks!

Tom

Offline DrRob

  • Posts: 18
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.77
Re: SYNOP (and some RAOB) URL problems in WXSIMATE
« Reply #1 on: November 13, 2018, 01:19:01 AM »
Hi Tom.
The fix should be relatively simple.
WXSIMATE is requesting the data using TLSv1 but the website is wanting TLSv1.2.
Your assembler should have a process for the upgrade of the TLS procedure.

The actual error received by the app is Fatal alert, Handshake Failure on the TLSv1 protocol.

The process for redirecting to https is working ok. WXSIMATE is being redirected to https:\\ but is then failing due to the less secure TLSv1 handshake.

Hope this gets you in the right direction.

Rob

 

cumulus