cloudy cloudy

Author Topic: Configuration lost after crash  (Read 213 times)

0 Members and 1 Guest are viewing this topic.

Offline tipd

  • Posts: 4
  • OS/Browser:
  • Win NT 6.3
  • Chrome 70.0.3538.77
Configuration lost after crash
« on: November 05, 2018, 09:37:39 PM »
Hi all

My windows 8.1 PC crashed last night and on starting Weather Display (version 10.37S14) all the configuration appears to have been lost i.e on startup it prompts for the language and the colours/units are back to what I guess are the defaults and no data is being received from the Davis Vantage Pro2. What does remain are two animations I setup on the main screen.

I recovered WDISPLAY.INI file from before the crash but it made no difference, the recovered file was 24kb but after starting WD the file was 2kb if that means anything.

Any ideas on how I might recover from this situation?

Thanks

Offline Weather Display

  • Posts: 85,313
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 70.0.3538.77
    • Weather Display
Re: Configuration lost after crash
« Reply #1 on: November 05, 2018, 11:46:47 PM »
see if you have a back up of that settings file in the folder databackup

Offline tipd

  • Posts: 4
  • OS/Browser:
  • Win NT 6.3
  • Chrome 70.0.3538.77
Re: Configuration lost after crash
« Reply #2 on: November 06, 2018, 08:28:32 AM »
Hi, I copied wdisplay.ini from databackup to c:\wdisplay and it looks to have fixed the problem except the chart customisations have been lost but not a big deal.

Many thanks for your help.


Offline tipd

  • Posts: 4
  • OS/Browser:
  • Win NT 6.3
  • Chrome 70.0.3538.77
Re: Configuration lost after crash
« Reply #3 on: November 06, 2018, 05:00:17 PM »
Hi, looking a bit more closely I see the monthly and annual rain totals are wrong on the main screen.

Looking at the logfile I see the discontinuity:

 5 11 2018  3 19 05.8  96 05.2 1003.5 0.0 0.0 348 0.0 0.0 7.8 391.8 5.8
 5 11 2018  3 20 05.8  96 05.2 1003.6 0.0 0.0 348 0.0 0.0 7.8 391.8 5.8
 5 11 2018  3 22 05.6  96 05.0 1003.8 0.0 0.0 338 0.0 0.0 21.8 118.6 5.6
 5 11 2018  3 23 05.6  96 05.0 1003.8 0.0 0.0 338 0.0 0.0 21.8 118.6 5.6

Note I recovered the data after the PC crash from from the datalogger beginning at 03:22.

Should I just fix this by editing the values on ALL the bad lines in the logfile or will it work just to edit the very last line?

Thanks

Offline Martyn

  • Davis VP2+ FARS/solar/UV
  • Posts: 930
  • Bristol, UK
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 62.0
    • Horfield/Filton, Bristol, UK weather station
Re: Configuration lost after crash
« Reply #4 on: November 06, 2018, 05:07:55 PM »
Hi, in WD go to control panel -> offsets and initial rain,  and you can set the monthly and yearly totals on the rain totals tab there and the log and datafiles will take the new values going forward and on the main screen also.
« Last Edit: November 06, 2018, 05:10:03 PM by Martyn »
Martyn,
Bristol, UK

Twitter: https://twitter.com/HorfieldWeather
FB: https://www.facebook.com/bristolweather
CWOP: CW2888
WU: IBRISTOL3

Offline tipd

  • Posts: 4
  • OS/Browser:
  • Win NT 6.3
  • Chrome 70.0.3538.77
Re: Configuration lost after crash
« Reply #5 on: November 07, 2018, 07:09:52 PM »
Hi thanks a lot, that worked great.

Just for info, the Averages/Extremes under View was missing data for the 1/2/3rd Nov but fixed this using "Convert log files to data files" feature.

Hopefully we're back to normal now.

 

cumulus