cloudy cloudy

Author Topic: 2nd WD crash  (Read 314 times)

0 Members and 1 Guest are viewing this topic.

Offline jmviper

  • Posts: 59
  • Murcia, SPAIN
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • MeteoArchena
2nd WD crash
« on: August 23, 2018, 12:51:38 PM »
Hi

I've always had running 2 WDs (one with Davis station and the other with Oregon WMR100N) without problems until today that Windows 10 has been updated with a security update (Version 1803 KB4100347).

After update reboots I've started Davis WD normally but when I've started Oregon WD a crash window has appeared (see attachment).

I've removed wdisplay2.ini (actually cut & paste) and tried to run but with no success. Also I've tried to start it alone (not starting Davis WD) but no success.

Something's wrong with that Windows Update ?

« Last Edit: August 23, 2018, 03:32:25 PM by jmviper »
 
  Davis Vantage Pro2 Plus
 www.meteoarchena.es

Offline Weather Display

  • Posts: 85,086
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 68.0.3440.106
    • Weather Display
Re: 2nd WD crash
« Reply #1 on: August 23, 2018, 08:42:42 PM »
try also deleting the wdisplayftp2.ini settings file in the registry

Offline jmviper

  • Posts: 59
  • Murcia, SPAIN
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • MeteoArchena
Re: 2nd WD crash
« Reply #2 on: August 23, 2018, 10:53:08 PM »
try also deleting the wdisplayftp2.ini settings file in the registry

No success…

I've tested several options… I've renamed WD Oregon folder (named WD2 formerly) and I've installed a fresh WD in WD2 empty folder, I've put into 2wd.txt file and not working yet.

I've tried to remove 2wd.txt file from WD2 folder and I've started Davis WD and can't get started… same error.

I think there is a conflict between the both WDs

 
  Davis Vantage Pro2 Plus
 www.meteoarchena.es

Offline BWX

  • Posts: 165
  • OS/Browser:
  • Win NT 10.0
  • Chrome 68.0.3440.106
Re: 2nd WD crash
« Reply #3 on: August 24, 2018, 03:38:52 AM »
Doe you have any custom images on the WD main screen on either?

Offline jmviper

  • Posts: 59
  • Murcia, SPAIN
  • OS/Browser:
  • Android 4.2.2
  • Safari 4.0
    • MeteoArchena
Re: 2nd WD crash
« Reply #4 on: August 24, 2018, 04:21:43 AM »
Doe you have any custom images on the WD main screen on either?

Not that I know of....
 
  Davis Vantage Pro2 Plus
 www.meteoarchena.es

Offline BWX

  • Posts: 165
  • OS/Browser:
  • Win NT 10.0
  • Chrome 68.0.3440.106
Re: 2nd WD crash
« Reply #5 on: August 24, 2018, 04:56:22 AM »
Does it crash straight away?

There could be a corrupt image that is causing this, i saw something similar on another forum hence mentioning the custom image, have you tried reinstalling WD (Full version not zip)

Another thing to check is the images in both wd main folder and the webfiles folder and download folder if the latter is in use, the way to do this is 1, set the folder to view icons and not list, then scroll through and check that all images look ok, 2, check the image sizes to make sure none have a size that looks incorrect, e.g 1kb when it should be at least 10kb, this is not an infallible way but it can be a quick way to go through them.

Offline jmviper

  • Posts: 59
  • Murcia, SPAIN
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • MeteoArchena
Re: 2nd WD crash
« Reply #6 on: August 24, 2018, 04:37:35 PM »
Thanks for trying to help

I've tried a fresh Oregon WD install with no result. I don't have custome images in any of the both WDs.

Bar progress at startup is stopped in the attachment (Loading settings). If this startup can be dumped on a file... just let me know to do it
 
  Davis Vantage Pro2 Plus
 www.meteoarchena.es

Offline BWX

  • Posts: 165
  • OS/Browser:
  • Android 7.0
  • Chrome 68.0.3440.91
Re: 2nd WD crash
« Reply #7 on: August 24, 2018, 04:55:37 PM »
You need Brian for that but I bet there is a corrupt image.

Offline Weather Display

  • Posts: 85,086
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 68.0.3440.106
    • Weather Display
Re: 2nd WD crash
« Reply #8 on: August 24, 2018, 07:20:51 PM »
email me your settings files
the wdisplay2.ini and wdisplayftp2.reg files, zipped, after going action, back up registry entry now, in WD

Offline jmviper

  • Posts: 59
  • Murcia, SPAIN
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • MeteoArchena
Re: 2nd WD crash
« Reply #9 on: August 24, 2018, 08:26:14 PM »
Fixed… As I mentioned above I've made a fresh install in WD2 (Oregon WD, the problematic one) and it crashed at startup. I copied and pasted the former content of that folder (datafiles, logfiles, etc etc) in other folder (called WD2-b).
It occurred to me starting weatherdisplay.exe in that folder (WD2-b) and it started fine. In WD2 folder not in a fresh install.
So I've created a folder named wdisplay2 and put all files in there and is running OK.

Perhaps there's something wrong with WD2 folder name in registry Windows or something like that… anyway as I said now is running OK

Thanks for your help
 
  Davis Vantage Pro2 Plus
 www.meteoarchena.es

 

cumulus