cloudy cloudy

Author Topic: Rain Stats in Trends  (Read 4501 times)

0 Members and 1 Guest are viewing this topic.

Offline yamiacaveman

  • Posts: 148
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
Rain Stats in Trends
« on: July 26, 2018, 08:39:01 PM »
http://www.pennlake.us/

http://www.pennlake.us/wxtrends.php

 Weather-Display   (10.37S-(b75)

I'm not sure when this happened but I am missing Last month and total last year at this time.

I did post over in the WX forum, but I am not sure if this is a WD or WX issue, or my own issue.

yamiacaveman



Records and Stats
RAIN   RAIN HISTORY
Today   0.00 in (0.00 in last hour)   Today   0 days since last rain on 25-Jul-2018 11:26pm
Yest.   1.18 in   Week   5.280 in over last 7 days.
Month   6.09 in (11 rain days this month)   Month   0.00 in last month.
Year   28.22 in ( 110 rain days this year)   Year   0.00 in total last year at this time.

Offline Weather Display

  • Posts: 85,426
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
    • Weather Display
Re: Rain Stats in Trends
« Reply #1 on: July 26, 2018, 11:50:22 PM »
if you go to view, rain chart
do you see the correct rain totals there for the months in question


Offline yamiacaveman

  • Posts: 148
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
Re: Rain Stats in Trends
« Reply #2 on: July 27, 2018, 01:15:25 AM »
Yes, View Rain chart, also In the Temp/Wind/Rain chart under view.

Offline yamiacaveman

  • Posts: 148
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
Re: Rain Stats in Trends
« Reply #3 on: August 01, 2018, 11:19:10 AM »
Weather Display install file  v 10.37S Build 75

Ok so - Question, if you go here and view my Records and Stats - Rain History - Month 0.00 in last month -- is this suppose to show the total of last month's rain or is it a measure of something else?

Second, to update that section I must now go to View - Trends and do a manual reset.

Conversation over at Wx http://www.wxforum.net/index.php?topic=34818.0

Thanks for any help

Offline yamiacaveman

  • Posts: 148
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
Re: Rain Stats in Trends
« Reply #4 on: August 01, 2018, 11:24:21 AM »
Ok another update:

Just saw and updated Weather Display to Weather Display install file  v 10.37S Build 76 installed and now under the Records and Stats - Year that total is back to 0.00

Going back to View - Trends - refresh - ok to see it that resovles the issue again.

Offline yamiacaveman

  • Posts: 148
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
Re: Rain Stats in Trends
« Reply #5 on: August 01, 2018, 11:30:03 AM »
So yes the manual refresh updated the year but not the month.

Offline Weather Display

  • Posts: 85,426
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
    • Weather Display
Re: Rain Stats in Trends
« Reply #6 on: August 01, 2018, 06:25:59 PM »
if you are using a custom web page that uses the trends custom tags then you need to make sure that you have the trends web data updated at least daily
(i.e set a time for that to be created)

Offline gwwilk

  • Posts: 657
  • Lincoln, NE
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
    • Southeast Lincoln Weather
Re: Rain Stats in Trends
« Reply #7 on: August 01, 2018, 06:37:32 PM »
I create the 'trends.gif' every minute, yet all day now it's displaying '0.00' for 'Rain Last Month'.  This is most likely a bug, Brian, because it's universal for those of us who have checked.  I suspect that this is only the case on the first day of the month, i.e. it's a boundary problem.
Regards, Jerry Wilkins
gwwilk@inebraska.com

Offline Weather Display

  • Posts: 85,426
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
    • Weather Display
Re: Rain Stats in Trends
« Reply #8 on: August 01, 2018, 06:46:39 PM »
yes, will be likely a problem that occurs on the 1st day of the month
updating that every minute could be a bit of over kill  8O

Offline yamiacaveman

  • Posts: 148
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
Re: Rain Stats in Trends
« Reply #9 on: August 01, 2018, 08:20:52 PM »
Hey Jerry, I don't have "trends.gif" turned on at all -- neither create or upload.

I did notice I had the Temperature panel #42 to upload but not to create, and now i did turn both on, to create and upload, but no difference in the problem.

Offline Weather Display

  • Posts: 85,426
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
    • Weather Display
Re: Rain Stats in Trends
« Reply #10 on: August 01, 2018, 09:15:42 PM »
its not clear what the current problem is now though
?

Offline yamiacaveman

  • Posts: 148
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
Re: Rain Stats in Trends
« Reply #11 on: August 02, 2018, 12:09:22 AM »
Well, the problem seems to be the last month and possible the last year totals in the weather trends --  Going to View Trends and refreshing clears the year problem but not the last month problem???? I am not sure how long my problem has been around, I just happened to notice it the other day, at first I thought it was the latest update, so I went back to 73? and had the same issue, I have also looked at people still using b63 -- they have the last year but still show 0.00 rain from last month. That's about all I can tell you.

Offline johnmac78

  • Posts: 57
  • Westminster, Massachusetts USA
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 67.0.3396.99
    • Village at Old Mill - Weather
Re: Rain Stats in Trends
« Reply #12 on: August 02, 2018, 12:50:54 AM »
I also have the same issue. Trends chart in WD does not show last month rainfall and Last year and Last month are 0.00 in wxtrends.php in the Saratoga Template. Did not understand the discussion about file #42 in WD, which has something to do with temperature not rain in my version. Sorry to muddy the waters more! Weather Display Ver 10.37S61. Cross posted at http://www.wxforum.net/index.php?topic=34818.0
John
scannorthcounty.net

Offline Weather Display

  • Posts: 85,426
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
    • Weather Display
Re: Rain Stats in Trends
« Reply #13 on: August 02, 2018, 10:58:03 PM »
it might have been a first day of the month issue

its still not all that clear me the exact issue
screen shots help a lot ;)

Offline gwwilk

  • Posts: 657
  • Lincoln, NE
  • OS/Browser:
  • Win NT 10.0
  • Chrome 67.0.3396.99
    • Southeast Lincoln Weather
Re: Rain Stats in Trends
« Reply #14 on: August 02, 2018, 11:41:58 PM »
The problem persists on August 2, 2018, Brian:

Regards, Jerry Wilkins
gwwilk@inebraska.com

 

cumulus