cloudy cloudy

Author Topic: Rainwise 1-wire gauge not registering tips  (Read 648 times)

0 Members and 1 Guest are viewing this topic.

Offline mickopla

  • Posts: 242
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 66.0.3359.139
    • Waterford City Weather, Ireland
Rainwise 1-wire gauge not registering tips
« on: May 13, 2018, 08:38:31 PM »
I had issues with my Rainwise 1-wire gauge a few years ago when tips were not registering in the 1-wire reader software and WD. Eventually i fixed the issue by replacing the reed switch. Unfortunately the old problem came back a few weeks ago. It was a very random problem this time with the gauge working on and off with no obvious pattern.

I decided yesterday to change the reed switch as i did have some left from my previous problems. Changing the reed has not fixed the issue with no tips registering. Brian suggested a few years ago the magnet may have lost its magnetism but ive checked and its not the case.
Where do i go from here with the trouble shooting procedure??

Offline Weather Display

  • Posts: 84,697
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 66.0.3359.139
    • Weather Display
Re: Rainwise 1-wire gauge not registering tips
« Reply #1 on: May 14, 2018, 04:25:05 AM »
have you checked with a volt meter (ohm meter?) if its working?

Offline mickopla

  • Posts: 242
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 66.0.3359.139
    • Waterford City Weather, Ireland
Re: Rainwise 1-wire gauge not registering tips
« Reply #2 on: May 14, 2018, 11:07:52 AM »
have you checked with a volt meter (ohm meter?) if its working?

Yes managed to do some tests this morning and the reed is working fine. When the bucket is tipped i hear audio from the meter and the reading  drops to zero so continuity is achieved. So somehow the counter is not picking up the trigger from the reed switch. I guess i could test continuity directly at the counter and see if i get the same result.

Offline Weather Display

  • Posts: 84,697
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 66.0.3359.139
    • Weather Display
Re: Rainwise 1-wire gauge not registering tips
« Reply #3 on: May 14, 2018, 06:40:06 PM »
maybe the counter is gone out of range
does the count increase with the actual official Dallas 1 wire software program?

Offline mickopla

  • Posts: 242
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 66.0.3359.139
    • Waterford City Weather, Ireland
Re: Rainwise 1-wire gauge not registering tips
« Reply #4 on: May 14, 2018, 11:02:38 PM »
maybe the counter is gone out of range
does the count increase with the actual official Dallas 1 wire software program?

How would the counter go out of range? I have avoided installing the official dallas 1 wire software as it has caused me an amount of headaches in the past.
I did test continuity at the counter and it remains open even when the magnet passes the reed.  A resistor failure on the reed circuit board a possibility??

Offline mickopla

  • Posts: 242
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 66.0.3359.181
    • Waterford City Weather, Ireland
Re: Rainwise 1-wire gauge not registering tips
« Reply #5 on: May 20, 2018, 02:33:18 PM »
Just an update to where i stand on this. Basically the issue remains. I have tested the reed switch and it works fine. I tested the 100 ohm resistor on the circuit board that contains the reed and it reads 100 Ohms.
I did disconnect the 5v and B wires that were connected to the data counter thinking i would get the same continuity results when testing the reed but the Multi-meter stays at 1 even when i pass the magnet over the reed. I'm at a loss now to what to do next.
Rainwise are looking for 32 dollars to ship the reed circuit board to Ireland but i'm not entirely sure thats where the problem lays.

Any further advice would be much appreciated

Offline Weather Display

  • Posts: 84,697
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 66.0.3359.139
    • Weather Display
Re: Rainwise 1-wire gauge not registering tips
« Reply #6 on: May 20, 2018, 06:54:14 PM »
my advice is to use the original Dallas 1 wire software to read the counter

Offline mickopla

  • Posts: 242
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 66.0.3359.181
    • Waterford City Weather, Ireland
Re: Rainwise 1-wire gauge not registering tips
« Reply #7 on: May 20, 2018, 07:41:15 PM »
my advice is to use the original Dallas 1 wire software to read the counter

I will do that Brian and install on another PC. Don't want to mess up my Weather Station PC installing drivers over drivers.

Offline mickopla

  • Posts: 242
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 66.0.3359.181
    • Waterford City Weather, Ireland
Re: Rainwise 1-wire gauge not registering tips
« Reply #8 on: May 20, 2018, 08:25:34 PM »
I installed the dallas 1-wire reader as advised by Brian. The counter is being detected as it was in in the WD one wire viewer software. A lot of numbers on view but i think its the Page 0 1 2 3 count i should be checking. I ran some water to tip the bucket but counts read as 00000000000 across the board. Maybe Brian could advise exactly what i should be checking in the software?? Thanks

Offline Weather Display

  • Posts: 84,697
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 66.0.3359.139
    • Weather Display
Re: Rainwise 1-wire gauge not registering tips
« Reply #9 on: May 21, 2018, 01:05:10 AM »
you should be seeing the count number go up
there is setting in the WD 1 wire to use page 14 instead of page 15 for the counter
did you try that?
(and I think the dallas software might have that option too)

Offline mickopla

  • Posts: 242
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 66.0.3359.181
    • Waterford City Weather, Ireland
Re: Rainwise 1-wire gauge not registering tips
« Reply #10 on: May 21, 2018, 09:33:40 AM »
you should be seeing the count number go up
there is setting in the WD 1 wire to use page 14 instead of page 15 for the counter
did you try that?
(and I think the dallas software might have that option too)

I did try using page 14 instead of 15 but still the count value doesn't rise. I believe its a hardware issue somewhere but ive tested the reed and its working. Somehow the info from the reed board is not getting back to the counter hence no tips being registered.

Offline mickopla

  • Posts: 242
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 66.0.3359.181
    • Waterford City Weather, Ireland
Re: Rainwise 1-wire gauge not registering tips
« Reply #11 on: May 25, 2018, 07:59:22 PM »
Just an update on this for future reference. It turned out the reed circuit board was the problem. When i changed the board with a different one everything worked fine. I didn't troubleshoot the faulty board yet but previous checking showed the reed ok and resistor ok so i'm still not sure what the issue was.

 

cumulus