cloudy cloudy

Author Topic: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3  (Read 2616 times)

0 Members and 1 Guest are viewing this topic.

Offline Redsafety

  • Posts: 37
  • OS/Browser:
  • Win NT 10.0
  • Firefox 59.0

Hi all,
Could I have some assistance in resolving the following:-

I have encountered the same symptoms as senapsys as documented within https://www.weather-watch.com/smf/index.php/topic,61722.msg493599.html#msg493599 In that the data from a Davis weather envoy 6314 via a serial to USB adapter is not being decoded consistently despite experimenting with different comms settings. I have attached two screen dumps of  examples of the data output from ConsoleWD, I have also attached a copy of the config file.
Up to now, I have been using Cumulus for displaying my data and have had no obvious data issues, however now I would like to use weather display using the very new Raspberrypi v3 B+.

Best regards

Online Weather Display

  • Posts: 85,050
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 65.0.3325.181
    • Weather Display
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #1 on: April 12, 2018, 11:04:13 PM »
did you try changing
Davis com method=2  // 1 for regular  2 for special davis serial read
to 1
I will do some testing here  later today

Offline Redsafety

  • Posts: 37
  • OS/Browser:
  • Win NT 10.0
  • Firefox 59.0
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #2 on: April 13, 2018, 02:22:00 PM »
Hi,
Thank you for the feedback, yes I have experimented with that comms setting if you set it to 1 you  get:-
requesting data
requesting data
and so on

which is the same  as documented by "senapsys"within https://www.weather-watch.com/smf/index.php/topic,61722.msg493599.html#msg493599

Online Weather Display

  • Posts: 85,050
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 65.0.3325.181
    • Weather Display
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #3 on: April 13, 2018, 09:36:57 PM »
I will see if I can improve the situation and get back to you

Online Weather Display

  • Posts: 85,050
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 65.0.3325.181
    • Weather Display
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #4 on: April 14, 2018, 12:41:22 AM »
I have tested here
it works great
(after initial start up where its a bit slow to get going)
then after the first data has arrived, its synced up and flys along nicely
maybe try updating the silicon labs usb driver you have?

Offline Redsafety

  • Posts: 37
  • OS/Browser:
  • Win NT 10.0
  • Chrome 65.0.3325.181
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #5 on: April 27, 2018, 05:41:04 PM »
Hi
Thank you for the feedback, I have done a sudo apt-get update and sudo apt-get dist-upgrade, however as you can see by the attachment still having problems. What is my route to doing any form of diagnostics and what data stream should I expect?
The only positive at the moment is another person had the same issue.

Online Weather Display

  • Posts: 85,050
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 65.0.3325.181
    • Weather Display
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #6 on: April 27, 2018, 07:23:20 PM »
I will check my code and see if I can get it to handle split data better

Offline Redsafety

  • Posts: 37
  • OS/Browser:
  • Win NT 10.0
  • Chrome 66.0.3359.139
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #7 on: May 15, 2018, 05:43:48 PM »
Hi
Have you a timescale for when you would be able to revisit your code?

Best regards

Online Weather Display

  • Posts: 85,050
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 66.0.3359.139
    • Weather Display
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #8 on: May 15, 2018, 07:15:13 PM »
it certainly is not a widespread problem
have you waited to see if the data gets in sync OK?
since I can not duplicate the problem here is not easy

but I will review the code and see if I can make an improvement that might help and let you know

Offline Redsafety

  • Posts: 37
  • OS/Browser:
  • Win NT 10.0
  • Chrome 66.0.3359.139
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #9 on: May 15, 2018, 08:45:29 PM »
Thank you for the update, I have left it running for ~5 minutes and the output is as per my post.
what output format should I be seeing?
can you suggest any debugging technique that I can do at my end to help you?

Online Weather Display

  • Posts: 85,050
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 66.0.3359.139
    • Weather Display
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #10 on: May 15, 2018, 09:12:33 PM »
try a new update (vers 17.3)
for raspberry pi3 version
and then in the config.txt
add
Davis timeout=250

and then try making that time out value a different number (e.g start at 0)
(restarting the program each time)
and see if that helps

Online Weather Display

  • Posts: 85,050
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 66.0.3359.139
    • Weather Display
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #11 on: May 18, 2018, 07:57:00 PM »
any news?

Offline Redsafety

  • Posts: 37
  • OS/Browser:
  • Win NT 10.0
  • Chrome 66.0.3359.181
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #12 on: May 18, 2018, 08:29:47 PM »
hi
I will be working on this over the weekend and get back to you with any feedback

Offline Redsafety

  • Posts: 37
  • OS/Browser:
  • Win NT 10.0
  • Chrome 66.0.3359.181
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #13 on: May 19, 2018, 08:50:53 AM »
Hi
I have a problem with just launching the new version of the program in that in the past I have been able to try to test out via using:-
cd /home/pi/Desktop/consolewdfiles/
sudo ./consolewd

However I am now getting the following status:-
pi@raspberrypi:~ $ cd /home/pi/Desktop/consolewdfiles/
pi@raspberrypi:~/Desktop/consolewdfiles $ sudo ./consolewd
sudo: ./consolewd: command not found
pi@raspberrypi:~/Desktop/consolewdfiles $

I have also tried out as per your readme but get the same status:-

pi@raspberrypi:~ $ cd /home/pi/Desktop/consolewdfiles/
pi@raspberrypi:~/Desktop/consolewdfiles $ sudo ./GoWdconsole.sh
sudo: ./GoWdconsole.sh: command not found
pi@raspberrypi:~/Desktop/consolewdfiles $

I have reverted back to the previous version and using the same commands as I normally use

cd /home/pi/Desktop/consolewdfiles/
sudo ./consolewd

I am able to get the programme to respond as you're aware of. Thus what am I overlooking to do correctly?

Online Weather Display

  • Posts: 85,050
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 66.0.3359.139
    • Weather Display
Re: Data output issue using Raspberrypi v3 B+ and ConsoleWD issue 17.3
« Reply #14 on: May 19, 2018, 10:05:33 AM »
that problem usually happens when you are running e.g version for rasberry pi2 on rasberry pi3

 

cumulus