cloudy cloudy

Author Topic: gui 64 bit not updating meteotemplate  (Read 875 times)

0 Members and 1 Guest are viewing this topic.

Offline blainec

  • Global Moderator
  • Posts: 370
  • Calgary, Ab.
  • OS/Browser:
  • (Linux Mint)
  • Firefox 58.0
    • Weather YYC
gui 64 bit not updating meteotemplate
« on: March 10, 2018, 04:09:42 AM »
I have a working windows version but am trying to change over to linux. I have used the same settings from windows in the linux verion but meteotemplate api is not updaing meteotemplatelive.txt..
The terminal window does not show any errors and things appear fine according to the terminal window.

Does anyone have any idea what could cause this?
 
« Last Edit: March 11, 2018, 03:53:35 PM by blainec »

Offline blainec

  • Global Moderator
  • Posts: 370
  • Calgary, Ab.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 58.0
    • Weather YYC
Re: gui 64 bit not updating meteotemplate
« Reply #1 on: March 11, 2018, 03:55:06 PM »
It appears that the api is not getting called on the website.

Does anyone else have this issue?

Offline blainec

  • Global Moderator
  • Posts: 370
  • Calgary, Ab.
  • OS/Browser:
  • Win NT 10.0
  • Firefox 58.0
    • Weather YYC
Re: gui 64 bit not updating meteotemplate
« Reply #2 on: March 11, 2018, 06:15:09 PM »
I went back to the windows version until I get this figured out.
it's strange that no one else has this issue. Windows version with same settings is working fine

Offline Weather Display

  • Posts: 85,421
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
    • Weather Display
Re: gui 64 bit not updating meteotemplate
« Reply #3 on: March 11, 2018, 06:54:53 PM »
what shows in a terminal window when you run the cronhttpget

Offline blainec

  • Global Moderator
  • Posts: 370
  • Calgary, Ab.
  • OS/Browser:
  • (Linux Mint)
  • Firefox 58.0
    • Weather YYC

Offline Weather Display

  • Posts: 85,421
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
    • Weather Display
Re: gui 64 bit not updating meteotemplate
« Reply #5 on: March 11, 2018, 07:43:48 PM »
try putting that data that is sent to be sent
in a url in a browser on your linux pc and see what shows in return

Offline blainec

  • Global Moderator
  • Posts: 370
  • Calgary, Ab.
  • OS/Browser:
  • (Linux Mint)
  • Firefox 58.0
    • Weather YYC
Re: gui 64 bit not updating meteotemplate
« Reply #6 on: March 11, 2018, 07:48:50 PM »
Success

Offline Weather Display

  • Posts: 85,421
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
    • Weather Display
Re: gui 64 bit not updating meteotemplate
« Reply #7 on: March 11, 2018, 07:50:47 PM »
and so did MT update?
the more information you can provide the better

Offline blainec

  • Global Moderator
  • Posts: 370
  • Calgary, Ab.
  • OS/Browser:
  • (Linux Mint)
  • Firefox 58.0
    • Weather YYC
Re: gui 64 bit not updating meteotemplate
« Reply #8 on: March 11, 2018, 07:53:45 PM »
no update on MT

Offline blainec

  • Global Moderator
  • Posts: 370
  • Calgary, Ab.
  • OS/Browser:
  • (Linux Mint)
  • Firefox 58.0
    • Weather YYC
Re: gui 64 bit not updating meteotemplate
« Reply #9 on: March 11, 2018, 08:02:08 PM »
when I enter the data string into the browser, the apiLog.txt file and cache file gets updated, but nothing else.
« Last Edit: March 11, 2018, 08:13:53 PM by blainec »

Offline Weather Display

  • Posts: 85,421
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
    • Weather Display
Re: gui 64 bit not updating meteotemplate
« Reply #10 on: March 11, 2018, 08:51:11 PM »
see if you can spot anything wrong
(e.g compare with the data sent from the windows version (in the senthttpget.txt file)

Offline blainec

  • Global Moderator
  • Posts: 370
  • Calgary, Ab.
  • OS/Browser:
  • (Linux Mint)
  • Firefox 58.0
    • Weather YYC
Re: gui 64 bit not updating meteotemplate
« Reply #11 on: March 11, 2018, 09:34:56 PM »
see if you can spot anything wrong
(e.g compare with the data sent from the windows version (in the senthttpget.txt file)
Where is the file located? I can't seem to find it

Offline Weather Display

  • Posts: 85,421
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
    • Weather Display
Re: gui 64 bit not updating meteotemplate
« Reply #12 on: March 11, 2018, 09:44:52 PM »
on the windows version?
it should be where WD is installed
note its called sentcustomhttpget.txt
but you should have at least seen that file and joined the dots

Offline blainec

  • Global Moderator
  • Posts: 370
  • Calgary, Ab.
  • OS/Browser:
  • (Linux Mint)
  • Firefox 58.0
    • Weather YYC
Re: gui 64 bit not updating meteotemplate
« Reply #13 on: March 11, 2018, 09:53:18 PM »
That file starts with a blank line then 2 lines with "OK" then the data string

-------------------

OK
OK
http://wxcalgary.com/meteotemplate/api.php?
U=1520796268&T=4.3&TMX=4.3&TMN=4.3&TIN=27.8&HIN=15&H=42&P=1032.1&W=0.8&G=0.0&
B=44&R=0.0&RR=0.000&BATT=4.7&PASS=3454&SW=WD&T2=255.0&SD=1.00&LW1=0&LW2=0&L
W3=0&LW4=0

Offline Weather Display

  • Posts: 85,421
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
    • Weather Display
Re: gui 64 bit not updating meteotemplate
« Reply #14 on: March 11, 2018, 09:54:54 PM »
yes
and so
how does the data compare ?