cloudy cloudy

Author Topic: WD wind gusts are low compared to WeatherLink  (Read 1116 times)

0 Members and 1 Guest are viewing this topic.

Offline niko

  • syzygy
  • Global Moderator
  • Posts: 27,483
  • Crystal Ball broken! Please post the URL.
  • Northern California, U.S.A.
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 64.0.3282.186
Re: WD wind gusts are low compared to WeatherLink
« Reply #30 on: March 09, 2018, 02:35:44 PM »
The regular wind in the Davis data feed to the PC is whole mph*, but the ten minute wind gust in the data is:

Code: [Select]
10-Min Wind Gust 22 2 It is a two-byte unsigned value in 0.1mph resolution.

* WD's conversion to and from knots can result in decimals.


Online Weather Display

  • Posts: 84,926
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
    • Weather Display
Re: WD wind gusts are low compared to WeatherLink
« Reply #31 on: March 09, 2018, 05:34:45 PM »
that is not the data that WD is requesting
its requesting the daily hi/low
and the value returned for that is whole mph

it looks like for the IP version, it does not always sync very well, getting that daily hi/lo data back
I will have to see if I can get that working more reliably

the problem is the ip data logger is not as good as the usb data logger at handling lots of commands, etc

Offline novawx

  • Posts: 35
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
Re: WD wind gusts are low compared to WeatherLink
« Reply #32 on: March 09, 2018, 05:48:54 PM »
I would think more people using the IP data logger would be having this issue - or maybe they just never noticed it.

I'm going to switch back to my old serial-to-usb logger and see if the maximum gusts are captured and report back.

It would be a bummer if I wasted $200 on the IP data logger. I purchased it to minimize the number of cables going to my PC, which right now is one - the thin power cable to my all-in-one HP.

Online Weather Display

  • Posts: 84,926
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
    • Weather Display
Re: WD wind gusts are low compared to WeatherLink
« Reply #33 on: March 09, 2018, 06:43:54 PM »
try a new .zip update, ready now
should be better now
not sure why all the negativity when I am actively working on this for you

Offline novawx

  • Posts: 35
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
Re: WD wind gusts are low compared to WeatherLink
« Reply #34 on: March 09, 2018, 06:55:43 PM »
Sorry Brian, I wasn't being negative towards you or WD. As a matter of fact I was going to see if you wanted me to hold-off on reinstalling my serial-to-usb logger so I could continue testing for you, which I am perfectly willing to do. My purchase of the IP logger has no connection to WD, as I said I was just trying to reduce cables connected to my PC. I also wouldn't want you to spend a lot of time trying to fix a problem that is not pervasive across WD users with an IP logger if it's something specific to my WD settings that could be a problem.

I'll install the new .zip and provide an update.

Offline novawx

  • Posts: 35
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
Re: WD wind gusts are low compared to WeatherLink
« Reply #35 on: March 10, 2018, 12:31:23 PM »
WD stopped recording/sending data about 5 minutes after midnight today. I saved a number of log files that might help diagnose the issue - not sure if I saved the correct files though. The last "setting to get vp hi/low" command in Debug Info was at 23:55 last night.

Offline hcorrin

  • Posts: 1,200
  • Ballaugh Isle of Man GB
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • Ballaugh Weather
Re: WD wind gusts are low compared to WeatherLink
« Reply #36 on: March 10, 2018, 08:18:53 PM »
Hi
I put the first version 68 on my 3 units late Thursday and 2 out of the 3 had intermittent data collection during Friday till I put version 66 back on late Friday PM and since the been ok   all 3 use serial to ip converters  and wd setup to use the ip

Offline novawx

  • Posts: 35
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
Re: WD wind gusts are low compared to WeatherLink
« Reply #37 on: March 11, 2018, 10:13:49 PM »
For 11 March, the console max gust was 10 mph at 1720 local time and the WD max gust was 7 mph at 0957 local time.

Offline novawx

  • Posts: 35
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
Re: WD wind gusts are low compared to WeatherLink
« Reply #38 on: March 13, 2018, 11:47:24 AM »
Console max gust so far today, 13 March, was 25 mph at 0714 local time and WD is showing 12 mph at 0253 local time.

The file weatherlinkdata.txt from C:\wdisplay\webfiles is showing the correct gust:
<wind_day_high_mph>25.0</wind_day_high_mph>
<wind_day_high_time>7:14am</wind_day_high_time>


The file datahtm1.txt shows:
Daily high gust speed 12.0 mph NNE

Still running the last .zip that Brian created on 9 March to try and solve this issue.

Online Weather Display

  • Posts: 84,926
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
    • Weather Display
Re: WD wind gusts are low compared to WeatherLink
« Reply #39 on: March 13, 2018, 08:11:54 PM »
i have made some improvements in the latest update build 69

Offline novawx

  • Posts: 35
  • OS/Browser:
  • Win NT 10.0
  • Chrome 64.0.3282.186
Re: WD wind gusts are low compared to WeatherLink
« Reply #40 on: March 13, 2018, 08:17:51 PM »
Thanks Brian. I'll give it a go.

Offline novawx

  • Posts: 35
  • OS/Browser:
  • Win NT 10.0
  • Chrome 65.0.3325.181
Re: WD wind gusts are low compared to WeatherLink
« Reply #41 on: April 01, 2018, 01:20:18 PM »
After no success over several weeks I decided to go back to my serial-to-usb data logger to see if I could rectify my issues with the maximum winds. Not only did this fix the maximum wind issue I was having with the weatherlink IP data logger but the VP2 Console battery voltage is displaying correctly on my status webpage (http://www.willowsfordfarmweather.org/wxstatus.php). I was never was able to fix the issue of having to reenter the "Data from Weatherlink.com" in Control Panel -> Station Type & Settings. Every time I restarted WD I had to re-enable and reenter the weatherlink DID, Key, User, and Password because they were blank after the restart.

I want to thank Brian for all the work he did trying to fix these issues. I doubt I am the only one experiencing weatherlink IP data logger issues but I guess it's possible. Maybe there was something unique about my setup or a setting I had incorrect. All is well now with the old serial-to-usb!

Online Weather Display

  • Posts: 84,926
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 65.0.3325.181
    • Weather Display
Re: WD wind gusts are low compared to WeatherLink
« Reply #42 on: April 01, 2018, 09:35:37 PM »
the problem with the weatherlink.com setting should have been fixed in a recent version of WD