cloudy cloudy

Author Topic: 1-wire reader & laser sensor  (Read 2491 times)

0 Members and 1 Guest are viewing this topic.

Offline mikeym

  • Posts: 1,206
  • Thornhurst, Pa USA
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 57.0
    • MikeyMs Thornhurst,PA Weather
1-wire reader & laser sensor
« on: November 28, 2017, 02:12:44 PM »
I'm trying to help a fella get his laser snow sensor up and running. The laser sensor is working correctly with all of the Porcupine Electronics software and the Dallas 1-wire reader is seeing the sensor, but is not taking any readings. In the 1-wire sensor there is this error "Default port does not have a driver". I haven't seen this problem before.

Any help would be greatly appreciated.

Thanks in advance.

Cheers

MikeyM
http://mikeymsweather.com/

Another VERY Happy WD user
Shuttle XS36v4 8 GB RAM
Davis Vantage Pro 2 wireless w/ Davis solar sensor
Laser Snow Depth Sensor LR4/Fluke 414D working in WD thanks to Brian

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Weather Display
Re: 1-wire reader & laser sensor
« Reply #1 on: November 29, 2017, 08:50:32 PM »
maybe needs the  dallas 1 wire driver installed (and then once that is installed, select the default port for that in the driver setup)
or try selecting /setting up the port in the 1 wire setup in the dallas 1 wire driver section?

Offline schwab

  • Posts: 39
  • OS/Browser:
  • Mac OS X 10.13.1
  • Chrome 64.0.3281.0
Re: 1-wire reader & laser sensor
« Reply #2 on: December 01, 2017, 05:40:24 PM »
This was done without solving the problem.

Thanks for any additional suggestions.

W10 may be the issue.

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Weather Display
Re: 1-wire reader & laser sensor
« Reply #3 on: December 01, 2017, 10:50:16 PM »
screen shot?

Offline schwab

  • Posts: 39
  • OS/Browser:
  • Mac OS X 10.13.1
  • Chrome 64.0.3282.3
Re: 1-wire reader & laser sensor
« Reply #4 on: December 02, 2017, 02:30:31 PM »
I have sent 6 screen shots to info@weatherdisplay.com & MikeyM

Attached are 2  Dallas1wirereader.exe v5.7 screenshots

Thanks for any suggestions/help.

Offline niko

  • syzygy
  • Global Moderator
  • Posts: 26,800
  • Crystal Ball broken! Please post the URL.
  • Northern California, U.S.A.
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 62.0.3202.94
Re: 1-wire reader & laser sensor
« Reply #5 on: December 02, 2017, 02:56:19 PM »
Maybe a typo in your post but it's  info@weather-display.com with a hyphen.

Offline Bjørn

  • Posts: 327
  • Ulsteinvik, Norway
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Ulsteinvikweather
Re: 1-wire reader & laser sensor
« Reply #6 on: December 02, 2017, 03:33:54 PM »
Hi.
I have been using the fluke 414 and wd dallas for 3 years in wintertime.
But since last year the dallas 1-wire has not been stabil over long time or windows 10 regonize the fluke as not fluke but a keyboard, plug usb in out somtimes fix this.
Also tryed fluke readings one time an houre, but same issue dallas stoped working for reason unknown.
So i stoped using this feature in wd.

But hopefully somone can sort things out.

See photo, you also need to have this ticked  "on".

Offline schwab

  • Posts: 39
  • OS/Browser:
  • Mac OS X 10.13.1
  • Chrome 64.0.3282.3
Re: 1-wire reader & laser sensor
« Reply #7 on: December 02, 2017, 04:42:33 PM »
I have attached two screenshots of my Dallas1wirereader.exe app. v 5.7

It is running under Windows 10

Not sure how to troubleshoot the Keyboard issue you identified and whether I even have that problem.

All snow parameters are checked in WD

I can receive a daily one-time snow measurement by manually either directly or by remoting-in to my HP Laptop and running a manual measurement using porcupinelabs LR4 apps.  Automatic flow of data just is not occurring at all using Dallas1wireader.exe & WD.

Appreciate you trying to help.

I downloaded my 64-bit 1wirereader driver from here:

https://www.maximintegrated.com/en/products/ibutton/software/tmex/download_drivers.cfm

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Weather Display
Re: 1-wire reader & laser sensor
« Reply #8 on: December 02, 2017, 06:02:25 PM »
@schwab
try
find the installed 1 wire driver dll files
like
IB97E32.dll
and copy to where you have WD installed
but the issue might be that you have installed 64 bit 1 wire drivers when only 32 bit driver needed
see if you can install the 32 bit dallas 1 wire drivers instead

the problem is I lost the code for the WD 1 wire program in a hard drive crash

Offline schwab

  • Posts: 39
  • OS/Browser:
  • Mac OS X 10.13
  • Firefox 57.0
Re: 1-wire reader & laser sensor
« Reply #9 on: December 02, 2017, 08:12:34 PM »
I found the file you suggested and attached a screen shot of its location on my PC

Also...this is a site that may help?  It is where I downloaded the 64-bit driver

https://www.maximintegrated.com/en/products/ibutton/software/tmex/download_drivers.cfm




Offline schwab

  • Posts: 39
  • OS/Browser:
  • Mac OS X 10.13.1
  • Chrome 64.0.3282.3
Re: 1-wire reader & laser sensor
« Reply #10 on: December 02, 2017, 08:44:25 PM »
Thanks...

UPDATE:

I tried to download the 32-bit one-wire driver from this site

https://www.maximintegrated.com/en/products/ibutton/software/tmex/download_drivers.cfm

but this failed because an applet popped-up and recognizes my PC running 64-bit Windows 10 and locks me out of downloading a 32-bit version.

Ideas?

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Weather Display
Re: 1-wire reader & laser sensor
« Reply #11 on: December 02, 2017, 09:37:11 PM »
try then deleting the 1 wire IB *.dll files from where WD is installed

Offline schwab

  • Posts: 39
  • OS/Browser:
  • Win NT 10.0
  • Chrome 51.0.2704.79
Re: 1-wire reader & laser sensor
« Reply #12 on: December 02, 2017, 10:49:22 PM »
Which of the files in the attached screen shot of my search shall I delete?

Thanks

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Weather Display
Re: 1-wire reader & laser sensor
« Reply #13 on: December 02, 2017, 11:01:15 PM »
not those ones
the  IB *.dll files from where WD is installed
(see my post)
not in the wow64 directory
but in the c:\wdisplay directory

i.e the IB97E32.dll and other IB (other name after that) dll files

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Weather Display
Re: 1-wire reader & laser sensor
« Reply #14 on: December 02, 2017, 11:20:09 PM »
OR
you can try deleting those IB dll files in the windows system folder and keep the ones in the WD folder

 

cumulus