cloudy cloudy

Author Topic: working IP cam, not working in WD  (Read 1802 times)

0 Members and 1 Guest are viewing this topic.

Offline Weather Display

  • Posts: 82,700
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Weather Display
Re: working IP cam, not working in WD
« Reply #90 on: December 07, 2017, 06:00:05 PM »
OK,that does work, I can get the picture (from Dan's port forwarded cam) to be downloaded via http get

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 10,294
  • Davis Vue/Win10
  • Ocean Park, WA.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Traveling RV Weather
Re: working IP cam, not working in WD
« Reply #91 on: December 07, 2017, 06:04:45 PM »
Initially it wouldn't connect to the cam.  I just ran it again to grab the preview text and it connected to the cam this time. 

What I am now seeing in the preview text window says it is grabbing an image.  But, the image displayed in webcam capture is not changing from the initial image grab, and the save file is not updating on my harddrive.  Other than the static image being displayed it appears that version 10.28 is running along happily even though no image update is occuring.


Offline Weather Display

  • Posts: 82,700
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Weather Display
Re: working IP cam, not working in WD
« Reply #92 on: December 07, 2017, 07:26:21 PM »
i have added option to use a separate cron program (crongetipcam) to try and download the image
try that
http://www.weather-display.com/downloadfiles/wdwebcamcapture.zip

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 10,294
  • Davis Vue/Win10
  • Ocean Park, WA.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Traveling RV Weather
Re: working IP cam, not working in WD
« Reply #93 on: December 08, 2017, 02:40:56 AM »
Got one image, then nothing.  Windows Defender complained and I tried to give the cron program an exclusion but not sure how/where to make sure.  Defender isn't real friendly about how to do it...any ideas?

Offline Weather Display

  • Posts: 82,700
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Weather Display
Re: working IP cam, not working in WD
« Reply #94 on: December 08, 2017, 02:47:51 AM »
it does not always get an image..some it fails
how long did you leave it running?

re the normal way, and it then no updating. what id you click on set then start in the first tab (connections)

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 10,294
  • Davis Vue/Win10
  • Ocean Park, WA.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Traveling RV Weather
Re: working IP cam, not working in WD
« Reply #95 on: December 08, 2017, 03:05:20 AM »
It's still running here...

I started up webcam exe and ticked to use cron method.  Shutdown web cam exe and restarted it...it gave me a popup from defender so I clicked add exclusion.  I see the cron icon popup in the task bar but it closes before I can open it to see whats going on with it.

add:  It is grabbing an image occasionally...


add2:  Do you have the cron program logging anyplace?  I think it's showing an error but it disappears before I can read it...
« Last Edit: December 08, 2017, 03:20:23 AM by NorCal Dan »

Offline Weather Display

  • Posts: 82,700
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Weather Display
Re: working IP cam, not working in WD
« Reply #96 on: December 08, 2017, 03:23:41 AM »
I was getting an error at times too
( I know what the error is but I do not know why the error)
but then it would also some times actually get an image too

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 10,294
  • Davis Vue/Win10
  • Ocean Park, WA.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Traveling RV Weather
Re: working IP cam, not working in WD
« Reply #97 on: December 08, 2017, 04:27:11 AM »
I suspect that digest authorization is whats causing problems.  This is my 2nd IP3M-943 Amcrest.  My first one is older and works fine.  The 2nd is newer with updated firmware where they implemented this digest auth scheme and really made a mess of a nice product.

Can digest auth not be implemented in WD?

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 10,294
  • Davis Vue/Win10
  • Ocean Park, WA.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Traveling RV Weather
Re: working IP cam, not working in WD
« Reply #98 on: December 11, 2017, 08:02:42 PM »
I am done trying to help you Brian...I ask one simple question and you get pissed off and give me the cold shoulder...

Offline Weather Display

  • Posts: 82,700
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Weather Display
Re: working IP cam, not working in WD
« Reply #99 on: December 11, 2017, 08:23:29 PM »
I did not see see your question,sorry

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 10,294
  • Davis Vue/Win10
  • Ocean Park, WA.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 62.0.3202.94
    • Traveling RV Weather
Re: working IP cam, not working in WD
« Reply #100 on: December 13, 2017, 08:09:07 PM »
Can digest auth not be implemented in WD?

Offline Weather Display

  • Posts: 82,700
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Android 5.0.1
  • Chrome 63.0.3239.83
    • Weather Display
Re: working IP cam, not working in WD
« Reply #101 on: December 14, 2017, 06:06:02 PM »
Not sure what you asking exactly..Can u be more specific ?
I do see where another use has this new webcamcapture
Working ok,and not using the cron method

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 10,294
  • Davis Vue/Win10
  • Ocean Park, WA.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 63.0.3239.84
    • Traveling RV Weather
Re: working IP cam, not working in WD
« Reply #102 on: December 14, 2017, 11:06:00 PM »
I thought you were going to implement digest authorization in WD.  The cron method being used now is not 100% reliable.

 

Offline Weather Display

  • Posts: 82,700
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Android 5.0.1
  • Chrome 63.0.3239.83
    • Weather Display
Re: working IP cam, not working in WD
« Reply #103 on: December 15, 2017, 12:58:58 AM »
Not sure where I Said that
I Don't even know what digest authorization is?

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 10,294
  • Davis Vue/Win10
  • Ocean Park, WA.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 63.0.3239.84
    • Traveling RV Weather
Re: working IP cam, not working in WD
« Reply #104 on: December 15, 2017, 02:23:42 AM »
Digest Auth is a more secure way to connect to a server.  Instead of sending something like http://[username]:[password]@192.168.1.1/cgi-bin/video.mp4 what happens in digest auth is when the client attempts to connect to the server, the server generates a 404 error AND sends the client a "key" code.  When the client receives the "key", the client generates a unique MD5 hash (with the "key" and the password).  The password is never sent in clear text, and the server decrypts the hash to verify it came from the client AND has the correct password to access the server.

Thats about all I know so far, but there is plenty of reference material available via google on how to implement digest auth and the RFC that contains all the specifics.

 

cumulus