cloudy cloudy

Author Topic: Meteotemplate API - no Solar or UV  (Read 958 times)

0 Members and 1 Guest are viewing this topic.

Offline cjohlandt

  • Posts: 10
  • Damascus, MD, USA
  • OS/Browser:
  • Win NT 10.0
  • Chrome 56.0.2924.87
    • Cedar Ridge Weather
Meteotemplate API - no Solar or UV
« on: March 18, 2017, 12:33:14 AM »
Brian,

I switched over to the Meteotemplate API last night and my website (http://cedarridgeweather.com) is no longer receiving Solar and UV data.  Looking at my Meteotemplate database, I can see that it stopped when I made the switch at 23:50 last night.  Jachym pointed out that the Solar and UV are not in the raw data (http://cedarridgeweather.com/meteotemplateLive.txt).  All other data seems to be uploading fine.  I'm running Weather Display 10.37S44.  Do I need to change a setting somewhere in Weather Display?

Thanks.
-Chris
« Last Edit: March 18, 2017, 12:44:20 PM by cjohlandt »

Davis Vantage Pro2 Plus Wireless
Weather Display 10.37S73

Offline Weather Display

  • Posts: 84,695
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 56.0.2924.87
    • Weather Display
Re: Meteotemplate API - no Solar or UV
« Reply #1 on: March 18, 2017, 03:04:54 AM »
solar data is working for me:
http://www.weather-display.org/template/indexDesktop.php

what weather station type?
make sure the switch is on under control panel, solar setup, in WD

Offline cjohlandt

  • Posts: 10
  • Damascus, MD, USA
  • OS/Browser:
  • Win NT 10.0
  • Chrome 56.0.2924.87
    • Cedar Ridge Weather
Re: Meteotemplate API - no Solar or UV
« Reply #2 on: March 18, 2017, 12:43:47 PM »
Davis VP2 Pro Plus.  I confirmed that the Solar + UV box is checked in the station setup (see attached).  I tried unchecking that box, restarting WD, r rechecking the box and again re-starting WD and it's still not uploading Solar & UV using the Meteotemplate API.  Solar & UV were uploading prior to switching to the API.

-Chris

Davis Vantage Pro2 Plus Wireless
Weather Display 10.37S73

Offline Jachym

  • Posts: 2,092
  • Meteotemplate Developer
  • Brno, Czech Republic
    • jachym.czech
  • OS/Browser:
  • (Linux Mint)
  • Chrome 48.0.2564.116
    • Meteotemplate
Re: Meteotemplate API - no Solar or UV
« Reply #3 on: March 18, 2017, 01:49:32 PM »
Hi Chris,
previously the data was taken directly from clientraw, now it takes in whatever WD sends to it, but given it works on other people's sites, Im 99% sure the api script is working fine. In your case I cannot see it right in the realtime file it creates before doing anything else - first thing the api script does is saves all info it received, before doing any further processing, and already in this file I dont see S and UV

No S/UV:

http://cedarridgeweather.com/meteotemplateLive.txt

Offline cjohlandt

  • Posts: 10
  • Damascus, MD, USA
  • OS/Browser:
  • Win NT 10.0
  • Chrome 56.0.2924.87
    • Cedar Ridge Weather
Re: Meteotemplate API - no Solar or UV
« Reply #4 on: March 18, 2017, 03:23:09 PM »
It definitely seems to be on the Weather Display side - the Solar and UV data are not being included in what is sent.  I turned off the API and went back to the original method and Solar and UV data are flowing again.  I'll try re-installing build 44 and see if that fixes it.

-Chris

Davis Vantage Pro2 Plus Wireless
Weather Display 10.37S73

Offline Weather Display

  • Posts: 84,695
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 56.0.2924.87
    • Weather Display
Re: Meteotemplate API - no Solar or UV
« Reply #5 on: March 18, 2017, 05:28:37 PM »
make sure the switch is on under control panel,solar setup

Offline cjohlandt

  • Posts: 10
  • Damascus, MD, USA
  • OS/Browser:
  • Win NT 10.0
  • Chrome 56.0.2924.87
    • Cedar Ridge Weather
Re: Meteotemplate API - no Solar or UV
« Reply #6 on: March 19, 2017, 12:12:49 AM »
That was it Brian!  Interestingly, I have not had that switch on in the past.  Thank you.

-Chris

Davis Vantage Pro2 Plus Wireless
Weather Display 10.37S73

 

cumulus