cloudy cloudy

Author Topic: Acu-Rite Acu-Link Replacement by MyAcuRite  (Read 4442 times)

0 Members and 1 Guest are viewing this topic.

Offline shadow

  • Posts: 125
  • Rockville, CT USA
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • http://weather.worswick.net
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #15 on: September 21, 2016, 11:25:14 PM »
It appears that myacurite still doesn't want to accept the wind direction that weather display is sending.

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • Weather Display
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #16 on: September 22, 2016, 12:13:16 AM »
that is strange
someone must know what the format should be for wind direction...
so the windspeed works ok?

Offline shadow

  • Posts: 125
  • Rockville, CT USA
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • http://weather.worswick.net
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #17 on: September 22, 2016, 01:21:14 AM »
It appears that the wind speed is uploading properly.

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • Weather Display
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #18 on: September 22, 2016, 02:55:13 AM »
its possible the wind direction needs to be only 16 cardinal
i.e 1 to 16
instead of 0 to 360
try another update, to see if that is it
http://www.weather-display.com/downloadfiles/weatherdisplaytest.zip

Offline shadow

  • Posts: 125
  • Rockville, CT USA
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • http://weather.worswick.net
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #19 on: September 22, 2016, 09:33:14 PM »
I updated to that latest version of the test client, but the wind direction still does not seem to be updating the direction still points North.  Also it appears that the rain doesn't seem to be updating on the website either.  Weather Display is reporting 0.04 in of rain, but the data it is sending to myacurite is 0.
Here is a copy of the test data mt=5N1x38&sensor=03348&winddir=12&windspeedmph=0.0&baromin=29.36&tempf=84&humidity=43&rainfall=0.000&battery=low&rssi=3

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • Weather Display
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #20 on: September 22, 2016, 10:07:40 PM »
the test data is not complete for the rain info sent
I will fix that
the problem with the rain is i might not be including enough decimal places for the inches for small rain amounts to show up
so try a new update re that
same url as before

re the wind direction not working
all that I have to go on is what info I could gleam from this thread
http://www.wxforum.net/index.php?topic=29838.475

it could be that it remains the same as the original, the wind direction, which was a coded format

Offline shadow

  • Posts: 125
  • Rockville, CT USA
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • http://weather.worswick.net
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #21 on: September 23, 2016, 03:03:19 AM »
I tried to install the Acu-Rite PC connect software and run wireshark on the computer to see what format it is sending the data to myacurite, but it appears that it is encrypting the data. 
I tried to use the SSLKEYLOGFILE environmental variable to try and allow wireshark to decrypt the packets, but I don't think the option works on Windows 10.

Offline shadow

  • Posts: 125
  • Rockville, CT USA
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • http://weather.worswick.net
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #22 on: September 24, 2016, 03:07:52 AM »
I was reading the forum post you linked to and noticed something about the data example that was given.  On one line the mt is listed as 5N1x31.  This line is the example that has the wind speed and direction along with the rain data. 
There is another line farther down on the data examples that has the mt listed as 5N1x38.  On this line, there is no wind direction or rain information transmitted. 
I wonder if this could be the reason why myacurite isn't showing this data, it is expecting that information with the mt of 5N1x31.

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • Weather Display
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #23 on: September 24, 2016, 03:35:49 AM »
of course!
I should have realised that
silly me  #-o
use a new update, to fix that
http://www.weather-display.com/downloadfiles/weatherdisplaytest.zip

should be OK now, build 23

Offline shadow

  • Posts: 125
  • Rockville, CT USA
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • http://weather.worswick.net
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #24 on: September 24, 2016, 04:18:45 AM »
I just tried the latest test version, but it appears that it is uploading two lines of data now, but they are not identical, the 5N1x38 line is just as it was before, but the 5N1x31 is missing some of the data.  Along with that, myacurite isn't updating with any of the information now. 

http://hubapi.myacurite.com/weatherstation/updateweatherstation?dateutc=now&action=updateraw&realtime=1&id=24C86Exxxxxx&mt=5N1x38&sensor=03348&windspeedmph=0.0&winddir=158&baromin=29.30&tempf=57&humidity=98&rainin=0.000&dailyrainin=0.010&battery=low&rssi=3
OK
http://hubapi.myacurite.com/weatherstation/updateweatherstation?dateutc=now&action=updateraw&realtime=1&id=24C86Exxxxxx&mt=5N1x31&sensor=03348&windspeedmph=0.0&winddir=158&rainin=0.000&dailyrainin=0.010&battery=low&rssi=3

I went back to the previous beta and the data is displaying again (missing the wind direction and rain of course).

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • Weather Display
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #25 on: September 24, 2016, 04:32:24 AM »
humm
we will get there...try again another update...
http://www.weather-display.com/downloadfiles/weatherdisplaytest.zip

the problem could be too many decimal places now for the rain data

Offline shadow

  • Posts: 125
  • Rockville, CT USA
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • http://weather.worswick.net
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #26 on: September 24, 2016, 12:38:18 PM »
I just tried the latest beta and guess what, it's working!  The wind direction is working and the rain is updating (although it says 0.00 which is what weather display is showing, we really need some rain here.  Been a very dry summer).

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • Weather Display
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #27 on: September 24, 2016, 06:59:29 PM »
that's good news :)

Offline shadow

  • Posts: 125
  • Rockville, CT USA
  • OS/Browser:
  • Win NT 10.0
  • Chrome 53.0.2785.116
    • http://weather.worswick.net
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #28 on: September 27, 2016, 10:33:18 PM »
When the beta is rolled into the production version version of weather display, will the temperature be uploaded with the tenth of a degree included?  Right now it appears to be rounding the temperature to the nearest whole degree.

Offline Weather Display

  • Posts: 82,667
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Android 5.0.1
  • Chrome 37.0.0.0
    • Weather Display
Re: Acu-Rite Acu-Link Replacement by MyAcuRite
« Reply #29 on: September 28, 2016, 12:21:12 AM »
Ah
Download another test update.same URL as before
Should fix that now

 

cumulus