cloudy cloudy

Author Topic: WXSIM 3in1 : meteogram disappears  (Read 2480 times)

0 Members and 1 Guest are viewing this topic.

Offline clement104

  • Posts: 23
  • Mélin Belgium
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 45.0.2454.101
    • Météo Mélin
WXSIM 3in1 : meteogram disappears
« on: October 04, 2015, 05:30:39 PM »
Hello,

Can someone tell me why the meteogram disappears on my installation: http://lobbes.cdhost.be/wxsim/jod/sivu2.php
It seems that everything else is working great.

Thanks a lot.

Regards
Clément

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 748
  • Amsterdam / Netherlands
  • OS/Browser:
  • iOS 9.0
  • Safari 9.0
    • My private weatherstation
Re: WXSIM 3in1 : meteogram disappears
« Reply #1 on: October 04, 2015, 07:02:25 PM »
Hello,

Can someone tell me why the meteogram disappears on my installation: http://lobbes.cdhost.be/wxsim/jod/sivu2.php
It seems that everything else is working great.

Thanks a lot.

Regards
The first tab and the icons are generated from plaintext.txt.
The meteogram and the other tabs are generated from lastret.txt.
If you changed settings in a wxsim program this can occur. Check your lastret.txt if it contains at least one line every hour on the exact hour. 
The current lastret at http://lobbes.cdhost.be/wxsim/jod/lastret.txt has all times 8 minutes before the hour.
« Last Edit: October 04, 2015, 07:23:33 PM by wvdkuil »
Vantage VUE with a WLIP used for https://weer.sluispark.be/
Vantage VP2 with a USB logger/Meteobridge for https://www.weerstation-herent.be/

Offline clement104

  • Posts: 23
  • Mélin Belgium
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 45.0.2454.101
    • Météo Mélin
Re: WXSIM 3in1 : meteogram disappears
« Reply #2 on: October 07, 2015, 01:00:26 PM »
So... The problem is in the configuration of wret?
Or it is due to local weather data that are not up to date?

Thanks :)
Clément

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 748
  • Amsterdam / Netherlands
  • OS/Browser:
  • Mac OS X 10.10.5
  • Chrome 45.0.2454.101
    • My private weatherstation
Re: WXSIM 3in1 : meteogram disappears
« Reply #3 on: October 07, 2015, 01:13:36 PM »
So... The problem is in the configuration of wret?
Or it is due to local weather data that are not up to date?

Thanks :)
Your site looks OK:  http://lobbes.cdhost.be/wxsim/jod/sivu2.php  and the lastret.txt is on the hour: http://lobbes.cdhost.be/wxsim/jod/lastret.txt

===

If the Meteogram and the tabs are not there at the first time after installing it is probably the setting with the arrow in the attached image.

If it suddenly happens once, it can be that there was a manual forecast run once. That will use the current time to generate the files.  In that case the file will be OK again after a scheduled run as wiull the Meteogram and the tabs.

Wim
Vantage VUE with a WLIP used for https://weer.sluispark.be/
Vantage VP2 with a USB logger/Meteobridge for https://www.weerstation-herent.be/

Offline clement104

  • Posts: 23
  • Mélin Belgium
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 45.0.2454.101
    • Météo Mélin
Re: WXSIM 3in1 : meteogram disappears
« Reply #4 on: October 10, 2015, 06:43:53 AM »
Hello,

Thank you for the tip!

Unfortunatelly, the box is checked...  :(

For information, the weather station is in a remote location, so I have to copy wlk files tu use them on the computer which runs Wxsim.
Clément

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 748
  • Amsterdam / Netherlands
  • OS/Browser:
  • Mac OS X 10.10.5
  • Chrome 45.0.2454.101
    • My private weatherstation
Re: WXSIM 3in1 : meteogram disappears
« Reply #5 on: October 10, 2015, 07:06:19 AM »
Hello,

Thank you for the tip!

Unfortunatelly, the box is checked...  :(

For information, the weather station is in a remote location, so I have to copy wlk files tu use them on the computer which runs Wxsim.
The first message
Quote
The current lastret at http://lobbes.cdhost.be/wxsim/jod/lastret.txt has all times 8 minutes before the hour.
The second
Quote
and the lastret.txt is on the hour: http://lobbes.cdhost.be/wxsim/jod/lastret.txt
and now the lastret.txt file contains data at two minutes before the hour.
Code: [Select]
6:58a DNS.OVC . . . . .    21    3      0 2015-10-10_04:58_UTC
Normally all  scheduled runs, (=all  lastret.txt  files) have the same hh:mm. So always at the hour, always 5 minutes before.
Only when a manual run is used the times can be different.

Is there any explanation that the  run times are not constant.?  Are you using automatically  scheduled runs? Or are you manualy running WXSIM?

When there is no constant difference there is no easy way to adapt the times in the script also.

Wim
Vantage VUE with a WLIP used for https://weer.sluispark.be/
Vantage VP2 with a USB logger/Meteobridge for https://www.weerstation-herent.be/

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 748
  • Amsterdam / Netherlands
  • OS/Browser:
  • Mac OS X 10.10.5
  • Chrome 45.0.2454.101
    • My private weatherstation
Re: WXSIM 3in1 : meteogram disappears
« Reply #6 on: October 10, 2015, 08:17:09 AM »
Hello,

Thank you for the tip!

Unfortunatelly, the box is checked...  :(

For information, the weather station is in a remote location, so I have to copy wlk files tu use them on the computer which runs Wxsim.
I modified the wxall.lastret.php to adapt to changing HH:MM, I hope HENKKA agrees with this messing with his scripts.

1. Unzip the attachement
2. Locate the current wxall.lastret.php, inside wxsim or a subfolder and make a backup-copy of that script.
3. replace with the unzipped version from the attachment

As there are multiple versions of this script, you could be using a different version.
So if there are new and strange errors, replace the script with the backup you made in step 2.

I tested it with your "2015-10-10_07:12_UTC" lastret.txt and it worked OK.

Wim
« Last Edit: October 10, 2015, 08:19:54 AM by wvdkuil »
Vantage VUE with a WLIP used for https://weer.sluispark.be/
Vantage VP2 with a USB logger/Meteobridge for https://www.weerstation-herent.be/

Offline clement104

  • Posts: 23
  • Mélin Belgium
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 45.0.2454.101
    • Météo Mélin
Re: WXSIM 3in1 : meteogram disappears
« Reply #7 on: October 10, 2015, 09:40:17 AM »
Hello,

Both Wxsim and Wxsimate are started 8 minutes after the hour by a batch script.
Then, Wxsimate starts downloading data 10 minutes after the hour with the autoschedulde mode. After that, it closes by itself.
Wxsim start generating forecasts 12 minutes after the hour with auto mode also. After that, wret is automatically launched.

A Syncback profile upload plaintext and lastret to the Internet, 20 minutes after the hour.
Clément

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 748
  • Amsterdam / Netherlands
  • OS/Browser:
  • Mac OS X 10.10.5
  • Chrome 45.0.2454.101
    • My private weatherstation
Re: WXSIM 3in1 : meteogram disappears
« Reply #8 on: October 10, 2015, 10:35:57 AM »
Hello,

Both Wxsim and Wxsimate are started 8 minutes after the hour by a batch script.
Then, Wxsimate starts downloading data 10 minutes after the hour with the autoschedulde mode. After that, it closes by itself.
Wxsim start generating forecasts 12 minutes after the hour with auto mode also. After that, wret is automatically launched.

A Syncback profile upload plaintext and lastret to the Internet, 20 minutes after the hour.
It is your setup. The HENKKA script only processes lines which are on the hour  HH:00.
If you try to use the wxall.lastret.php from my previous post, it does not matter as it should work with any HH:MM in the lastret.txt file.

Wim
Vantage VUE with a WLIP used for https://weer.sluispark.be/
Vantage VP2 with a USB logger/Meteobridge for https://www.weerstation-herent.be/

Offline clement104

  • Posts: 23
  • Mélin Belgium
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 46.0.2490.71
    • Météo Mélin
Re: WXSIM 3in1 : meteogram disappears
« Reply #9 on: October 21, 2015, 07:41:52 AM »
Big thank to you Wim.

Smooth workaround :D

Regards,
Clément

 

cumulus