cloudy cloudy

Author Topic: VVP stops passing new data  (Read 3084 times)

0 Members and 1 Guest are viewing this topic.

Offline waterside

  • Posts: 66
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 17.0.963.83
    • Crab Meadow Weather
VVP stops passing new data
« on: March 24, 2012, 01:12:10 PM »
I recently retired my old weather pc and replaced with another.  I had been running Win7/32, VVP with NB8vCOM as serial port emulator feeding WD and WL using virtual serial.  This was running solid even on slow hardware.

I am now running Win7/64 with VVP feeding WD and WL.  I had tried the HHD Software virtual serial port driver for x64 but was unable to get it to work so I switched to feeding WD and WL via TCP/IP from VVP instead.

This is where I am running into problems.  Occasionally WL will close its Bulletin window in turn causing it to stop reading data.  VVP does not seem to handle this well and after a few hours will stop feeding new data to WD.  It does keep providing updates, but gets stuck on one set of values causing WD to flatline all of its readings.  When this happens VVP continually logs a pair of error messages every two seconds:

    PreCondition - TVirtualVp.ReceiveLoop: PreCondition 1 failed
    Error              - Output buffer too small for block

I need to exit WL, WD, and VVP then restart all to recover.

I am using VVP 1.2.5.74 and all software is running as an unprivileged (non-admin) user, as I had done on win7/32.  I will look to trying the virtual serial again but am interested to know if anyone else has seen this or has any ideas.

Edit:
I also observed that VVP apparently stops reading from the VP2 console but does not disconnect.  Upon restart of VVP it does fetch the missing archive data, or at least appears to do so, which takes a short time similar to cases where VVP has not been running for a while.

« Last Edit: March 26, 2012, 12:50:34 PM by waterside »

Offline Tornado Tim

  • Posts: 586
  • I Love storms!
  • Matangi, Hamilton, Waikato, New Zealand
  • OS/Browser:
  • Mac OS X 10.6.8
  • Safari 5.1.4
    • Matangi Weather
Re: VVP stops passing new data
« Reply #1 on: March 27, 2012, 07:59:19 AM »
based on your edit to test: dont touch any of the console buttons, such as pressing the forecast button, everytime a button like that is pressed it halts any data being fed into the PC.
That could be causing VVP to stop reading the console.
http://matangiweather.org
http://NZAPStrike.net- NZ Aus Pacific Strike Network

Offline waterside

  • Posts: 66
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 17.0.963.83
    • Crab Meadow Weather
Re: VVP stops passing new data
« Reply #2 on: March 27, 2012, 12:30:03 PM »
I don't touch the console - VVP stops reading from the VP2 when it gets into this condition after logging the 'Output buffer too small' error, which happens after WL Bulletin closes.  It was an additional observation to go with the above.

Again - this is all new after switching to TCP/IP configurations in WL and WD after successfully using virtual serial ports for 3.5 years previously.  I'm right now trying to find some time to re-attempt virtual serial ports but I've noted others are using TCP/IP in their configurations apparently without issues.

Offline R_o_B

  • Posts: 170
  • Maple Bay, British Columbia, Canada
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 11.0
    • Tzouhalem-Maple Bay Weather
Re: VVP stops passing new data
« Reply #3 on: April 01, 2012, 11:15:06 AM »
For your 64-bit computer, you could use the com0com null-modem emulator - a 64-bit signed version is available on the SourceForge.

Since I have had the Vantage Pro2 weather station, I have used Virtual VP. As far as I can remember, I have always had problems whenever I ran the WeatherLink software - it has not been designed to 'play' nice with any other software, including Virtual VP - it appears that the WeatherLink software does not like to have its input redirected through a software, it prefers direct connection to the data logger.
R_o_B
---
eMail: weather@tzweather.org

Offline waterside

  • Posts: 66
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 18.0.1025.142
    • Crab Meadow Weather
Re: VVP stops passing new data
« Reply #4 on: April 03, 2012, 01:29:46 PM »
The com0com driver is test-signed and requires driver signature enforcement to be relaxed, which I want to avoid for now.  There are several options for serial emulators and I will look to try this again once I have time to spend.  Network (tcp/ip) connectivity should be more reliable but at the moment does not appear to be so (at least for me).  I have yet to reach out to Steve (SoftWX), but VVP shouldn't be so affected by WL.

Offline tstolze

  • Posts: 71
  • Ofallon, MO
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 11.0
    • Ofallon Missouri Weather
Re: VVP stops passing new data
« Reply #5 on: April 06, 2012, 02:39:20 AM »
I had to switch mine from tcp/ip to serial ports due to connection issues after midnight. It was very sporadic and at time would run weeks without a problem. Since changing to serial I have had no issues at all.