cloudy cloudy

Author Topic: Wxsim 3in1 script  (Read 185291 times)

0 Members and 1 Guest are viewing this topic.

Offline weatherc

  • Posts: 1,977
  • Salo, Finland
    • Weatherstation Salo,FI
Re: Wxsim 3in1 script
« Reply #30 on: September 03, 2010, 04:54:57 PM »
Hi,

Quote
Only a question now about the translation. How is this simple to do?

So long you have the path to plaintext-parser-lang-nl.txt correct it should use it directly, that was whole idea with the script, less translation-files. Note tought to add the new words from plaintext.lang.txt to it. Even if tryed to get all from old langfile it needed a few new words added to work smoothly :)

Bashy,
humm...Have you checked the paths are correct? (ie. it looks for a icon what really exsists)

henkka

Offline Andretti

  • Posts: 283
  • Poland, silesia, Zabrze
    • ASM Poland - Zabrze
Re: Wxsim 3in1 script
« Reply #31 on: September 03, 2010, 06:55:29 PM »
Hi Henkka
i try to run the perfect script - very good job.
But the script does not work correctly on my site.
I am not able to find the cause.
I see a message at the top of the page that is a problem with java.
But I do not know how to solve the problem.
I do not know if all of the error is associated with this message.
Maybe you have some hint
http://www.andretti.pl/wxsim_forecast.php
or
http://www.andretti.pl/sivu2.php
thanks
andretti


Edit:
the java error on my page say:
JAVASCRIPT STARTUP ERRORS
am is undefined at line number 8 in http://www.andretti.pl/wxsim_allinone/jquery/jquery.wxsim.flot.js
... please inform your webmaster.
« Last Edit: September 03, 2010, 07:23:00 PM by Andretti »

Bashy

  • Guest
Re: Wxsim 3in1 script
« Reply #32 on: September 03, 2010, 09:26:47 PM »
Hi Hennka

The paths appear to be correct,

// Icondir-paths (Yeah, we have 5 sets of them :D)
$iconDir ='wxsim/img/dotvoid_frc/';           // Dotvoid icons
$iconDirb = 'wxsim/img/dotvoid_mini/';        // Dotvoid mini
$bignumbdir = "wxsim/img/bignumb/";           // colorized numbers
$windarrows = "wxsim/img/arrows/";            // windarrows
$uvimg = "wxsim/img/UV_icons/";               // UV-icons

All the other icons work apart from the  conditions icon/s


Andretti

In the settings file, do you have this path correct

$jsdir = "wxsim_allinone/jquery/";                           // js-folder

I think yours should be as i have put above?

Offline Andretti

  • Posts: 283
  • Poland, silesia, Zabrze
    • ASM Poland - Zabrze
Re: Wxsim 3in1 script
« Reply #33 on: September 04, 2010, 04:51:40 AM »
Hi Simon
I think that is good. Since all files are in subdirectory "wxsim_allinone" not "wxsim"

here my settings:
Code: [Select]
// Icondir-paths (Yeah, we have 5 sets of them :D)
$iconDir ='wxsim_allinone/img/dotvoid_frc/';           // Dotvoid icons
$iconDirb = 'wxsim_allinone/img/dotvoid_mini/';        // Dotvoid mini
$bignumbdir = "wxsim_allinone/img/bignumb/";           // colorized numbers
$windarrows = "wxsim_allinone/img/arrows/";            // windarrows
$uvimg = "wxsim_allinone/img/UV_icons/";               // UV-icons

// jQuerydir-path
$jsdir = "wxsim_allinone/jquery/";                           // js-folder

// Other paths
$pathtolsparser = 'wxsim_allinone/wxsim.allinone.lastretparser.php';
$lastretfile = "lastret.txt";
$plaintextFile = 'plaintext.txt';       // location of the WXSIM plaintext.txt
$filea = 'plaintext-parser-data.txt';
$fileb = 'plaintext-parser-lang-'.$lang.'.txt';  // just change the path, language are detetcred auto

andretti

Offline weatherc

  • Posts: 1,977
  • Salo, Finland
    • Weatherstation Salo,FI
Re: Wxsim 3in1 script
« Reply #34 on: September 04, 2010, 12:40:57 PM »
Andretti,

Check the path to lastret.txt as in source-code are no data in the arrays from that:

Code: [Select]
<script type="text/javascript">
var wxsimdata = {
tempdata: [],
precdata: [],
dewdata: [],
chilldata: [],
heatdata: [],
winddata: [],
dirdata: [],
uvdata: [],
kidata: []
}

Theese should be full of data. I *think*, not sure tought, the javascript fails because/when there are no data there. Js can be a bit clunky on that.

henkka

Offline Andretti

  • Posts: 283
  • Poland, silesia, Zabrze
    • ASM Poland - Zabrze
Re: Wxsim 3in1 script
« Reply #35 on: September 04, 2010, 04:50:45 PM »
hehe ;)
What I found to be a problem. The problem to be very trivial.
File lastret.txt not be current, and the date was the September 1.
I probably can not set WXSIM to create this file automatically.
I manually update the file and now everything work.  :)

But I see a small error. On the charts, after moving the cursor, do not display values. I get a blank label.
Can I fix this? How?

thanks
andretti

Offline weatherc

  • Posts: 1,977
  • Salo, Finland
    • Weatherstation Salo,FI
Re: Wxsim 3in1 script
« Reply #36 on: September 04, 2010, 04:58:01 PM »
To get wxsim to create lastret.txt you need to choose that "Ext Boot"-thingy and at least i had to set up a SS-call what runs WRET before i upload the files. WRET then just starts and automaticly closes itself few seconds later and create the lastret.txt.

For the labels...Humm...
Could it be a css-thingy there? Will add a txt-color the labels and update the zip so we can test, as it seems the texts are defined (the boxes sizes varys) but no text are visible...

Henkka

Offline Andretti

  • Posts: 283
  • Poland, silesia, Zabrze
    • ASM Poland - Zabrze
Re: Wxsim 3in1 script
« Reply #37 on: September 04, 2010, 05:26:06 PM »
Henkka,
if you write "SS-call" - you have in mind System Scheduler ?

For the labels ...
I noted that work correctly in the file
http://www.andretti.pl/sivu2.php
But I do not work here
http://www.andretti.pl/wxsim_forecast.php?lang=en
And the content is almost the same, the difference is an additional Carterlake template script

andretti

Offline FORSURH

  • Posts: 166
  • Grootegast,NL
    • Weerstation Grootegast
Re: Wxsim 3in1 script
« Reply #38 on: September 04, 2010, 07:47:53 PM »
Henkka,

Struggeling with the tabs and graphs,

See link:

http://www.weerstation-grootegast.nl/sivu2.php


What am i doing wrong?

Greetz,

Wisse

Bashy

  • Guest
Re: Wxsim 3in1 script
« Reply #39 on: September 04, 2010, 07:51:56 PM »
Hi Wisse, it will be the path to the jquery folder incorrect i think...

Offline Andretti

  • Posts: 283
  • Poland, silesia, Zabrze
    • ASM Poland - Zabrze
Re: Wxsim 3in1 script
« Reply #40 on: September 04, 2010, 08:26:58 PM »
Wisse,
And it seems to me that you have a problem with lastret.txt
1st wrong path to the file
or
2nd no current data in the file lastret.txt (that was my problem)
or
3 no file lastret.txt

andretti

Bashy

  • Guest
Re: Wxsim 3in1 script
« Reply #41 on: September 04, 2010, 09:03:51 PM »
Hi Henkka, I have managed to get it working great'ish, it was this line

$filea = './plaintext-parser-data.txt';

it had .php i finally figured it out even though someone told me that 1st time round but i forgot  #-o


The data inside the floating tooltip is not showing and i have figured out why but not how to fix...?

This is causing the problem thats in my top.php i think its supposed to be there for the template setup
and it could be that im using the black template and a lot of my data is white hence you cant t see the
data in the tooltip cause its showing white, well thats what i think i the reason is, if i comment out those
2 lines the data appears in the tooltip

    <link rel="stylesheet" type="text/css" href="<?php echo $SITE['CSSscreen']; ?>" media="screen" title="screen" />
    <link rel="stylesheet" type="text/css" href="<?php echo $SITE['CSSprint']; ?>" media="print" />

http://www.northantsweather.com/wxwxsimmulti.php
« Last Edit: September 04, 2010, 09:06:06 PM by Bashy »

Offline Andretti

  • Posts: 283
  • Poland, silesia, Zabrze
    • ASM Poland - Zabrze
Re: Wxsim 3in1 script
« Reply #42 on: September 04, 2010, 09:22:30 PM »
Simon,
I see that you have a similar problem with tooltip like me.
Following your suggestion, I change the color of the template to blue. Now you can see the text in tooltip.
So just the opportunity to nominate the color of the font.
Maybe Henkka can suggest how to change it.

andretti

Offline Andretti

  • Posts: 283
  • Poland, silesia, Zabrze
    • ASM Poland - Zabrze
Re: Wxsim 3in1 script
« Reply #43 on: September 04, 2010, 09:32:47 PM »
One more thing I wonder.
Why Lifted Index is displayed so differently. I have in mind my earlier chart on the page with the forecast http://www.andretti.pl/wxsimforecast.php, and this now being tested http://www.andretti.pl/wxsim_forecast.php.
The older version always verify. And currently do not indicate the possibility of a storm.
The new version shows a very high Lifted Index

andretti

Offline weatherc

  • Posts: 1,977
  • Salo, Finland
    • Weatherstation Salo,FI
Re: Wxsim 3in1 script
« Reply #44 on: September 04, 2010, 09:39:49 PM »
Great work guys!  :D

That confirmed my tought of what the color-issue was. Should have a fix now where font is forced to black in the tooltip. Zip updated.
Changed file: jquery.wxsim.allinone.js

henkka

 

cumulus