cloudy cloudy

Author Topic: Wxsim 3in1 script  (Read 185167 times)

0 Members and 1 Guest are viewing this topic.

Offline i_fiorentino

  • Alessandro Bardi
  • Posts: 1,682
  • 150 mls Candeglia (Pt), Tuscany, Italy
  • OS/Browser:
  • Win NT 10.0
  • Chrome 54.0.2840.99
    • Meteopistoia.it
Re: Wxsim 3in1 script
« Reply #1200 on: November 16, 2016, 03:43:22 PM »
Hi Wim,
thanks for your patience :)
I've put this string:

Code: [Select]
<link rel="stylesheet" type="text/css" media="screen" href="/home/byoryrxn/newsite/wxsim_wxall/css/wxall.css" />
on header section of my site.
Result is the same :(

Offline i_fiorentino

  • Alessandro Bardi
  • Posts: 1,682
  • 150 mls Candeglia (Pt), Tuscany, Italy
  • OS/Browser:
  • Win NT 10.0
  • Chrome 54.0.2840.99
    • Meteopistoia.it
Re: Wxsim 3in1 script
« Reply #1201 on: November 16, 2016, 03:45:46 PM »
Hi Wim,
thanks for your patience :)
I've put this string:

Code: [Select]
<link rel="stylesheet" type="text/css" media="screen" href="/home/byoryrxn/newsite/wxsim_wxall/css/wxall.css" />
on header section of my site.
Result is the same :(


Fixed!!!
Thank you so much Wim !!!!

Offline janove

  • Posts: 17
  • Vårgårda, Sweden
  • OS/Browser:
  • Win NT 10.0
  • Firefox 49.0
    • Vårgårda Väderstation
Re: Wxsim 3in1 script
« Reply #1202 on: November 17, 2016, 05:14:03 PM »
Hi!
This time I wounder about the icons in the top. I have read all posts but cant find any answer. The icons show snow but here is nearly 10°C and the forecast from SMHI says rain. What am I missing? Here it is: www.janove.se/wxsim_wxall.php if you will look, please.

Thank you!

Jan-Ove

Online wvdkuil

  • Wim van der Kuil
  • Posts: 745
  • Amsterdam / Netherlands
  • OS/Browser:
  • Mac OS X 10.12.1
  • Chrome 54.0.2840.71
    • My private weatherstation
Re: Wxsim 3in1 script
« Reply #1203 on: November 17, 2016, 06:50:49 PM »
Hi!
This time I wounder about the icons in the top. I have read all posts but cant find any answer. The icons show snow but here is nearly 10°C and the forecast from SMHI says rain. What am I missing? Here it is: www.janove.se/wxsim_wxall.php if you will look, please.

Thank you!

Jan-Ove
That is a nice problem.  But it seems to be not in the scripts but in your changes of the default settings.
I used your lastret.txt and plaintext and run the standard download-scripts. The icons are correct there showing rain an no snow flakes.
So check your settings in wxall.settings.php first.
I will see tomorrow if the snow is still there as tonight is busy over here.

Probably there is no C  (capital c) in the line with uoms in wxall.settings.php line 40
Code: [Select]
$uoms = array('∞C','mm','m/s','hPa','cm','km');If there is no C then the temp unit is assumed to be Fahrenheit and the freezing point is 32. As all temps are below that all precipitation is converted to snow in words and snowflakes in the icons.

Wim
« Last Edit: November 17, 2016, 07:12:08 PM by wvdkuil »
Vantage VUE with a WLIP used for https://weer.sluispark.be/
Vantage VP2 with a USB logger/Meteobridge for https://www.weerstation-herent.be/

Offline janove

  • Posts: 17
  • Vårgårda, Sweden
  • OS/Browser:
  • Win NT 10.0
  • Firefox 49.0
    • Vårgårda Väderstation
Re: Wxsim 3in1 script
« Reply #1204 on: November 17, 2016, 09:26:29 PM »
Hi,
I check the settings and there was no C so I changed it and now it works perfect.
Thank you very much for your help Wim.  :signthanks: :occasion5:

Best regards
Jan-Ove

Offline i_fiorentino

  • Alessandro Bardi
  • Posts: 1,682
  • 150 mls Candeglia (Pt), Tuscany, Italy
  • OS/Browser:
  • Win NT 10.0
  • Chrome 55.0.2883.87
    • Meteopistoia.it
Re: Wxsim 3in1 script
« Reply #1205 on: January 10, 2017, 10:57:08 AM »
Hi guys,
do you know where could i fix degrees symbol?

http://i.imgur.com/1wAOuCU.png

On the popup shows ok but not in graphics window.
Thanks in advance.
Regards,



Alessandro

Offline SteveFitz1

  • Posts: 141
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 50.0
    • Tyler Texas Weather
Re: Wxsim 3in1 script
« Reply #1206 on: January 10, 2017, 02:31:00 PM »
Alessandro,

I just made this correction on my site.

First off, I use NotePad ++ as my editor. This allows me the option to save a file with encoding of UTF-8.

Open wxsim.js, then set encoding to UTF-8. I found 5 instances of the degree symbol in wxsim.js. The first is on line 121 in my wxsim.js and is
  var temptitle = "°F";

You probably will not see the actual degree symbol in your file. You may see something like 'xB0'. Change that to the degree symbol. You can enter it by holding the ALT key and keying 0176.

The remaining 4 degree symbols will be preceded by '{value}'. Search for that expression and you'll find each of them. Simply replace them in the same way if necessary. Save the file after you're done.

Hope this helps.

Steve

Offline i_fiorentino

  • Alessandro Bardi
  • Posts: 1,682
  • 150 mls Candeglia (Pt), Tuscany, Italy
  • OS/Browser:
  • Win NT 10.0
  • Chrome 55.0.2883.87
    • Meteopistoia.it
Re: Wxsim 3in1 script
« Reply #1207 on: January 10, 2017, 04:14:19 PM »
Alessandro,

I just made this correction on my site.

First off, I use NotePad ++ as my editor. This allows me the option to save a file with encoding of UTF-8.

Open wxsim.js, then set encoding to UTF-8. I found 5 instances of the degree symbol in wxsim.js. The first is on line 121 in my wxsim.js and is
  var temptitle = "°F";

You probably will not see the actual degree symbol in your file. You may see something like 'xB0'. Change that to the degree symbol. You can enter it by holding the ALT key and keying 0176.

The remaining 4 degree symbols will be preceded by '{value}'. Search for that expression and you'll find each of them. Simply replace them in the same way if necessary. Save the file after you're done.

Hope this helps.

Steve


Wow, great!
Thank you so much Steve :)
Link: http://www.meteopistoia.it/custom/wxsim.php

Last thing.
What kind of symbol is show after w/m?
I've "xB2" on wxsim.js.

Thanks again.
Regards,


Alessandro

Offline SteveFitz1

  • Posts: 141
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 50.0
    • Tyler Texas Weather
Re: Wxsim 3in1 script
« Reply #1208 on: January 10, 2017, 07:33:45 PM »
Alessandro,

Glad that worked. The 'xB2' is for the Superscript 2. Just replace the 'xB2' in the same way you did the 'xB0' but use 0178 instead of 0176.

Steve

Offline i_fiorentino

  • Alessandro Bardi
  • Posts: 1,682
  • 150 mls Candeglia (Pt), Tuscany, Italy
    • Meteopistoia.it
Re: Wxsim 3in1 script
« Reply #1209 on: January 11, 2017, 09:29:29 PM »
Alessandro,

Glad that worked. The 'xB2' is for the Superscript 2. Just replace the 'xB2' in the same way you did the 'xB0' but use 0178 instead of 0176.

Steve
Thank you so much Steve!
Regards,


Alessandro

Inviato dal mio SM-G900F utilizzando Tapatalk


Offline gdumbleton

  • Posts: 153
  • Brantford, ON., Canada
  • OS/Browser:
  • Win NT 10.0
  • Firefox 50.0
    • Brantford Weather (Canada)
Graph not showing after replace my weather computer
« Reply #1210 on: January 19, 2017, 12:48:08 PM »
Hello,

My old weather computer was crashing a lot.  I set up a new system and configured WXSIM the same (I think) as my old computer.

Things that are not going in 3in1 is the top graph, hour by hour, etc. and I believe these come from lastret.txt

I have not touched anything on the web server
Everything worked fine before the new computer
lastret.txt is uploading

Obviously, I have done or not done something in my configuring of WXSIM / WRET but I cannot see anything.

Any ideas what may be wrong?

Thanks

Gary
Cheers,

Gary W Dumbleton