cloudy cloudy

Author Topic: WordPress Blog Add On for Carterlake Templates updated for WP 2.9+  (Read 49548 times)

0 Members and 1 Guest are viewing this topic.

Offline magical46

  • Phils Weather
  • Posts: 598
  • Farnham, Surrey
    • Phils Weather
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #30 on: February 27, 2009, 11:06:16 PM »
Ok all installed everything ok until I click on the
Quote
"Appearance" and choose the theme "Weather Display Blog by Tony Hake & Jack Ahern."

when I get this error message

Quote
Warning: fopen(./flyout-menu.xml) [function.fopen]: failed to open stream: No such file or directory in /home/.sites/150/site462/web/flyout-menu.php on line 92
could not open XML input from ./flyout-menu.xml

Any ideas?

Offline MCHALLIS

  • Posts: 2,158
  • Long Beach, WA USA
    • Weather for Long Beach, WA USA
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #31 on: February 27, 2009, 11:52:25 PM »
Phil, douple check Step 5 ...

Change these three settings in flyout-menu.php:  ....

Offline magical46

  • Phils Weather
  • Posts: 598
  • Farnham, Surrey
    • Phils Weather
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #32 on: February 28, 2009, 12:31:02 AM »
WICKED

My Blog Page is now up and running. Many Many thaks to all involved, especially to Mike for his excellent assistance.

Please take a look, log in and add a comment.

Just got to think of stuff to write!!

Oh well I'll sleep on it

Phil  :D

Offline strandvejr

  • Seaman
  • Posts: 169
  • Sortsø Strand - Denmark
    • Vejrstation Sortsø Strand
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #33 on: March 22, 2009, 12:59:32 PM »
Hi

Just installed wordpress - at Its running almost ok. Just two things is not working correctly - and I have been searching the Forum and the net without finding the solution.

1. The ajax - current condition icon - the text part shows funny character intead of the danish letters ø,å, and æ. It has something to do with the charset - Im using ISO 8859-1 at the rest of my site - but at the blog page http://www.strandvejr.dk/wxblog I can see i the view source that it uses utf-8. Where do I correct that?

2. In the menubar I have a UV icon generated from the "get-uv-forecast-inc.php" file - it does not show at the blog page ...what to change?

Help is much appreciated.

best

strandvejr

Offline MCHALLIS

  • Posts: 2,158
  • Long Beach, WA USA
    • Weather for Long Beach, WA USA
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #34 on: March 23, 2009, 01:06:09 AM »
You can try changing this setting in wp-config.php

Code: [Select]
/** Database Charset to use in creating database tables. */
define('DB_CHARSET', 'utf8');


Offline strandvejr

  • Seaman
  • Posts: 169
  • Sortsø Strand - Denmark
    • Vejrstation Sortsø Strand
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #35 on: March 24, 2009, 09:17:13 AM »
Hi

I need some CSS help here with my blog-page http://www.strandvejr.dk/wxblog/. It doesnt look good at the main blog page. The entries is not showing up in the right way.

What is wrong?

And there is a Firefox problem as well - when I view the page in FF3 the left sidebar does not look good either.

I use the attached CSS file for the hole site.

best

strandvejr

Offline MCHALLIS

  • Posts: 2,158
  • Long Beach, WA USA
    • Weather for Long Beach, WA USA
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #36 on: March 24, 2009, 06:11:40 PM »
strandvejr,

When you post a blog entry with an image you should post the image at the top, then follow the image with a sufficient amount of text to make a paragraph as tall as the image. This way the page will not look like that with the next blog entry next to the image from the last entry..
I am not sure why it has to be that way, but it does.

Sorry I can't help with the menu, I do not have the time.

Offline strandvejr

  • Seaman
  • Posts: 169
  • Sortsø Strand - Denmark
    • Vejrstation Sortsø Strand
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #37 on: March 24, 2009, 07:18:57 PM »
Hi

Ok and thanks - sometimes things are just the way things are.
 I'll live with that for now.

best

strandvejr

abaldish

  • Guest
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #38 on: May 10, 2009, 06:40:24 PM »
Maybe someone can lend a hand here, I have everything up and running, works great, But i am one of those people that likes everything to be Valid XHTML 1.0 lol, So after getting everything up and running, here is the error it gives when checking:

Sorry! This document can not be checked.
Sorry, I am unable to validate this document because on line 220 it contained one or more bytes that I cannot interpret as utf-8 (in other words, the bytes found are not valid values in the specified Character Encoding). Please check both the content of the file and the character encoding indication.

The error was: utf8 "\xB0" does not map to Unicode

I looked high and low for the /xB0 and can not find it, and when the page loads looking at the source here it what it says:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
   "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

So not sure where it is coming up with that.
thanks.

Offline MCHALLIS

  • Posts: 2,158
  • Long Beach, WA USA
    • Weather for Long Beach, WA USA
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #39 on: May 10, 2009, 11:47:40 PM »
Albert, What is the URL to your blog?


Offline linuxfreak

  • Posts: 291
  • Hey there.....
  • Hamilton, Ontario, Canada
    • Hamilton Central Mountain Weather
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #41 on: May 11, 2009, 01:08:28 AM »
Line 220 is your dewpoint display in the ajax gizmo.

I found this when viewing the source:
Code: [Select]
<span class="ajax" id="ajaxdew">41.6�F</span>
looks like your degree symbol got munched somewhere along the way.  #-o

Just my $.02  :wink:

George


Maybe someone can lend a hand here, I have everything up and running, works great, But i am one of those people that likes everything to be Valid XHTML 1.0 lol, So after getting everything up and running, here is the error it gives when checking:

Sorry! This document can not be checked.
Sorry, I am unable to validate this document because on line 220 it contained one or more bytes that I cannot interpret as utf-8 (in other words, the bytes found are not valid values in the specified Character Encoding). Please check both the content of the file and the character encoding indication.

The error was: utf8 "\xB0" does not map to Unicode

I looked high and low for the /xB0 and can not find it, and when the page loads looking at the source here it what it says:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
   "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" dir="ltr">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />

So not sure where it is coming up with that.
thanks.

Davis VP2/FARS, Intel Atom N330 dual-core, 2Gig ram, Windows XP Home SP3 

abaldish

  • Guest
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #42 on: May 11, 2009, 01:22:38 AM »
Yea i see what you are talking about, After looking at my other pages they are fine except the wordpress is the only place it is showing up. so has to be in one of the scripts that is calling it. looking for it now.
Well found where it is calling it from, it get it from ajax-gizmo.php and all the other pages use it and that don't show up in there, here is the data from the php part of that:
<span class="ajax" id="ajaxdew"><?php
          $t1 = strip_units($dewpt);
          echo $dewpt;  ?></span><?php
          echo gen_difference(
          $dewpt, $t1-$dewchangelasthour, '',
          'Increased %s'. $uomTemp .' since last hour.',
          'Decreased %s'. $uomTemp .' since last hour.'); ?>

After playing and playing around, Think i found the problem, Seem there was a power outage around the timestamp and well now that computer won't boot, Just my luck hahahaha. Now the work begins to fix a crash!


Somewhere in wordpress it is adding that and no idea where.
Also took notice that all the other pages load the ajax and updates, but the wordpress page is not.
« Last Edit: May 11, 2009, 02:38:54 AM by abaldish »

abaldish

  • Guest
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #43 on: May 11, 2009, 07:26:40 AM »
Ok back in the game, got the system back up and running, And put all the files back the way they should be for wordpress with the template from mike, Still getting the same issue with the same error:
The error was: utf8 "\xB0" does not map to Unicode. when passed to the validation. Also as the other person posted about the weird char in the ajax part, that still does it and is not updateing, where the rest of the pages are. so now really lost.
even followed the instructions to a t!

thanks.

Offline MCHALLIS

  • Posts: 2,158
  • Long Beach, WA USA
    • Weather for Long Beach, WA USA
Re: WordPress Blog Add On for Carterlake Templates updated for WP 2.7+
« Reply #44 on: May 11, 2009, 05:00:54 PM »
Albert,

This is caused by a bug in ajax-gizmo.php

Edit your ajax-gizmo.php
change:
Code: [Select]
<?php
 $t1 strip_units($dewpt);
 echo $dewpt;  ?>

to:
Code: [Select]
<?php
 $t1 strip_units($dewpt);
 echo $t1 $uomTemp;  ?>

Let me know if that fixed it, because if it does fix it, then I will contact Ken True to have him fix it in the downloadable template set.

 

cumulus