cloudy

Author Topic: Boltek Storm Tracker Lightning Detector  (Read 12811 times)

0 Members and 1 Guest are viewing this topic.

Offline Bob

  • Posts: 244
  • Chatburn, Lancashire, UK
    • Chatburn Weather
Boltek Storm Tracker Lightning Detector
« on: July 01, 2005, 08:11:42 PM »
We've recently bought a Boltek lightning detector, but haven't got it to work yet.  When I install the PCI card, I get the following error when the PC reboots: 

*** STOP: 0x0000001E (0xC0000005, 0xBFC6F23B, 0x00000000, 0x00000000) KMODE_EXCEPTION_NOT_HANDLED

Windows recognises the card, and I have an up-to-date driver for it.  Boltek have suggested I change the setting for the "PNP operating system" in the BIOS, but I can't find that setting.  We're running Win2K. 

Does anyone have any clue about this?
Cheers, Bob

Win 2000 Pro Service Pack 4, Pentium 4 2.8 GHz, 512 Mb RAM, VP Plus Wireless, Leaf wetness soil moisture soil temperature, Boltek Storm Tracker Lightning Detector


Offline Weather Display

  • Posts: 72,521
  • Davis VP1
  • New Zealand
    • Weather Display
Re: Boltek Storm Tracker Lightning Detector
« Reply #1 on: July 01, 2005, 08:28:03 PM »
check in the peripheral part of the bios settings?
fun and games by the look of it!
good for you getting a boltek :)

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 9,949
  • Davis Vue/iMac/Parallels/WinXP
  • Marysville, California
    • Traveling RV Weather
Re: Boltek Storm Tracker Lightning Detector
« Reply #2 on: July 01, 2005, 09:31:12 PM »
Maybe see if this applies.   http://support.microsoft.com/kb/q294728/

Offline Softvark

  • Global Moderator
  • Posts: 4,281
  • UK
    • The weather in Colchester
Re: Boltek Storm Tracker Lightning Detector
« Reply #3 on: July 01, 2005, 10:00:19 PM »
I had a lot of trouble getting the driver working without BSODs. Eventually I rebuilt the PC and that cured it but no explanation for the problems I'm afraid.

Julian

Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 9,949
  • Davis Vue/iMac/Parallels/WinXP
  • Marysville, California
    • Traveling RV Weather
Re: Boltek Storm Tracker Lightning Detector
« Reply #4 on: July 01, 2005, 11:04:26 PM »
Here's a post from the lightning-detectors yahoo group.  Sounds very similar to your problem...

Quote
I had a struggle to get the Boltek StormTracker PCI card working on
my computer. I doubt that my problems would apply to anyone else,
but I thought I would mention them here, just in case...

A year ago, I bought a computer to use as a server for our weather
site. It had an ASUS motherboard, Intel Celeron 2.4 GHz processor,
and 512 MB memory, running under Windows 2000 Pro. It is connected
to the WeatherLink module in a Davis VP Plus system. It also hosts a
MySQL database and some weather-related software I wrote, along with
various weather-related utility programs. All in all, it had a
fairly heavy burden and seemed to cope with it with no difficulty.

I recently purchased and installed a Boltek StormTracker PCI card,
and that's when the problems started. The motherboard had 3 PCI
slots, none of which were occupied. I plugged the Boltek card into
the first one, and the installation seemed normal. The Boltek
software recognized the card, but the system said that I needed to
reboot. I did so, but every subsequent restart resulted in a Dreaded
Blue Screen ("DBS") Stop error. The specific message was:

STOP: 0X0000001E (0xC0000005, 0xBFD18B15, 0x00000000, 0x0000002B)
KMODE_EXCEPTION_NOT_HANDLED

There were no other parameters in the error message to narrow down
the source of the problem.

The machine would restart in Safe Mode, but the Boltek driver was not
loaded. Any attempt to boot normally with the card installed gave
the same DBS error message, and whenever the card was removed the
machine would restart normally.

I wondered if there was a problem with that particular PCI slot, so I
inserted the card into the second PCI slot. The system asked for,
and loaded, the driver, and the Boltek software recognized the card.
When I rebooted, the DBS error reappeared and stayed as long as the
card was in either slot 1 or slot 2. The same sequence of events
happened when I put the card in the 3rd slot. During the course of
all this, I spoke on various occasions to a Boltek tech rep (John
Gilmor) who could not have been more helpful. He suggested a number
of things. I downloaded and installed the newest driver as he
recommended, but it didn't change anything -- the driver was the same
version as the one I already had. In the end, the problem remained,
and I could not get the Boltek PCI card working.

I then concluded that the problem must be with Windows 2000, which is
known to have issues with the Boltek PCI card. I bought the Windows
XP Pro upgrade and set about installing it on top of Windows 2K, as
it recommended, having first pulled the Boltek card. Win XP
completed the install uneventfully, but on the first bootup after the
install finished, it crashed on the second series of animated dots on
the startup screen. After various tries, I could not get XP to
install, so I wiped the hard disk and tried to do a clean install of
XP Pro, starting with nothing. Same result. It would install and
crash during the startup screen. (The Boltek card was not installed
throughout all of this.)

I tried to go back to Win 2K, and it took a couple of attempts to
reinstall it, still with the Boltek card removed. At this point, it
slowly dawned on me that there was a serious hardware problem
completely unrelated to the Boltek card, so I took the computer back
to the vendor. To make a long story short, it appears that there was
some sort of hardware problem on the motherboard (possible conflicts
between the PCI slots and USB 2, but I'm not certain), and it was
replaced under warranty. Stranger yet, the first replacement
motherboard also would not load Win XP, but the second one worked
just fine. After that, Win XP loaded without problems and I was able
to get everything running again.

The bottom line? Well, I'm too embarrassed to reveal how many hours
I spent trying to get the stupid thing working before finally sending
it back to the shop. Let's just say that it was a LOT of time. But
if any of you are having persistent problems to get the Boltek card
working, then you also may have a previously undetected motherboard
problem that only surfaced after the Boltek PCI card was installed.

Sorry for the length of this post, but perhaps it may help someone in
the future,

Offline Weather Display

  • Posts: 72,521
  • Davis VP1
  • New Zealand
    • Weather Display
Re: Boltek Storm Tracker Lightning Detector
« Reply #5 on: July 01, 2005, 11:30:05 PM »
its possible a hair line crack was made worse when trying to put in the boltek..?

Offline Bob

  • Posts: 244
  • Chatburn, Lancashire, UK
    • Chatburn Weather
Re: Boltek Storm Tracker Lightning Detector
« Reply #6 on: July 02, 2005, 01:51:57 PM »
Thanks for your ideas - fortunately, I don't think it's as bad as all that.  We can actually run the PC, and the lightning detector, and it seems to work.  (Only tested it with a gas-lighter, because there's no lightning around just now.)  What we can't do is boot up with the StormTracker card installed.  So until we find a real solution, we'll just have to uninstall it whenever we reboot - which is messy, but better than nothing. 
Cheers, Bob

Win 2000 Pro Service Pack 4, Pentium 4 2.8 GHz, 512 Mb RAM, VP Plus Wireless, Leaf wetness soil moisture soil temperature, Boltek Storm Tracker Lightning Detector


Offline miketish

  • Posts: 110
    • Gozo Weather Station
Re: Boltek Storm Tracker Lightning Detector
« Reply #7 on: July 02, 2005, 02:09:54 PM »
I had exactly the same sort of problem with my Boltek installation, I tried it in both the spare slots I had and both had the error.

I then took out one of the existing boards from another slot, put it into one of the spare slots and then fitted the Boltek into the slot that was now vacant, it then worked perfectly.

Maybe you have already tried this, if not it might be worth a shot  :lol:

Cheers,

Michael

Offline Bob

  • Posts: 244
  • Chatburn, Lancashire, UK
    • Chatburn Weather
Re: Boltek Storm Tracker Lightning Detector
« Reply #8 on: July 02, 2005, 02:58:23 PM »
Michael

Quote
I then took out one of the existing boards from another slot, put it into one of the spare slots and then fitted the Boltek into the slot that was now vacant, it then worked perfectly.

Thanks for the advice. Unfortunatly, both our computers are Shuttle (small form factor) and each only have one slot. As thay both run 24/7 and are connected, if all else fails it may be worth trying the boltek in the other computer. Thanks again

Bob
Cheers, Bob

Win 2000 Pro Service Pack 4, Pentium 4 2.8 GHz, 512 Mb RAM, VP Plus Wireless, Leaf wetness soil moisture soil temperature, Boltek Storm Tracker Lightning Detector


Offline iww

  • Isle of Wight Weather
  • Posts: 694
  • Asinus asinum fricat
  • Isle of Wight (GBR)
    • The Isle of Wight Weather Station Network
Re: Boltek Storm Tracker Lightning Detector
« Reply #9 on: July 02, 2005, 03:01:01 PM »
Looks to be a common problem. I guess the card must be a bit fussy. I had an LD-250 to start with, but it would not run on the same pc as my wd.

Bob - I will pm you details you want.
Shaun Wheeler - The Isle of Wight Weather Station Network


Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 9,949
  • Davis Vue/iMac/Parallels/WinXP
  • Marysville, California
    • Traveling RV Weather
Re: Boltek Storm Tracker Lightning Detector
« Reply #10 on: July 02, 2005, 03:08:30 PM »
I put a cross-post on the YaBB for Astrogenic.  My guess is there are other owners who have had the same problem.  Will be interesting to see how they fixed the problem.  Bob, the bb can be found at http://www.astrogenic.com/cgi-bin/YaBB.pl.

Offline Softvark

  • Global Moderator
  • Posts: 4,281
  • UK
    • The weather in Colchester
Re: Boltek Storm Tracker Lightning Detector
« Reply #11 on: July 02, 2005, 04:13:53 PM »
There have been a few posts on the Yahoo lightning detectors group about this problem Someone reckoned it was because the driver was written using an older version of Jungo's Windriver and Boltek needed to update it. The person got around the same problem you're having by -

Quote
1) Download the latest drivers-
2) From Device Manager - Delete the Jungo Device
3) Delete all instances of WDPNP.SYS and WINDRVR.SYS from your
system.
4) Reboot.
5) When Windows detects the new hardware and asks for the drivers
point it at the files you downloaded in Step 1.
6) Complete the "new hardware routine".
7) Now ensure you have a copy of WDPNP.SYS and WINDRVR.SYS from Step
1 in both C:\WINDOWS\System32\Drivers and in C:\Windows. If not
manually copy them into those locations.
8) Reboot again.

You should now have a working card. There is obviously a bug in the
code that looks for the drivers in two different places.

Don't know if that will help but might be worth a try

Julian

Offline Tarma

  • Posts: 490
  • Oakley, Utah
    • Weber Canyon Weather
Re: Boltek Storm Tracker Lightning Detector
« Reply #12 on: July 02, 2005, 05:31:49 PM »
I had a similar problem with my Asus Pundit (small form factor), except mine happened later. Initially there were no problems with the card, but after messing with a totally unrelated USB driver, I got a similar blue screen (sorry, don't remember details now). What I found interesting was when I restored an older drive image, I still had problems until I disabled the plug and play in the bios. (Usually you reach the bios by hitting the delete key when the system is first booting). Who knows, maybe it was also the incantation of 4 letter words that provided a little extra magic to fix things!

Tarma

Offline Bob

  • Posts: 244
  • Chatburn, Lancashire, UK
    • Chatburn Weather
Re: Boltek Storm Tracker Lightning Detector
« Reply #13 on: July 03, 2005, 01:21:57 PM »
Julian,

I downloaded a copy of windrvr.sys from Boltek, but I can't find wdpnp.sys.  Do you know where I can get it?  Or perhaps I don't need it, because I haven't been asked for it. 
Cheers, Bob

Win 2000 Pro Service Pack 4, Pentium 4 2.8 GHz, 512 Mb RAM, VP Plus Wireless, Leaf wetness soil moisture soil temperature, Boltek Storm Tracker Lightning Detector


Offline NorCal Dan

  • Dan - KJ6RGX
  • Posts: 9,949
  • Davis Vue/iMac/Parallels/WinXP
  • Marysville, California
    • Traveling RV Weather
Re: Boltek Storm Tracker Lightning Detector
« Reply #14 on: July 05, 2005, 05:50:16 AM »
Bob,

Whats the latest on your troubleshooting?