cloudy cloudy

Author Topic: Humidity Tag in Overlay not showing % sign  (Read 241 times)

0 Members and 1 Guest are viewing this topic.

Offline dan43

  • Posts: 447
  • Oregon Scientific WMR300
  • Port Coquitlam, British Columbia, Canada
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 60.0.3112.113
    • Port Coquitlam Weather
Humidity Tag in Overlay not showing % sign
« on: September 08, 2017, 03:23:43 PM »
Hi everyone!  I haven't posted here in a long time, but this issue is bothering me.

When I add %hum% to my overlay tags, if I want the % sign to show after the humidity value, I have to physically type the word "percent".  If I put a % sign after the tag, it looks like this:  %hum%%, but it cuts off all of the subsequent tags like Rain, Wind, etc... you can see an example on my live image, http://portcoquitlamweather.ca/webcam.php.

Would it be possible that if we included/created a tag like %percent%, that it would show the percent sign?

(Note, I did read the other thread on this, but there was no concrete way of fixing this discussed)

Offline Martyn

  • Davis VP2+ FARS/solar/UV
  • Posts: 876
  • Bristol, UK
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 55.0
    • Horfield/Filton, Bristol, UK weather station
Re: Humidity Tag in Overlay not showing % sign
« Reply #1 on: September 08, 2017, 03:42:07 PM »
There is a tag %humpercent% for the value followed by %, but when I tried that, it doesn't work (results in just the value and cuts off any following tags like manually adding the %).

EDIT - I was using pct but have just started using /o (degree symbol / and lower case o)  so %hum%/o which is not brilliant but does look quite like %  :)
« Last Edit: September 08, 2017, 04:03:10 PM by Martyn »
Martyn,
Bristol, UK

Twitter: https://twitter.com/HorfieldWeather
FB: https://www.facebook.com/bristolweather
CWOP: CW2888
WU: IBRISTOL3

Offline dan43

  • Posts: 447
  • Oregon Scientific WMR300
  • Port Coquitlam, British Columbia, Canada
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 60.0.3112.113
    • Port Coquitlam Weather
Re: Humidity Tag in Overlay not showing % sign
« Reply #2 on: September 13, 2017, 08:32:26 PM »
I discover that it works in the overlay if you add the %humpercent% tag, along with an extra % at the end, so it looks like this:  %humpercent%%

Check it out.

Of course, Martyn's method is good too, but if you're a stickler for conformity, then you can use this tag with the extra %.

Offline Martyn

  • Davis VP2+ FARS/solar/UV
  • Posts: 876
  • Bristol, UK
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 55.0
    • Horfield/Filton, Bristol, UK weather station
Re: Humidity Tag in Overlay not showing % sign
« Reply #3 on: September 13, 2017, 08:51:37 PM »
Good call - using %humpercent%% now :)
Martyn,
Bristol, UK

Twitter: https://twitter.com/HorfieldWeather
FB: https://www.facebook.com/bristolweather
CWOP: CW2888
WU: IBRISTOL3