cloudy cloudy

Author Topic: %mintemp% Sometimes Reports 0.0 Degrees Unexpectedly  (Read 180 times)

0 Members and 1 Guest are viewing this topic.

Offline FPGAgeek

  • Posts: 76
  • Davis VP2
  • Dorset, UK
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 55.0
    • Basstudio Weather
%mintemp% Sometimes Reports 0.0 Degrees Unexpectedly
« on: August 23, 2017, 05:02:15 PM »
I have only seen this a handful of times where the daily low temperature is reported at 0.0-degrees Celsius (see attached) even though the graph and data log don't have equivalent data recorded. I think this spurious low temperatures also get logged in the monthly all-time low temperature records too as I currently have July (%recordlowtempjul%), August (%recordlowtempaug%) and September (%recordlowtempsep%) all of which reporting 0.0-degrees in 2016.

This is a similar to this discussion here: https://www.weather-watch.com/smf/index.php/topic,65482.0.html

I am not sure why this happens, is there anything I can do to test this further?

Any thoughts, thanks guys?

Offline Weather Display

  • Posts: 81,704
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 60.0.3112.90
    • Weather Display
Re: %mintemp% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #1 on: August 23, 2017, 08:40:48 PM »
what weather station type?

Offline FPGAgeek

  • Posts: 76
  • Davis VP2
  • Dorset, UK
  • OS/Browser:
  • Android 5.0.2
  • Chrome 59.0.3071.125
    • Basstudio Weather
Re: %mintemp% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #2 on: August 23, 2017, 09:33:51 PM »
Davis VP2 connected via native RS232.

Offline Weather Display

  • Posts: 81,704
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 60.0.3112.90
    • Weather Display
Re: %mintemp% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #3 on: August 23, 2017, 09:41:02 PM »
it could be a periodic fault in the temperature sensor?
you could try setting a minimum temperature value limit in WD as a test (control panel, offsets, limits)

Offline FPGAgeek

  • Posts: 76
  • Davis VP2
  • Dorset, UK
  • OS/Browser:
  • Android 5.0.2
  • Chrome 59.0.3071.125
    • Basstudio Weather
Re: %mintemp% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #4 on: August 24, 2017, 06:32:58 AM »
Yes it could be - what I will do then is tap off the received VP2 RS232 data to another computer such that I have the raw data logged if and when it happens again for comparison.

How does WD manage the samples from the VP2 regarding temperature i.e. are the high/lows compared against each sample received and the current temperature logged (per minute) an average of the samples received?

Thanks

Offline Weather Display

  • Posts: 81,704
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 60.0.3112.90
    • Weather Display
Re: %mintemp% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #5 on: August 24, 2017, 08:13:03 PM »
all the data received over a minute is averaged for the data/log file
but each data point received is used for the max/min of the day

Offline FPGAgeek

  • Posts: 76
  • Davis VP2
  • Dorset, UK
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 55.0
    • Basstudio Weather
Re: %mintemp% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #6 on: August 24, 2017, 08:36:29 PM »
That makes sense.

I will setup a RS232 logger connected to the VP2 data to see if I capture anything, I have only seen this 3x times (i think) before, this was last year so I am not sure if I will capture anything of interest but I will try.

Offline FPGAgeek

  • Posts: 76
  • Davis VP2
  • Dorset, UK
  • OS/Browser:
  • Android 5.0.1
  • Chrome 60.0.3112.107
    • Basstudio Weather
Re: %mintemp% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #7 on: September 05, 2017, 07:21:34 PM »
I saw this issue again on Sunday at 00:26hrs. Unfortunately I hadn't setup my VP2 data capture  #-o I have definitely set it up now and its capturing all VP2 data transmitted from the console to the weather PC interface.