cloudy cloudy

Author Topic: A few queries after setting up Steel Gauges  (Read 334 times)

0 Members and 1 Guest are viewing this topic.

Offline monadh

  • Posts: 70
  • Scotland
  • OS/Browser:
  • Win NT 10.0
  • Firefox 54.0
    • Brora & Nethy Bridge Weather
A few queries after setting up Steel Gauges
« on: August 09, 2017, 02:37:52 PM »
Just setup Steel gauges for my two sites and have the following queries:

1) Why am I getting a strange symbol instead of the degree sign on the temperature gauge
2) Why does the Wind Chill & Apparent show higher than Standard Temp.
3) How do I get information to display in the top box - currently only shows when station down.
4) Any pointers on how to get Graphs working would be appreciated

Sample here; http://monadh.com/nbl.php or http://monadh.com/NB/gauges-ss-basic.htm

Offline oz7mks

  • Posts: 14
  • Davis VP2
  • OS/Browser:
  • Win NT 10.0
  • Firefox 54.0
Re: A few queries after setting up Steel Gauges
« Reply #1 on: August 10, 2017, 05:13:35 AM »
Hi...

It seem that your html-file (gauges-ss-basic.htm) is using japanese character set in line 4; "<head><meta http-equiv="Content-Type" content="text/html; charset=euc-jp">"..
I think that should be changed to: "<head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

Offline monadh

  • Posts: 70
  • Scotland
  • OS/Browser:
  • Win NT 10.0
  • Chrome 52.0.2743.116
    • Brora & Nethy Bridge Weather
Re: A few queries after setting up Steel Gauges
« Reply #2 on: August 10, 2017, 07:50:15 AM »
Hi...

It seem that your html-file (gauges-ss-basic.htm) is using japanese character set in line 4; "<head><meta http-equiv="Content-Type" content="text/html; charset=euc-jp">"..
I think that should be changed to: "<head><meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

Thanks,

I had not spotted that. :oops:
For other users that download the latest version I found that the css file had a fault: @font-face should be .font-face  8O
Correcting these 2 issues have solved item 1) :lol:, now I can move on to the remaining problems #-o

Offline niko

  • syzygy
  • Global Moderator
  • Posts: 26,648
  • Crystal Ball broken! Please post the URL.
  • Northern California, U.S.A.
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 60.0.3112.90
Re: A few queries after setting up Steel Gauges
« Reply #3 on: August 10, 2017, 01:34:05 PM »
The graphs are the "wxgraphs" which use the jpgraph graphing package. There's a very long thread here which will help.

Offline mcrossley

  • Posts: 572
  • Wilmslow, Cheshire, UK
    • none
  • OS/Browser:
  • Win NT 10.0
  • Chrome 60.0.3112.90
    • WilmslowAstro Weather
Re: A few queries after setting up Steel Gauges
« Reply #4 on: August 11, 2017, 08:48:20 AM »
For other users that download the latest version I found that the css file had a fault: @font-face should be .font-face  8O
Correcting these 2 issues have solved item 1) :lol:, now I can move on to the remaining problems #-o
Why do you think @font-face is wrong? You have changed the css into saying "font-face" is a class name rather than a font to be loaded.
Mark

Offline monadh

  • Posts: 70
  • Scotland
  • OS/Browser:
  • Win NT 10.0
  • Chrome 52.0.2743.116
    • Brora & Nethy Bridge Weather
Re: A few queries after setting up Steel Gauges
« Reply #5 on: August 11, 2017, 10:01:33 AM »
Why do you think @font-face is wrong? You have changed the css into saying "font-face" is a class name rather than a font to be loaded.

Sorry my lack of knowledge :oops: I changed it and it all then worked :roll:

I have now changed it back and all is working as it should :D

Offline monadh

  • Posts: 70
  • Scotland
  • OS/Browser:
  • Win NT 10.0
  • Chrome 52.0.2743.116
    • Brora & Nethy Bridge Weather
Re: A few queries after setting up Steel Gauges
« Reply #6 on: August 13, 2017, 11:14:48 AM »
Thanks to all for your help. :D

I now have everything working on both sites :multi: can be seen here:-  http://monadh.com/nbwcl.php

Using ;-
WD v10.37S Build 54
PHP  v7.1
Steel Gauges v2.6.2
JPgraph v4.0.2
WXgraphs v3.0

Checked with browsers:-
Safari
Chrome
Firefox
IE11
Edge

Ray

Offline niko

  • syzygy
  • Global Moderator
  • Posts: 26,648
  • Crystal Ball broken! Please post the URL.
  • Northern California, U.S.A.
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 60.0.3112.90
Re: A few queries after setting up Steel Gauges
« Reply #7 on: August 13, 2017, 01:15:01 PM »
Good job sir  =D&gt;