cloudy cloudy

Author Topic: %mintemplast24hours% Sometimes Reports 0.0 Degrees Unexpectedly  (Read 317 times)

0 Members and 1 Guest are viewing this topic.

Offline FPGAgeek

  • Posts: 77
  • Davis VP2
  • Dorset, UK
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 54.0
    • Basstudio Weather
I am hoping someone can help me with this one as I am not sure why it happens.

I generate daily weather email reports at 11:59 and 23:59 every day.
In the weather email report I include the lowest temperature in the last 24-hours using the following tags:
Code: [Select]
%mintemplast24hours%°C at %mintemplast24hourst%
However, sometimes (about 1-in-5 reports) it says 0.0C at 11:59 or 23:59 (depending on which report of the day is generated) even though the temperature has never dropped to freezing. I have inspected the data log file and this has the correct temperatures recorded i.e. it is not 0.0-degrees. To me it seems coincidental that the logged time for this temperature is the same for when the report was generated!

Any ideas......... thanks guys.

Offline Weather Display

  • Posts: 81,844
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 59.0.3071.115
    • Weather Display
Re: %mintemplast24hours% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #1 on: August 07, 2017, 09:10:49 PM »
I have added an extra data quality check and  changed the local variable name used (as it might have been getting corrupted) in this version you could try
http://www.weather-display.com/downloadfiles/weatherdisplaytest.zip

Offline FPGAgeek

  • Posts: 77
  • Davis VP2
  • Dorset, UK
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 54.0
    • Basstudio Weather
Re: %mintemplast24hours% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #2 on: August 07, 2017, 10:24:05 PM »
I have added an extra data quality check and  changed the local variable name used (as it might have been getting corrupted) in this version you could try
http://www.weather-display.com/downloadfiles/weatherdisplaytest.zip

Thanks Brian.
This test version is now running here so I will check each report and see what happens over the next few days and let you know.

Offline FPGAgeek

  • Posts: 77
  • Davis VP2
  • Dorset, UK
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 54.0
    • Basstudio Weather
Re: %mintemplast24hours% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #3 on: August 16, 2017, 07:28:43 PM »
It looks like this is working better. Most of the time the 24hr low temp looks right (%mintemplast24hours%), but not always, and the corresponding time/date of the 24hr low (%mintemplast24hourst%) is quite often wrong.

Yesterday is a prime example I can share, in which my report emailed at 23:59hrs = 8.7C at 19:49 15/08/17
I have attached my graph for yesterday which shows that the temperature never dropped below approx 13C, additionally in the same report the temperature low for the day = 13.8C at 23:58

Sorry for the bad news, if there is anything I can do to help e.g. further info please let me know.

Offline Weather Display

  • Posts: 81,844
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 60.0.3112.90
    • Weather Display
Re: %mintemplast24hours% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #4 on: August 16, 2017, 09:18:34 PM »
I should be able to improve this, stand by

Offline Weather Display

  • Posts: 81,844
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 60.0.3112.90
    • Weather Display
Re: %mintemplast24hours% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #5 on: August 16, 2017, 09:32:48 PM »
try a new update (same URL as above)

Offline FPGAgeek

  • Posts: 77
  • Davis VP2
  • Dorset, UK
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 54.0
    • Basstudio Weather
Re: %mintemplast24hours% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #6 on: August 17, 2017, 07:00:16 AM »
Thanks for the update - its now running here so I will see how it goes.

Offline FPGAgeek

  • Posts: 77
  • Davis VP2
  • Dorset, UK
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 55.0
    • Basstudio Weather
Re: %mintemplast24hours% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #7 on: August 27, 2017, 11:20:30 AM »
The test update has been working fine over the last week - can this fix be included in the main build (if not already) thanks.

Thanks for the support.

Offline Weather Display

  • Posts: 81,844
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 60.0.3112.90
    • Weather Display
Re: %mintemplast24hours% Sometimes Reports 0.0 Degrees Unexpectedly
« Reply #8 on: August 28, 2017, 03:11:17 AM »
it is