cloudy cloudy

Author Topic: WDL not working with MS Edge  (Read 471 times)

0 Members and 1 Guest are viewing this topic.

Offline monadh

  • Posts: 70
  • Scotland
  • OS/Browser:
  • Win NT 10.0
  • Firefox 54.0
    • Brora & Nethy Bridge Weather
WDL not working with MS Edge
« on: August 07, 2017, 10:12:13 AM »
Has anybody managed to get WDL working with MS Edge browser?
I have tried all the MS recommended settings but still cannot get it to work on either of my two sites or any others I have tried.
See example here http://monadh.com/nbl.php
Any ideas would be appreciated.

Offline teal

  • Posts: 790
  • Davis vantage pro 2 windows 10
  • Norfolk England
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 59.0.3071.115
    • Weather At Wilney Green Norfolk
Re: WDL not working with MS Edge
« Reply #1 on: August 07, 2017, 01:19:25 PM »
 My WDL is working OK here with Edge on my PC,  go into settings top right hand (three little dots) side of Edge page, then click on settings, then click on advanced settings, then turn on use "Adobe Flash Player" see upload.

  teal.

Offline monadh

  • Posts: 70
  • Scotland
  • OS/Browser:
  • Win NT 10.0
  • Firefox 54.0
    • Brora & Nethy Bridge Weather
Re: WDL not working with MS Edge
« Reply #2 on: August 07, 2017, 02:20:17 PM »
teal,
I have already enabled Flash as you suggest. It must be some other setting as your live site will not load in my Edge browser.
Have you altered/enabled any other setting, and can you load my site in your Edge?

Ray

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 740
  • Amsterdam / Netherlands
  • OS/Browser:
  • Mac OS X 10.12.6
  • Chrome 59.0.3071.115
    • My private weatherstation
Re: WDL not working with MS Edge
« Reply #3 on: August 07, 2017, 02:25:46 PM »
It is not Flash, but another error:
Console:
swfobject.js Failed to load resource: the server responded with a status of 404 (Not Found)

HTML:
Code: [Select]
   var so = new SWFObject(versionOfWdl+"?"+pathToWdlconfig, versionOfWdl, widthOfWdl, heightOfWdl, "8", backgroundColourOfWdl);
So it is not working on any browser I have here. Not on Edge/IE or Chrome.

Wim
Vantage VUE with a WLIP used for https://weer.sluispark.be/
Vantage VP2 with a USB logger/Meteobridge for https://www.weerstation-herent.be/

Offline monadh

  • Posts: 70
  • Scotland
  • OS/Browser:
  • Win NT 10.0
  • Firefox 54.0
    • Brora & Nethy Bridge Weather
Re: WDL not working with MS Edge
« Reply #4 on: August 07, 2017, 03:10:23 PM »
Thanks Wim,

I had renamed the js file in my attempt to solve the Edge problem.
I found the cause after your comment as Safari showed the problem, but the other browsers were using a cached version of the file.
Unfortunately this does not solve my Edge problem.

Ray

Offline wvdkuil

  • Wim van der Kuil
  • Posts: 740
  • Amsterdam / Netherlands
  • OS/Browser:
  • Mac OS X 10.12.6
  • Chrome 59.0.3071.115
    • My private weatherstation
Re: WDL not working with MS Edge
« Reply #5 on: August 07, 2017, 04:07:25 PM »
Thanks Wim,

I had renamed the js file in my attempt to solve the Edge problem.
I found the cause after your comment as Safari showed the problem, but the other browsers were using a cached version of the file.
Unfortunately this does not solve my Edge problem.

Ray
You are running a relative old version (1.4.4) of swfobject.js
You could try to use the 2.2 version from https://developers.google.com/speed/libraries/#swfobject
Replace in your script NB/nblive.html the line
Code: [Select]
<script type="text/javascript" src="swfobject.js"></script>with
Code: [Select]
<script src="https://ajax.googleapis.com/ajax/libs/swfobject/2.2/swfobject.js"></script>
SORRY, will not work either, version 2.3 is needed according to Adobe.
http://blogs.adobe.com/flashplayer/2015/10/flash-player-guidance-for-internet-explorer-11-and-microsoft-edge.html#sthash.QXbtXUY2.JwlTeLUW.dpbs

So you have to remove swfobject and use the plain FLASH commands.

It is much easier to debug for us outsiders, if you give, next time,  a real link to a problem-page, not a page with the problem hidden in an iFrame.  This is the real link this time : http://monadh.com/NB/nblive.html

Wim

« Last Edit: August 07, 2017, 04:18:54 PM by wvdkuil »
Vantage VUE with a WLIP used for https://weer.sluispark.be/
Vantage VP2 with a USB logger/Meteobridge for https://www.weerstation-herent.be/

Offline monadh

  • Posts: 70
  • Scotland
  • OS/Browser:
  • Win NT 10.0
  • Firefox 54.0
    • Brora & Nethy Bridge Weather
Re: WDL not working with MS Edge
« Reply #6 on: August 07, 2017, 05:19:23 PM »
Thanks Wim,

Sorry I did not post the direct link causing the problem.

Not sure how to:- "So you have to remove swfobject and use the plain FLASH commands."

Do have an example or link to one?

Ray

Offline Weather Display

  • Posts: 81,684
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 59.0.3071.115
    • Weather Display
Re: WDL not working with MS Edge
« Reply #7 on: August 07, 2017, 07:09:28 PM »
flash now has a date not far in the future where it will not work at all
so might be a good time now to setup the steel gauges
http://www.weather-display.com/windy/gb/gauges-ss.html
(I have a youtube video on how to do that)

or setup meteotemplate on your web site, where you can easily setup to use the steel gauges

Offline bitsostring

  • Posts: 194
  • WMR200
  • Edinburgh, UK
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
Re: WDL not working with MS Edge
« Reply #8 on: August 07, 2017, 08:29:56 PM »
My WDL is working OK here with Edge on my PC,  go into settings top right hand (three little dots) side of Edge page, then click on settings, then click on advanced settings, then turn on use "Adobe Flash Player" see upload.

That works for me too in Edge.

However, even after enabling Java and Flash in the latest version of Chrome (60.0.3112.90) I had to specifically allow my own WDL site.
It's meant to be fun. . .

Offline monadh

  • Posts: 70
  • Scotland
  • OS/Browser:
  • Win NT 10.0
  • Mozilla compatible
    • Brora & Nethy Bridge Weather
Re: WDL not working with MS Edge
« Reply #9 on: August 08, 2017, 06:52:30 PM »
flash now has a date not far in the future where it will not work at all
so might be a good time now to setup the steel gauges
http://www.weather-display.com/windy/gb/gauges-ss.html
(I have a youtube video on how to do that)

or setup meteotemplate on your web site, where you can easily setup to use the steel gauges

Thanks Brian,
I have taken the plunge and now have the Steel Gauges basically working for both my sites.
When I have cleaned them up I will use instead of WDL
Ray

Offline Weather Display

  • Posts: 81,684
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 60.0.3112.90
    • Weather Display
Re: WDL not working with MS Edge
« Reply #10 on: August 08, 2017, 07:33:37 PM »
 :hello1: :occasion5:

 

cumulus