cloudy cloudy

Author Topic: Weather Display and Meteotemplate API Rain Rate issue  (Read 886 times)

0 Members and 1 Guest are viewing this topic.

Offline justinhow

  • Posts: 15
  • Bit of a geek really
  • Slough, UK
  • OS/Browser:
  • Win NT 10.0
  • Firefox 53.0
    • East Berkshire Weather
Re: Weather Display and Meteotemplate API Rain Rate issue
« Reply #15 on: June 07, 2017, 09:41:50 PM »
Should this be sending the mm/hour on a rolling 1 min average (as in the attached file)? It does not appear to be sending this.
Station: Davis Vantage Pro2, Weather Display 10.37S53, Meteotemplate 14
Location: Langley, Berkshire, England
http://www.eastberks-weather.com

Offline Weather Display

  • Posts: 81,468
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 58.0.3029.110
    • Weather Display
Re: Weather Display and Meteotemplate API Rain Rate issue
« Reply #16 on: June 07, 2017, 10:06:02 PM »
its sending a rolling 1 minute average
that is not what shows on the WD main screen

Offline justinhow

  • Posts: 15
  • Bit of a geek really
  • Slough, UK
  • OS/Browser:
  • Win NT 10.0
  • Firefox 53.0
    • East Berkshire Weather
Re: Weather Display and Meteotemplate API Rain Rate issue
« Reply #17 on: June 07, 2017, 10:19:48 PM »
But presumably it would typically be something fairly similar.
At the time of the above screen shot the API registered 0.0mm/hr
Station: Davis Vantage Pro2, Weather Display 10.37S53, Meteotemplate 14
Location: Langley, Berkshire, England
http://www.eastberks-weather.com

Offline Weather Display

  • Posts: 81,468
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 58.0.3029.110
    • Weather Display
Re: Weather Display and Meteotemplate API Rain Rate issue
« Reply #18 on: June 07, 2017, 10:23:56 PM »
you would need to check on what is being sent over the minute of data sends after the rain rate has been recorded in WD
I have tested here by setting a rain rate in code and it sent the correct data
are you sure you are using the new update of WD (check the file change date/time)

Offline justinhow

  • Posts: 15
  • Bit of a geek really
  • Slough, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 52.0.2743.116
    • East Berkshire Weather
Re: Weather Display and Meteotemplate API Rain Rate issue
« Reply #19 on: June 08, 2017, 08:34:38 AM »
I will do some more checks when there is a bit more rain.
Thanks
Station: Davis Vantage Pro2, Weather Display 10.37S53, Meteotemplate 14
Location: Langley, Berkshire, England
http://www.eastberks-weather.com

Offline weatherbee

  • Posts: 694
  • Sherman, Ct.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 58.0.3029.110
    • Sherman Ct. Weather
Re: Weather Display and Meteotemplate API Rain Rate issue
« Reply #20 on: June 15, 2017, 12:25:45 PM »
I'm using this test version.  It worked well when it was raining but I've had two days of no rain and it still showing a rainrate of .12 in/hr.
Tom
Sony Pentium 4, 1.6 GHZ,512 MB Ram, Windows XP Pro, SP2

Offline justinhow

  • Posts: 15
  • Bit of a geek really
  • Slough, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 52.0.2743.116
    • East Berkshire Weather
Re: Weather Display and Meteotemplate API Rain Rate issue
« Reply #21 on: June 19, 2017, 03:47:05 PM »
I have not forgotten this - there has just been no significant rain in my area for quite sometime - heatwave now for next few days! Reading 36C in my garden at the moment!
Station: Davis Vantage Pro2, Weather Display 10.37S53, Meteotemplate 14
Location: Langley, Berkshire, England
http://www.eastberks-weather.com

Offline Weather Display

  • Posts: 81,468
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 58.0.3029.110
    • Weather Display
Re: Weather Display and Meteotemplate API Rain Rate issue
« Reply #22 on: June 19, 2017, 09:01:15 PM »
Quote
but I've had two days of no rain and it still showing a rainrate of .12 in/hr.
ah
with no rain it was not going to reset
use the latest .zip update of WD to fix that

Offline weatherbee

  • Posts: 694
  • Sherman, Ct.
  • OS/Browser:
  • Win NT 10.0
  • Chrome 58.0.3029.110
    • Sherman Ct. Weather
Re: Weather Display and Meteotemplate API Rain Rate issue
« Reply #23 on: June 21, 2017, 11:22:25 AM »
Thanks Brian.  That works.
Tom
Sony Pentium 4, 1.6 GHZ,512 MB Ram, Windows XP Pro, SP2

Offline justinhow

  • Posts: 15
  • Bit of a geek really
  • Slough, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 52.0.2743.116
    • East Berkshire Weather
Re: Weather Display and Meteotemplate API Rain Rate issue
« Reply #24 on: June 27, 2017, 11:58:56 AM »
Hi Brian
Ok - at last it is raining here (the grass is not looking good at all!) and it appears that this RR issue is fixed - I will keep an eye on it.

Thanks for the quick response!
Justin
Station: Davis Vantage Pro2, Weather Display 10.37S53, Meteotemplate 14
Location: Langley, Berkshire, England
http://www.eastberks-weather.com