cloudy cloudy

Author Topic: 1 forum mod? and email sending  (Read 804 times)

0 Members and 1 Guest are viewing this topic.

Offline niko

  • syzygy
  • Global Moderator
  • Posts: 26,453
  • Crystal Ball broken! Please post the URL.
  • Northern California, U.S.A.
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Chrome 56.0.2924.87
Re: 1 forum mod? and email sending
« Reply #30 on: February 13, 2017, 04:41:40 PM »
The auto timezone thing is just broken in SMF, this isn't the only forum that I have to either adjust for DST or just live with the time being "off" part of the year.

Offline Bashy

  • Posts: 1,280
  • Suffolk, UK
  • OS/Browser:
  • Android 5.0
  • Chrome 55.0.2883.91
    • Suffolk Weather
Re: 1 forum mod? and email sending
« Reply #31 on: February 13, 2017, 04:50:50 PM »
An smf bug then I take it, no worries, I didn't notice tilnwe started messing with emails lol

Offline administrator

  • Administrator
  • Posts: 10,770
  • Get answers to your questions - use Forum SEARCH!
  • Blackpool, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 56.0.2924.87
    • Weather-Watch.com
Re: 1 forum mod? and email sending
« Reply #32 on: February 13, 2017, 05:11:30 PM »
Not sure it's fair to call it a bug. We've got an international forum with users in pretty much every time zone and there's no guaranteed way from a browser interface to know how local time on your PC compares to UTC. Add onto that that some time zones are plain weird and not based on geography, e.g. China covers three time zones but only uses one, plus there are 30 minute time zones in some places. Then the use of DST varies dramatically (I think I saw that that some US states have areas with DST, other areas with no-DST, and some that have a 30 minute DST). Oh and don't forget that there's northern and southern hemisphere DST to contend with. I'm amazed that SMF gets close to getting it right!
Chris
Weather Forum Administrator

Offline Bashy

  • Posts: 1,280
  • Suffolk, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 56.0.2924.87
    • Suffolk Weather
Re: 1 forum mod? and email sending
« Reply #33 on: February 13, 2017, 05:14:02 PM »
You would think it would get GMT right though seen as thats what all the rest are based on

Offline administrator

  • Administrator
  • Posts: 10,770
  • Get answers to your questions - use Forum SEARCH!
  • Blackpool, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 56.0.2924.87
    • Weather-Watch.com
Re: 1 forum mod? and email sending
« Reply #34 on: February 13, 2017, 05:28:50 PM »
It does for me (now). Historically I had it set to the time in the location where the servers are (Germany) so the offsets looked weird...internally '-1' (which you don't see) so you had to set '1' in your profile to get back to UTC. I've now properly set the server to UTC and the forum zone to UTC with a zero hour offset. That means that my profile offset is now zero too. The times are OK for me now, but they're probably wrong for everyone else now!
 
Chris
Weather Forum Administrator

Offline Bashy

  • Posts: 1,280
  • Suffolk, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 56.0.2924.87
    • Suffolk Weather
Re: 1 forum mod? and email sending
« Reply #35 on: February 13, 2017, 05:42:13 PM »
Ah yeah, server time is a pain for forums, i normally have a server in the US and it was rae i could get the time right on the server for over here lol

Offline administrator

  • Administrator
  • Posts: 10,770
  • Get answers to your questions - use Forum SEARCH!
  • Blackpool, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 56.0.2924.87
    • Weather-Watch.com
Re: 1 forum mod? and email sending
« Reply #36 on: February 13, 2017, 05:49:57 PM »
Stick with UTC on your server. Then you can move it anywhere in the world and the time will always be the same.
Chris
Weather Forum Administrator

Offline Bashy

  • Posts: 1,280
  • Suffolk, UK
  • OS/Browser:
  • Win NT 10.0
  • Chrome 56.0.2924.87
    • Suffolk Weather
Re: 1 forum mod? and email sending
« Reply #37 on: February 13, 2017, 05:51:02 PM »
Ah, ok, good tip, thanks :)