cloudy cloudy

Author Topic: new youtube help vidoes for setting up WD :)  (Read 4407 times)

0 Members and 1 Guest are viewing this topic.

Offline Weather Display

  • Posts: 80,288
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 47.0.2526.106
    • Weather Display
Re: new youtube help vidoes for setting up WD :)
« Reply #15 on: December 30, 2015, 06:19:26 PM »
then by uploading any missing dailynoaa reports that should come correct

I will add a video today of how to use wunderground data to fill in missing data in WD

Online Murry Conarroe

  • Posts: 605
  • Decatur, Texas
  • OS/Browser:
  • Win NT 10.0
  • Firefox 43.0
    • Wildwood Weather
Re: new youtube help vidoes for setting up WD :)
« Reply #16 on: December 30, 2015, 06:20:08 PM »
As an example, please see http://tiggrweather.net/wxbarosummary.php. I started in 4/2006, and the black holes between then and now used to have data. Don't know how it got lost. I got a lot filled in by downloading all WU data for a full month (day by day unfortunately), then putting that into a single file (something like 82010wu.csv), and then getting that to wind up in WD filling in a missing month of soup to nuts data. When my HD crashed so did my instructions and all the data I had previously loaded.The NOAA Report and Monthly Report normally created at 0000; e.g., dailynoaareport, etc. Yes, recreate and import.

Thanks.

The barometer (and dewpoint & wetbulb) scripts use the climatedataout files, not the NOAA reports.
The 'holes' are because the climatedataout files for those months are not on your website. If they are not in the webfiles of WD,
recreate the climatedataout files for the needed months and upload.
Murry

Offline Weather Display

  • Posts: 80,288
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 47.0.2526.106
    • Weather Display
Re: new youtube help vidoes for setting up WD :)
« Reply #17 on: December 30, 2015, 06:24:52 PM »
thanks Murray
viewing a missing detailed climate data in WD will create a date stamped output file
e.g if you view month 6 2008 a climatedataout62008.html file will get created in the web files folder so you can upload that

Offline jgillett

  • John - W7JKG
  • Posts: 871
  • Phoenix, AZ
  • OS/Browser:
  • Mac OS X 10.11
  • Firefox 43.0
    • TiggrWeather Phoenix
Re: new youtube help vidoes for setting up WD :)
« Reply #18 on: December 30, 2015, 07:37:11 PM »
Murry, thanks for the correction.

Brian, tried a number of the blank dates I have showing. The files were created, but are essentially blank as far as data is concerned. Please see attachment (it's the same for all I tried and for the full month - didn't want to waste the space).

Thanks.
John
W7JKG


Offline Weather Display

  • Posts: 80,288
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 47.0.2526.106
    • Weather Display
Re: new youtube help vidoes for setting up WD :)
« Reply #19 on: December 30, 2015, 07:40:56 PM »
try converting that months logfile to date file
(there is now a youtube video on that)

Offline jgillett

  • John - W7JKG
  • Posts: 871
  • Phoenix, AZ
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 43.0
    • TiggrWeather Phoenix
Re: new youtube help vidoes for setting up WD :)
« Reply #20 on: December 30, 2015, 09:55:13 PM »
try converting that months logfile to date file
(there is now a youtube video on that)
Trying to start with the oldest - 52006, 52007, 52008, then 62006, etc. There are NO lg.txt files for any of those, nor any of the others that are missing. Also, it's not only the baro data (that link was just an example), but ALL Wx data for the blank items shown on that link - http://tiggrweather.net/wxbarosummary.php - temp, rain, wind, etc., etc. Use the WX Summary item on the nav bar to see any others. The same months/years are missing data.

Thanks.
John
W7JKG


Offline Weather Display

  • Posts: 80,288
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 47.0.2526.106
    • Weather Display
Re: new youtube help vidoes for setting up WD :)
« Reply #21 on: December 30, 2015, 10:28:43 PM »
what happened to your data to loose it like that?

Offline jgillett

  • John - W7JKG
  • Posts: 871
  • Phoenix, AZ
  • OS/Browser:
  • Mac OS X 10.11
  • Firefox 43.0
    • TiggrWeather Phoenix
Re: new youtube help vidoes for setting up WD :)
« Reply #22 on: December 30, 2015, 10:39:17 PM »
Brian, really wish I knew. Over 5 years of recent good data, but that huge missing chunk early on. As mentioned, I remember having to get the data from WU day by day (they don't offer getting a full month at a time, or at least not the last time I looked), then combining that into one monthly file, etc., etc. It's the etc., etc., that I've forgotten how to do.

Thanks.
John
W7JKG


Offline Weather Display

  • Posts: 80,288
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 47.0.2526.106
    • Weather Display
Re: new youtube help vidoes for setting up WD :)
« Reply #23 on: December 31, 2015, 06:28:32 PM »
I am going to do that video next...
but I am thinking I could automate that process...in WD...in an added function...or even a separate .exe...which you would leave running to do its thing...good idea?

Offline jgillett

  • John - W7JKG
  • Posts: 871
  • Phoenix, AZ
  • OS/Browser:
  • Mac OS X 10.11
  • Firefox 43.0
    • TiggrWeather Phoenix
Re: new youtube help vidoes for setting up WD :)
« Reply #24 on: December 31, 2015, 06:42:02 PM »
I am going to do that video next...
but I am thinking I could automate that process...in WD...in an added function...or even a separate .exe...which you would leave running to do its thing...good idea?
Absolutely! Anything you can do to make it easier on this old withering brain will be most appreciated!   :D
John
W7JKG


Offline hydrowx

  • Bill
  • Posts: 1,588
  • Northeast Illinois USA
  • OS/Browser:
  • Mac OS X 10.10.5
  • Safari 9.0.2
    • Goose Lake Weather
Re: new youtube help vidoes for setting up WD :)
« Reply #25 on: December 31, 2015, 07:03:46 PM »
Just discovered the YouTube videos. Nice job Brian! =D>
Bill


Davis VP2+

Offline Weather Display

  • Posts: 80,288
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 47.0.2526.106
    • Weather Display
Re: new youtube help vidoes for setting up WD :)
« Reply #26 on: December 31, 2015, 11:47:40 PM »
I have added a new wunderground import function, that is all automatic, to import a whole month of data (or selected days (this needs manual work after))
to this new version
http://www.weather-display.com/downloadfiles/weatherdisplaytest.zip
build 307

(see under action, import....wunderground csv import)

do back up the month/data file you are importing for first
only tested with my data...

Offline jgillett

  • John - W7JKG
  • Posts: 871
  • Phoenix, AZ
  • OS/Browser:
  • Mac OS X 10.11
  • Firefox 43.0
    • TiggrWeather Phoenix
Re: new youtube help vidoes for setting up WD :)
« Reply #27 on: January 01, 2016, 06:04:29 PM »
Got 307, Brian. Will let you know.

Thanks!!
John
W7JKG


Offline Weather Display

  • Posts: 80,288
  • Davis VP2
  • New Zealand
  • OS/Browser:
  • Win NT 10.0
  • Chrome 47.0.2526.106
    • Weather Display
Re: new youtube help vidoes for setting up WD :)
« Reply #28 on: January 01, 2016, 06:38:00 PM »
just to note that if you are using the function to fill in missing data for a month of data you have already, then its a bit more complicated
you would need to back up the existing logfile
then once you have done the import, slot in the new created logfile file (for that month) into the back up, where the missing data is, and then use action, convert WD logfiles to data files

Offline jgillett

  • John - W7JKG
  • Posts: 871
  • Phoenix, AZ
  • OS/Browser:
  • Win 7/Srvr 2008R2
  • Firefox 43.0
    • TiggrWeather Phoenix
Re: new youtube help vidoes for setting up WD :)
« Reply #29 on: January 01, 2016, 06:57:46 PM »
Problems (of course).

The file for 62010lg.txt imported fine from WU. However, the data in it seems to be incorrect; the 34276.701 entry in column 9). Compare with 52010lg.txt which was properly loaded by WD way back then. The table display at http://www.wunderground.com/personal-weather-station/dashboard?ID=KAZPHOEN59#history/tdata/s20100601/e20100601/mdaily appears to be OK. Did I miss ticking a box in the setup?

Also in test.jpg the text overrun in the upper circled item (assume it's the same data as in the lower circled item). However, after clicking the convert log to graph button that file is nowhere to be found.

Thanks.
« Last Edit: January 01, 2016, 07:03:56 PM by jgillett »
John
W7JKG