cloudy

Author Topic: The RemoteHost address is invalid (0.0.0.0). [RESOLVED]  (Read 5782 times)

0 Members and 1 Guest are viewing this topic.

Offline thedentaltourist

  • Posts: 14
The RemoteHost address is invalid (0.0.0.0). [RESOLVED]
« on: January 23, 2008, 10:19:16 AM »
I'm pulling my hair out and I've not got much left so please if anyone has an answer to my problem please let me know.

Weather display appears to be working OK. However, when I try to upload to the web there seems to be a slight problem.

ERROR: 11004: [11004] Valid name, no data record (check DNS setup) at time/date 06:53:02 23/01/2008
 
I've also gone through the web page wizard and the ftp log shows
 
*******list of files uploaded********
 
*******actual messages from upload session********
***Start Time/date***:09:47:35 23/01/2008
Permanent connection selected
Permanent connection, will do ftp now
Finshed email agenda
Finshed email agenda, and more Internet agenda items to do (FTP)....
***Time/date***:09:47:37 23/01/2008
Logging onto FTP server....wetyorkshire.org.uk
11004: [11004] Valid name, no data record (check DNS setup)
Connecting to FTP server.
102: The RemoteHost address is invalid (0.0.0.0).
Doing abort procedure/program close...

I've checked the ftp settings and they're ok. I have of course the same problems with display live too. Consulted Brian and Julian but no suggestions other than inncorrect ftp info or firewall problem and I don't think it's either. Found somebody with a similar problem but the post didn't really answer the question.

Any ideas?
« Last Edit: June 16, 2009, 12:47:58 AM by windy »

Offline niko

  • syzygy
  • Global Moderator
  • Posts: 24,205
  • Crystal Ball broken! Please post the URL.
  • Northern California, U.S.A.
    • http://www.realweatherstation.com
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #1 on: January 23, 2008, 01:00:59 PM »
They are correct, something external to WD is blocking its FTP functions.

wetyorkshire.org.uk is a valid ftp server address
 
Are other programs on that PC, eg the browser, able to access the internet OK?

In windows do:

Start
Run
cmd

at the prompt type

ftp wetyorkshire.org.uk

hit enter and tell us what happens.

What OS do you have?

Are you using Windows Firewall/Security?

Are you using other firewall/security software, eg Norton, Mcafee?


Offline thedentaltourist

  • Posts: 14
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #2 on: January 23, 2008, 01:16:00 PM »
They are correct, something external to WD is blocking its FTP functions.

wetyorkshire.org.uk is a valid ftp server address
 
Are other programs on that PC, eg the browser, able to access the internet OK?

In windows do:

Start
Run
cmd

at the prompt type

ftp wetyorkshire.org.uk

hit enter and tell us what happens.

What OS do you have?

Are you using Windows Firewall/Security?

Are you using other firewall/security software, eg Norton, Mcafee?


Hi Niko

I ran the command and this is the result

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Chris Sparks>ftp wetyorkshire.org.uk
Connected to wetyorkshire.org.uk.
220---------- Welcome to Pure-FTPd [TLS] ----------
220-You are user number 2 of 100 allowed.
220-Local time is now 14:01. Server port: 21.
220-This is a private system - No anonymous login
220 You will be disconnected after 15 minutes of inactivity.
User (wetyorkshire.org.uk:(none)): sr0870588
331 User sr0870588 OK. Password required
Password:
230-User sr0870588 has group access to:  f-users
230 OK. Current restricted directory is /
ftp>

I'm using Wndows XP

and only Wndows firewall



Offline niko

  • syzygy
  • Global Moderator
  • Posts: 24,205
  • Crystal Ball broken! Please post the URL.
  • Northern California, U.S.A.
    • http://www.realweatherstation.com
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #3 on: January 23, 2008, 01:42:48 PM »
You need to back off the security settings in windows then. Try turning it off altogether just to test.

Offline thedentaltourist

  • Posts: 14
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #4 on: January 23, 2008, 01:48:21 PM »
OK turned firewall off and...

No change

I contacted my ISP to ask if there was any reason the software wouldn't be allowed access and he said it depends how it's doing it. It's just ftping though isn't it nothing fancy?

Offline niko

  • syzygy
  • Global Moderator
  • Posts: 24,205
  • Crystal Ball broken! Please post the URL.
  • Northern California, U.S.A.
    • http://www.realweatherstation.com
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #5 on: January 23, 2008, 02:11:42 PM »
If you can get to the ftp server login from the command prompt (the cmd test above) then you should be able to get to it with WD. The 0.0.0.0 error shows that WD's FTP isn't getting any connection to the internet. Please post a screen capture of the "connections" tab of the FTP set up.

Offline thedentaltourist

  • Posts: 14
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #6 on: January 24, 2008, 10:58:14 AM »
Well miraculously it all seems to be working. Don't ask me what I did but it seems to be working ...well at least information is being supplied to wdlive which was the point of the exercise. the web page for weather display however doesn't update yet.  :)

Offline 1006

  • Posts: 115
  • MALTA
    • http://www.sananton.edu.mt/weatherstation
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #7 on: February 27, 2008, 08:35:25 AM »
Hi there,

I seem to be having the same problem!

I had to change the link of the FTP and i inputted it in the FTP conections, and now its giving me this error:

ERROR: 11004: [11004] Valid name, no data record (check DNS setup) at time/date

any idea how i can fix it ?

Offline 1006

  • Posts: 115
  • MALTA
    • http://www.sananton.edu.mt/weatherstation
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #8 on: February 27, 2008, 08:37:36 AM »
Ok i found out the problem, if you guys get this problem, all you need to do is take off the ftp:// in the  FTP host settings

Offline fireman

  • Posts: 31
  • Bucks County
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #9 on: June 13, 2009, 11:31:30 PM »
Ok i found out the problem, if you guys get this problem, all you need to do is take off the ftp:// in the  FTP host settings
Where would I find the above.  Also is this why I'm not getting the email weather reports and warnings.  Also I'm running no-ip.com on my network, so this will have a different IP address than the computer has.

Offline Weather Display

  • Posts: 74,411
  • Davis VP1
  • New Zealand
    • Weather Display
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #10 on: June 14, 2009, 04:12:30 AM »
check your ftp connection setup in the control panel, ftp/internet setup, connections setup
for the email, what shows in the ftplogfull.txt after doing a test email send

Offline fireman

  • Posts: 31
  • Bucks County
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #11 on: June 15, 2009, 09:28:23 AM »
Here is what is in the ftplogfull.txt after I push the test on the email
*******list of files uploaded********
Connecting to mail server.

Connected.
220-host35.hostmonster.com ESMTP Exim 4.69 #1 Mon, 15 Jun 2009 04:26:30 -0600
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.
EHLO owner-7crwew3tj
250-host35.hostmonster.com Hello pool-71-123-40-100.phlapa.fios.verizon.net
[71.123.40.100]
250-SIZE 52428800
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP
AUTH LOGIN
334 VXNlcm5hbWU6
dHN0ZWluZXI=
334 UGFzc3dvcmQ6
ZmlyZWZpbG1z
535 Incorrect authentication data
*******actual messages from upload session********
***Start Time/date***:6:27:21 AM 6/15/2009
paz069.txt
allentown.txt
philadelphia.txt
Permanent connection selected
Permanent connection, will do ftp now
Checking for what else to do...
there are 1 more things to do
Sending Weather Report Email, auth
Connecting to mail server.
Connected.
220-host35.hostmonster.com ESMTP Exim 4.69 #1 Mon, 15 Jun 2009 04:26:30 -0600
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.
EHLO owner-7crwew3tj
250-host35.hostmonster.com Hello pool-71-123-40-100.phlapa.fios.verizon.net
[71.123.40.100]
250-SIZE 52428800
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP
AUTH LOGIN
334 VXNlcm5hbWU6
dHN0ZWluZXI=
334 UGFzc3dvcmQ6
ZmlyZWZpbG1z
535 Incorrect authentication data
161: SMTP protocol error. 535 Incorrect authentication data.
Finshed email agenda
Finished email agenda, no FTP items to do...
Doing abort procedure/program close...

Offline Weather Display

  • Posts: 74,411
  • Davis VP1
  • New Zealand
    • Weather Display
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #12 on: June 15, 2009, 09:42:03 AM »
Quote
535 Incorrect authentication data

check  you have the username/password set correctly

Offline fireman

  • Posts: 31
  • Bucks County
Re: The RemoteHost address is invalid (0.0.0.0).
« Reply #13 on: June 15, 2009, 11:45:46 PM »
check  you have the username/password set correctly
Boy do I feel dumb, This morning after making this post and beating my head against the wall, trying to figure out what is going wrong here.  Well I actually re-read carefully what I posted.  I noticed that it said Auth rejected.  So I went back and checked my PW and Login and sure enough it was wrong.  I fixed it to the correct ones and low and behold I started getting emails. So thanks for the help.

 

cumulus