cloudy cloudy

Author Topic: I've paid for a subscription, but my account isn't working yet. Why?  (Read 6649 times)

0 Members and 1 Guest are viewing this topic.

Offline administrator

  • Administrator
  • Posts: 10,824
  • Get answers to your questions - use Forum SEARCH!
  • Blackpool, UK
    • Weather-Watch.com
The time between your payment being made and your account becoming active depends on three main things...

1) How you've paid. If you pay by eCheque or some other form of payment which takes a while to clear, then Paypal won't send payment details through until the payment has cleared. I've seen this take up to 7 days in some cases.

2) Once the payment has cleared how long it takes Paypal to send the details through. This is usually fairly quick, but occasionally can take a 5-10 minutes.

3) Once payment details are received there is a batch job on the MML server which runs every 15 minutes to set up the accounts for operation. If the payment arrives seconds after the last run completed it takes nearly 15 minutes for your account to be fully configured. However, like buses arriving at a bus stop, on average you'll only wait 7.5 minutes.

So from 'payment' to 'account operational' can take anything from 30 seconds to 7 days! The only part of this that we can change is the final delay of up to 15 minutes. I'll look at this at some point, but for most people this average delay of around 7.5 minutes isn't a huge problem.
Chris
Weather Forum Administrator

 

cumulus